Results 1 to 10 of 10
Discuss Suddenly (while walking on the street) got "no sim card installed" 2G, FW 2.1 at the General - Hackint0sh.org; Hi, Today, while walking on the street a few seconds after making a phone call, ...
  1. #1
    Professional Array

    Join Date
    Aug 2006
    Posts
    84
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Exclamation Suddenly (while walking on the street) got "no sim card installed" 2G, FW 2.1

    Hi,

    Today, while walking on the street a few seconds after making a phone call, my iPhone showed a message "no sim card installed". I tried removing and reinserting the sim card, restoring to my previously pwned 2.1 firmware file, restarted the phone, airplae mode on/off, but nothing works...

    Does anyone knowns anything that's worth a try, r does anyone recognize the problem?

    To summarize:

    - Suddenly got a "no sim", iPhone worked perfectly for weeks.
    - FW 2.1, unlocked with pwnage.
    - First generation - old - iPhone.
    - Wifi works

    Thanks in advance!



  2. #2
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    did u ever use a simproxy on the iphone? i.e turbosim, universal sim, rebel sim....etc

  3. #3
    Professional Array

    Join Date
    Aug 2006
    Posts
    84
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    Quote Originally Posted by hussain93 View Post
    did u ever use a simproxy on the iphone? i.e turbosim, universal sim, rebel sim....etc
    Nope, never did. It's one of the first first gen iPhones with bootloader 3.9, so I was always able to use a software unlock. Never used ziphone btw.

  4. #4
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    then maybe something went loose in the sim connectors, i really don't know i thought it was because of the simproxy because some of my friends had such issues after using them, the connector became loose or something

  5. #5
    Professional Array

    Join Date
    Aug 2006
    Posts
    84
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    OK, just got my hands on another phone and simcard and it turns out that the problem isn't with the iPhone, but with my SIM card: In other phones it gives the same error message, and another SIM card works perfectly in my iPhone...

    Guess I have to call my operator about this, or does anyone know some magic SIM card trick to get it working again?


  6. #6
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by profit42 View Post
    OK, just got my hands on another phone and simcard and it turns out that the problem isn't with the iPhone, but with my SIM card: In other phones it gives the same error message, and another SIM card works perfectly in my iPhone...

    Guess I have to call my operator about this, or does anyone know some magic SIM card trick to get it working again?
    Forget about that, exept trying to clean it with a soft tissue.
    I'd always go for a replacement if the simcard is the reason.
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  7. #7
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by profit42 View Post
    OK, just got my hands on another phone and simcard and it turns out that the problem isn't with the iPhone, but with my SIM card: In other phones it gives the same error message, and another SIM card works perfectly in my iPhone...

    Guess I have to call my operator about this, or does anyone know some magic SIM card trick to get it working again?
    good to hear that ur phone is functional, anyway just go to ur operator and they will replace it for u. In my country if the sim is not working they will replace it for free, maybe they will not charge u

  8. #8
    Rookie Array

    Join Date
    Jan 2009
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I highly suggest doing a restore in iTunes and allow it to update your phone. You should see the 'Invalid SIM' message, then use quickpwn (which has been updated for 2.2.1!!!), to unlock.

    I was having the same problem, and this worked for me. I think there are some messed up ipsw floating about on torrents, and, since pwnage is only available for Mac, a lot of people have been downloading and using them.

    Quickpwn, IMHO, is better, because it only makes the needed changes and is direct from source (as opposed to shady torrent).

    -b

    PS Do not bother putting stuff behind your SIM to increase contact. This is almost never the issue, and is more likely to cause physical problems later.

  9. #9
    Board Hero Array

    Join Date
    Nov 2007
    Location
    Mustang Ridge, Texas, United States
    Posts
    1,169
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    65

    Default

    ok i had a problem exactly like that my tmobile sim crapped out for some reason so i tried everything... took the sim in and they tested it and it was fried, so just skip the bs and get a new sim (if the guy working there likes your phone you might get it free of charge) after that pop the sim in and it should work perfectly

    ps, dont post in the thread if you havent read it entirely or youll end up confusing people
    Get the latest info for NoAccSplash Here
    Currently it should work on iOS 4.x - 6.x
    If you'd like to help extend its functionality, the source is also available.

  10. #10
    Professional Array

    Join Date
    Aug 2006
    Posts
    84
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    truehybridx: Yeah, I called my operator yesterday and they send me a new SIM free of charge, which I'll recieve today hopefully!

    Thanks for all the help guys, looks like the problem has been solved!


 

 

Similar Threads

  1. [Problem] "no sim card installed" message
    By super384 in forum General
    Replies: 7
    Last Post: 11-28-2008, 01:05 PM
  2. [1.1.4] NO error ("No SIM Card Installed") but no signal
    By BigDaddyK in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 03-18-2008, 06:07 AM
  3. Replies: 9
    Last Post: 02-12-2008, 05:50 AM
  4. Replies: 3
    Last Post: 11-16-2007, 11:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:51 AM.
twitter, follow us!