Results 1 to 6 of 6
Discuss Strange baseband update problem at the General - Hackint0sh.org; Hello, I recently bought a second-hand iPhone 2G with 1.1.4 installed on it. Then i ...
  1. #1
    Newbie Array

    Join Date
    Jan 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Strange baseband update problem

    Hello, I recently bought a second-hand iPhone 2G with 1.1.4 installed on it.

    Then i tried to update it to fw 2.2, but it came ot with 1002 error.
    Since i was new i got digging on how to restore to 1.1.4 just to get something working.
    I tried the downgrade procedure, but still - 1002, 1015 ... all kinds of 10xx errors

    So after some digging/testing i found that it was problem with the baseband - it couldn't be flashed on the device. I then started testing (a bit chaotically, but still...) - i got working 1.1.4 by using iLiberty+ payload: Fix no wifi, no bluetooth, no signal. Then i started trying to flash 04 05 04 baseband (2.2's baseband) to the device... no luck! It just refused to update the baseband.
    It came up with some errors about wrong checksums during flashing (I have posted a link to logfile at the end of the post). So i went on trying to flash some kind of a baseband - tried to restore to 1.1.1, 1.1.2, 1.1.3 .... still - the baseband problem remains - (1002 errors).
    Then i came up with the genius idea to update the baseband by hand - I got 1.1.4 working again and with iph tunnel connected to the phone and started trying: bbupdater -f xx.fls -e yy.eep with every baseband i had available - the result was wrong checksums.
    Since i have previously installed bootneuter i found that it had it own bbupdater. I tried with it too - it didn't complain about checksums, but still no luck - it just cycles trying to flash the baseband and it doesn't (you can see in the log file).
    Then i tried the dev-team simple unlock thingy (dd if=/dev/zero....) and tried flashing again with every baseband listed on the devteam list with simple unlock - this time it said that checksums verified, but still the baseband wasn't updated.
    Then i tried to get 1.1.4 working again and all i ran was to delete baseband using KiPhone and then just using iLiberty+ payload "Fix no signal, no wifi, no bluetooth" which seems to flash the baseband 04 04 05G to the phone and guess what - it succeeds.

    So now to summarize the things from above:
    • The phone works ONLY on 1.1.4 and baseband 04 04 05 (provided by the iLiberty payload "Fix no signal, no wifi, no bluetooth".
    • Trying to flash any baseband is no luck situation... it just doesn't flash it.



    A thing to note:
    using kiphone it always succeeds to erase and downgrade baseband. Is there a version that instead of downgrading ... upgrades the baseband ?!

    http://bisko.be/iph - ipl5.log and ipl6.log (they are logs from two consequential updates to 2.2 (ipl5 is 1.1.4->2.2, ipl6 is 2.2->2.2)



  2. #2
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    What happened when you put the iphone in DFU mode and restore with 2.2 fw ?
    ** If you just want to support hackint0sh.org with a donation click here **

  3. #3
    Newbie Array

    Join Date
    Jan 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Doh, I feel like I am starting to cry

    In DFU it happens the same thing - the bar filled up and will stay there for an hour more, trying to flash the baseband ... and nothing will happen I am leaving it to flash and going to bed to get some sleep.

    Some notes:

    Before trying to DFUupdate 2.2 to 2.2 i tried to unlock it with QuickPwn - still no luck, BootNeuter came up with error 46... supposedly because it cannot flash the baseband. After that i just had a nice fancy iPod touch (no modem version in the settings menu)

    And one thing i am planning for tomorrow - what if i restore to 1.1.4 and unlock/activate/jailbreak with ZiPhone ? As i used iLiberty since the first bad flash, but ZiPhone was used by the previous owner several times. But i don't know how ZiPhone's unlock works, and don't know if it will reflash the baseband....


    Btw I think it could be some kind of hardware problem. It seems like the baseband chip doesn't allow writing to certain locations.
    Last edited by unrealnet; 01-11-2009 at 02:50 AM.

  4. #4
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by unrealnet View Post
    Doh, I feel like I am starting to cry

    In DFU it happens the same thing - the bar filled up and will stay there for an hour more, trying to flash the baseband ... and nothing will happen I am leaving it to flash and going to bed to get some sleep.

    Some notes:

    Before trying to DFUupdate 2.2 to 2.2 i tried to unlock it with QuickPwn - still no luck, BootNeuter came up with error 46... supposedly because it cannot flash the baseband. After that i just had a nice fancy iPod touch (no modem version in the settings menu)

    And one thing i am planning for tomorrow - what if i restore to 1.1.4 and unlock/activate/jailbreak with ZiPhone ? As i used iLiberty since the first bad flash, but ZiPhone was used by the previous owner several times. But i don't know how ZiPhone's unlock works, and don't know if it will reflash the baseband....


    Btw I think it could be some kind of hardware problem. It seems like the baseband chip doesn't allow writing to certain locations.
    since the former user used ziphone, then most probably it is beacause of it. Ziphone can damage ur baseband and that's why ur having problems, so no DO NOT USE ZIPHONE!!! it will cause more damage than it already has done.

  5. #5
    Newbie Array

    Join Date
    Jan 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    The problem turned out to be hardware....

    The baseband chip was bugged and the only baseband that could be written was the thingy from iLiberty (fix no signal, no wifi, no bluetooth).

    So i went on flashing 2.0.2 by removing the baseband update and leaving it working with the old baseband ... and guess what - it worked


  6. #6
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by unrealnet View Post
    The problem turned out to be hardware....

    The baseband chip was bugged and the only baseband that could be written was the thingy from iLiberty (fix no signal, no wifi, no bluetooth).

    So i went on flashing 2.0.2 by removing the baseband update and leaving it working with the old baseband ... and guess what - it worked
    good to hear that and trust me the cause for the damage to ur baseband is from ziphone, dont ever use it

 

 

Similar Threads

  1. Replies: 6
    Last Post: 12-29-2011, 06:33 PM
  2. Replies: 5
    Last Post: 11-29-2011, 11:24 PM
  3. Replies: 0
    Last Post: 02-05-2008, 01:35 PM
  4. Replies: 8
    Last Post: 02-01-2008, 05:26 PM
  5. Replies: 0
    Last Post: 01-31-2008, 03:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:08 AM.
twitter, follow us!