Results 1 to 9 of 9
Discuss SSH Connection crashes after entering 3 characters! at the General - Hackint0sh.org; Hi, I've got a serious problem. If I enter 3 characters in an ssh session ...
  1. #1
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    174
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default SSH Connection crashes after entering 3 characters!

    Hi,

    I've got a serious problem.

    If I enter 3 characters in an ssh session to my iphone from either the mac os x terminal, putty or the vt100 terminal on the iphone (I wonder why?!), the connection crashes, or the the vt100 terminal says something like "process completed".

    I revirginised successfully by following the tutorial by xadnanx, I don't know if this is in any relation.

    I installed dropbear ssh by using independence, since then I can't use open ssh anymore.

    Please, help me!



  2. #2
    Newbie Array

    Join Date
    Sep 2007
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i am having the same problem... please help

    Quote Originally Posted by Lenuam View Post
    Hi,

    I've got a serious problem.

    If I enter 3 characters in an ssh session to my iphone from either the mac os x terminal, putty or the vt100 terminal on the iphone (I wonder why?!), the connection crashes, or the the vt100 terminal says something like "process completed".

    I revirginised successfully by following the tutorial by xadnanx, I don't know if this is in any relation.

    I installed dropbear ssh by using independence, since then I can't use open ssh anymore.

    Please, help me!

  3. #3
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    174
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    At least I'm not alone .

    I noticed it when I wanted to use norz to check if my seczone is filled with zeros now =/.

    If the only solution is a 1.1.1 restore, does the unlock with anysim 1.1.1 survive the restore at least?

    Oh, and is this problem related to IPSF? Cause I heard about that somewhere...

  4. #4
    Newbie Array

    Join Date
    Aug 2007
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by samho1976 View Post
    i am having the same problem... please help
    Maybe you had an old version of ssh when you first unlocked the phone and installed the BSD subsystem from Installer.app on top of it. I had just the same problem.

    Just reinstall OpenSSH from Installer.app and everything will work fine again.

  5. #5
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    174
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    Unfortunately, that doesn't work =/.

    Does anysim 1.1.1 survive a restore?


  6. #6
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    103
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    Yup... it does... The baseband is not overwritten because the version is not newer in the restore image.
    _______________________
    Working 2.0 Beta unlocked with Pwnage Tool
    from 1.1.4 Ziphone
    from 1.1.3
    from 1.1.2
    from 1.1.1
    from 1.0.2. Hw Unlocked thanx to Geohot.
    :hack:

  7. #7
    Developer Array

    Join Date
    Sep 2007
    Location
    Germany
    Posts
    227
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Just reinstall the BSD Subsystem in installer, this should solve the problem.

  8. #8
    Professional Array

    Join Date
    Jul 2007
    Location
    Austria
    Posts
    72
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    had the same problem today and found a solution somewhere here in the forum.
    reinstalling SSH (via Independence) or OpenSSH via Installer didn't help me.
    read my blog entry here (it's in german), this probably helps: http://www.apfelei.com/archives/7-SS...on-allein.html

    short version in english:
    download from iphone and edit /etc/master.passwd and find the line starting with "root:"
    at the end you find this
    ...System Administrator:/var/root:/bin/sh
    replace it with this:
    ...System Administrator:/var/root:/bin/csh

    save the file and upload it back to the iphone. that should help you!

  9. #9
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    174
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    Thanks for the help!
    But now I'm already restoring

 

 

Similar Threads

  1. Entering the stream
    By superCG in forum Redsn0w
    Replies: 6
    Last Post: 03-15-2011, 12:31 AM
  2. Keyboard Characters
    By Hal9000 in forum General
    Replies: 89
    Last Post: 01-22-2009, 10:59 AM
  3. Replies: 1
    Last Post: 05-08-2008, 04:51 PM
  4. [REQ] SMS - count Characters?
    By Sacharon in forum Free Toolchain Software (Cydia App's)
    Replies: 6
    Last Post: 04-26-2008, 10:46 AM
  5. sms with more than 160 characters
    By Phylar in forum General
    Replies: 5
    Last Post: 09-14-2007, 09:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:42 AM.
twitter, follow us!