Results 1 to 7 of 7
Discuss Please Help me with my iPhones soundproblem at the General - Hackint0sh.org; Hello all! I bought a used iPhone 2 weeks ago and now I have some ...
  1. #1
    Newbie Array

    Join Date
    Jan 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Please Help me with my iPhones soundproblem

    Hello all!

    I bought a used iPhone 2 weeks ago and now I have some trouble with the bottom headspeaker, and I seek your advice what to do.

    First of all, phone was working perfect with a sim-card with Telia (The exclusive operator in Sweden which the phone is locked to).
    But I want to use my other operator and got told to jailbreak and install a software called yellowsn0w. This was easy and everything was fine. 2 days after this, suddenly the bottom speaker quit working. I've checked the soundswitch on the upper side and the volume. Asked on a Swedish forum and they told me about the headset -"bug", that the phone still think it is plugged in. Tried plugging/unplugging loads of time, cleaned the jacket, but it wasn't really dirty after all. No success

    RESTORED my iphone via iTunes, and still NO SOUND. 2 days after this, back to the Telia SIM-card, all of a sudden while I was playing a game, *poof*, the sound was back on!

    This was last Sunday and I was about to take the phone to the store. Now I didn't have to!

    Got home from work, jailbreaked and installed yell0wsn0w again. All was fine. Installed some programs (bossprefs winterboard etc..) and was listening to some music through my headphones again. Unplugged them and NO SOUND through the speaker.

    Although calling works great, they can hear me and I can hear them. Everything works except the bottom speaker.

    Today at work I was looking around at the call signals and got sound from the bottom speaker for 1 second, then it disappeared again, with no luck reproducing it.

    Tried to shake and tap the phone allover but no luck.

    PLEASE, please I beg you for advice what to do.

    Broken hardware?
    Headphonejacketbug?
    Softwarebug from jailbreaking?


    Most sincerely
    and excuse my English


    edit: I have tried resetting with home+power, and cleared all settings



  2. #2
    Newbie Array

    Join Date
    Sep 2008
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I encountered a sound problem some months ago which is somewhat same as yours. I could only listen to music by my earphone then. But once when I was listenning to a song I unplugged it for fun and then found that the volume was turned off immediately. Then I turned up the volume and the bottom bottom worked. I dont know why,but since then it has been played now are working properly. I hope it can be useful to you.
    Good luck.
    Last edited by pingwwh; 01-14-2009 at 07:10 AM.

  3. #3
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    174
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    The "bug" that you talk about affected 2G iPhones. I haven't heard of 3G phones having the same problem. It doesn't sound like there is any pattern to when the sound cuts out. It sounds like you just have a loose connector. Try pushing on the bottom left corner of the LCD screen. That is where the connector for the speaker is. If that seems to make it work. Then just take the screen off and re-seat the connector. I've noticed that the connector for the speaker on some phones get stuck to the LCD and a drop might cause the connector to come loose. Hope this helps

  4. #4
    Senior Professional Array

    Join Date
    Sep 2008
    Posts
    221
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    am sure it is a headphone bug or whatever they call it, since it happens after plugging in and plugging out the headphones. Search the hardware section in this forum and u may find some answers.

    cheers

  5. #5
    Newbie Array

    Join Date
    Jan 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    reason why I don't think it is the headphonesbug is that appearently people in the other end during a phonecall shouldn't be able to hear you....

    anyway.. i returned the phone for service at the store today, hope they cant detect the jailbreaking+yellowsn0w there after restoring to facctorymode ;X.

    I will give info here when service is done whether im fcked or not


  6. #6
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    381
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    I dont think its the headphone bug either

    I have a 3G unlocked with yellowsn0w and recently I was listening to pandora thru the headphone jack, which happens to go to a cassete in my Van, and plays thru the vehicle stereo system speakers...

    I pulled the jack without quitting pandora

    after that, I could only make phone calls on speakerphone, otherwise I could not hear the person I was calling talking on the iPhone handset earspeaker

    I then put the phone to sleep and double tapped home, which brings up iPod volume control and found the volume was way down low, and when I turned it up, I could hear music. A song from my iPod was in Play mode. (caused by pulling the plug on Pandora? not sure)

    I plugged the headphone jack in, heard music thru the car stereo, paused the song in iPod, and after that I can make normal phone calls, without the speakerphone, and hear thru the earspeaker.

    1. pulling the headphone jack when iPod or Pandora is in play mode, is the cause of the iPhone handset earspeaker not working

    2. the fix is to go into iPod, music playing with headphone jack plugged in, and Pause the music, Before pulling the headphone jack out

    after that, for me, normal telephone earspeaker returns

    (note, possibly unrelated, recently I could not turn on my Bluetooth toggle on the iPhone, need to confirm if that was related, bluetooth currently works normally, I think it got fixed when the ear speaker came back online by pausing iPod music and quitting Pandora before pulling the jack)
    Last edited by jon_slider; 01-18-2009 at 04:36 AM.

  7. #7
    Newbie Array

    Join Date
    Apr 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    sorry if this question has been answered before but i couldent find the anwser. (2g 16g) But sometimes my iphone wont play my music on the ipod tab. But my ringtons always play with sound. I thought kate was the problem so i restored my iphone, and know its not installed.
    Is there a 2g bug for sound?? and how do i fix it?? Thanks.

 

 

Similar Threads

  1. soundproblem AC97+USB SOUND
    By macnoobi in forum Hardware
    Replies: 1
    Last Post: 01-04-2011, 09:33 PM
  2. [FS] 8 Gb iphones and 16 GB Iphones Worldwide Shipping
    By shaneel786 in forum Flea Market
    Replies: 12
    Last Post: 05-08-2008, 09:17 PM
  3. [FS] 3 16GB Iphones and 2 8gb iphones
    By shaneel786 in forum Flea Market
    Replies: 0
    Last Post: 04-28-2008, 04:09 PM
  4. Replies: 0
    Last Post: 03-09-2008, 12:48 PM
  5. Replies: 3
    Last Post: 10-12-2007, 12:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:44 AM.
twitter, follow us!