Page 1 of 5 12345 LastLast
Results 1 to 10 of 41
Discuss iPhone stuck in headset mode - no sound from speaker at the General - Hackint0sh.org; Hi Guys, My iPhone is stuck in a mode where it thinks the headset is ...
  1. #1
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    Melbourne Australia
    Posts
    302
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    22

    Default iPhone stuck in headset mode - no sound from speaker

    Hi Guys,

    My iPhone is stuck in a mode where it thinks the headset is still plugged in.

    I cant get any sounds through the speaker. Cant hear sms or emails arrive. If the phone rings i hear it but pple cant hear me or i cant hear them.

    The phone works fine with the headphones plugged in.

    I have tried all the usual solutions, inserted and removed the headset (at least 50 times)
    Soft reboot
    full restore

    Nothing seems to work. I have searched on this and it seems to be a well know issue but there doesnt seem to be any firm solutions that i can find to fix the problem

    I am in australia, so returning to Apple is not an option. Does anyone have any suggestions?



  2. #2
    Respected Professional Array

    Join Date
    Oct 2007
    Posts
    617
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    38

    Default

    speaker may be blown

    dell xps m1710 laptop its really pretty
    core 2 duo t7600G @ 2.83ghz
    4gb ram
    nvidia 512mb 7950 gtx
    160gb 7200rpm

  3. #3
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    Melbourne Australia
    Posts
    302
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    22

    Default

    no the speaker is not blown. I can hear the phone ring. But the phone thinks the headset is plugged in all the time.

    I can also answer calls by speaker, so i know the speaker is operational. Its the headset issue

  4. #4
    Rookie Array

    Join Date
    Sep 2007
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Plug and unplug the headphone jack into the iphone fast a couple of times. Sometimes the iphone thinks that the headphone is still plugged in when it is not.


    Allan

  5. #5
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    Melbourne Australia
    Posts
    302
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    22

    Default

    Yep Allan, tried that... about 50 times to no avail.


  6. #6
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    155
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    I had the exact same problem what i did what plug the phone into the dock with the headphones in and make a call, during the call take the headphones out, you should now not be able to hear anything or it should be coming out of the loud speaker anyway end the call with the headphones out and keep the phone in the dock turn the phone off then on still in the dock and it should be fine take it out of the dock and it should work.

  7. #7
    Professional Array iDean's Avatar

    Join Date
    Sep 2007
    Posts
    91
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    I am having the exact same problem, did you fix it yet?

  8. #8
    Professional Array iDean's Avatar

    Join Date
    Sep 2007
    Posts
    91
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    I just found this,

    http://discussions.apple.com/thread....957&tstart=480

    after a couple tries it worked, I was really scared there for a second.

  9. #9
    Newbie Array

    Join Date
    Jul 2007
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I had a similar problem where the earpiece would not have any sound. The speakerphone and headphones works fine.

    The solution I found was to use a small Qtip dipped in a little alcohol (95% if possible) then to just stick it into the earphone jack. Once I did that and rebooted, the earpiece sound came back again.

    You'll have to clean the earphone jack pretty good otherwise the disappearing earpiece sound may occur again.

    Hope this helps.

  10. #10
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    Melbourne Australia
    Posts
    302
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    22

    Default

    i have tried al of these and nothing works.

    It looks like i will have to replace the headphone socket


 

 
Page 1 of 5 12345 LastLast

Similar Threads

  1. iPhone stuck on Safe Mode, won't load up normal mode?
    By CaptainFantastic in forum iPhone 3GS
    Replies: 4
    Last Post: 09-09-2011, 10:02 AM
  2. iPhone 4 stuck in speaker mode
    By computergeek008 in forum iPhone 4
    Replies: 3
    Last Post: 02-09-2011, 08:49 AM
  3. MacNN: Sound ID Bluetooth headset gets own iPhone app
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 05-24-2010, 08:10 PM
  4. Replies: 19
    Last Post: 10-11-2008, 10:19 PM
  5. [Headset][Solution] headset mode only - No sound
    By woomwireless in forum Hardware
    Replies: 11
    Last Post: 03-12-2008, 11:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 10:11 AM.
twitter, follow us!