Results 1 to 2 of 2
Discuss Iphone "hard-lock" to AT&T - Possible cause of "No Service" issue at the General - Hackint0sh.org; Hi, The Iphone Dev Team has the following listed on the wiki for the "Past ...
  1. #1
    Rookie Array

    Join Date
    Sep 2007
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question Iphone "hard-lock" to AT&T - Possible cause of "No Service" issue

    Hi,
    The Iphone Dev Team has the following listed on the wiki for the "Past Progress" section of July 17th.

    Now the iPhone only has one lock, a network personalization lock. This lock means the MCC(US=310) and the MNC(AT&T=410) must match the first six digits of the SIM cards IMSI. This check is done in the baseband firmware itself. I'm not really sure where yet, but that isn't really relevant.

    The only thing standing in the way of an unlock is the baseband. All the other sim checks are known and can be patched out. We even know the AT command to do the unlock. It's 'AT+CLCK="PN",0,"xxxxxxxx"'. But good luck finding those x's. They are called the NCK, or Network Control Key, and are believed to be unique in everyones phone. Forget brute force(time impractical) and the obvious entries. If you still think bruteforce is a good idea, read this. Further, there is a limit of 3-10 unlock attempts per phone, after which the firmware will "hard-lock" itself to AT&T.


    • My question is is it possible to reset the baseband if it is already "hard-locked" to AT&T? (note: I have ran bbupdater -f ICE03.14.08_G.fls & bbupdater -e ICE03.14.08_G.eep, I have uloaded com.apple.CommCenter.plist, I have used the patched Lockdown file, etc...)

    • If it is, can somebody provide instructions?

    • Will a reset of the baseband "Un-Hard-Lock" the iphone from AT&T?


    I bought an iphone that was initially activated via AT&T contract. I attempted to activate & unlock it for use w/t-mobile which has been unsuccessful for the last 15 days. Have tried HW & SW methods over 20 times. Two common issues I get whith each different type of activation & unlocking:

    1. Even after successful activation, I am always getting "Waiting for AT&T Activation" message popping up on the IPhone
    2. Using both HW & SW unlocking methods the minicom AT+CLCK="PN",0,"00000000" command returns "Error"; however the "AT+CLCK="PN",2 command results in 0 & OK.
    Last edited by atresso; 09-15-2007 at 04:52 PM.



  2. #2
    Rookie Array

    Join Date
    Sep 2007
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Anybody has any thoughts on this?

 

 

Similar Threads

  1. "No Service", "Searching...", and "No SIM" after unlocking
    By kimmy527 in forum Ultrasn0w (3G(S)/iPhone 4 unlock)
    Replies: 2
    Last Post: 08-04-2010, 08:45 AM
  2. [Solved] "No Service", "Network Lost"
    By henryyan in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 06-07-2008, 10:46 AM
  3. [Bossprefs] anyway to add "auto-lock" service ?
    By asher_ungar in forum Free Toolchain Software (Cydia App's)
    Replies: 7
    Last Post: 04-08-2008, 10:41 AM
  4. "Unlock.app" can fix "no service","no wifi","IMEI 049.."
    By max9241 in forum iPhone "2G" (Rev. 1)
    Replies: 17
    Last Post: 11-11-2007, 04:12 PM
  5. Replies: 0
    Last Post: 10-02-2007, 04:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:27 AM.
twitter, follow us!