Results 1 to 10 of 10
Discuss iPhone 3G 3.1.3 tethering patch for custom carrier bundles at the General - Hackint0sh.org; Thank you to iPhone Devteam for 3.1.2 Patch, which I've been using to find the ...
  1. #1
    Senior Professional Array stonefred's Avatar

    Join Date
    Nov 2007
    Posts
    326
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    25

    Lightbulb iPhone 3G/3GS 3.1.3 tethering patch

    Thank you to iPhone Devteam for 3.1.2 Patch, which I've been using to find the new offsets! Thanks to saurik for Ldid!
    Last edited by stonefred; 02-24-2010 at 01:49 AM.
    Every time you Can Has, God kills a LOLcat.



  2. #2
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    165
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default About Commcenter patch

    Stonefred,

    Is This CommCenter patch data the same that was used for Commcenter 3.1.2?
    What I mean is if I use 3.1.2 CommCenter patch on 3.1.3 Commcenter will it work the same way?
    All your process is the same as for 3.1.2.

    cheers.
    3.0 :iPhone: unlocked (BL 3.9)
    3.0.1 :iPhone: Telcel 4.4 w/Tethering/MMS/VVM
    Mexico

    Want to enable Tethering on TELCEL MEX?: http://iph0ned.blogspot.com/

  3. #3
    Newbie Array

    Join Date
    Feb 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    now that 3GS 3.1.3 firmware can be jailbroken and works fine with snowbreeze, any chance we can see a updated commcenter patch for the 3GS? going on a photography trip to wales in a few days and I'd hate to be without net access!

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by retro View Post
    now that 3GS 3.1.3 firmware can be jailbroken and works fine with snowbreeze, any chance we can see a updated commcenter patch for the 3GS? going on a photography trip to wales in a few days and I'd hate to be without net access!
    The advice was to avoid 3.1.3 - especially for 3GS. There are zero new features and the security fixes are not essential.

    This release was mostly designed by Apple to "flush out" any exploits the jailbreaking community might have so that Apple can lock down OS 4.0 much tighter and avoid the chance that like 3.0 it will be jailbroken and unlocked straight away. The jailbreakers are not stupid and are recommending avoiding 3.1.3 because they don't want to play Apple's game and prematurely reveal any exploits they may or may not have.

    If you want to support the jailbreaking and unlocking scene, stay away from 3.1.3 and recommend everyone else stays away from it. The more people who upgrade accidentally and panic, the more noise that distracts from the real goal 4.x jailbroken within days of release.

    Maybe it is not so hard to update the tethering patch to 3.1.3, I have no idea how hard it is. However I know there is no real need for anyone to be running 3.1.3, there is a 3.1.2 tethering patch, jailbreak and unlock. Stay with that until 4.0 is released, seriously.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Newbie Array

    Join Date
    Feb 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    The advice was to avoid 3.1.3 - especially for 3GS. There are zero new features and the security fixes are not essential.

    This release was mostly designed by Apple to "flush out" any exploits the jailbreaking community might have so that Apple can lock down OS 4.0 much tighter and avoid the chance that like 3.0 it will be jailbroken and unlocked straight away. The jailbreakers are not stupid and are recommending avoiding 3.1.3 because they don't want to play Apple's game and prematurely reveal any exploits they may or may not have.

    If you want to support the jailbreaking and unlocking scene, stay away from 3.1.3 and recommend everyone else stays away from it. The more people who upgrade accidentally and panic, the more noise that distracts from the real goal 4.x jailbroken within days of release.

    Maybe it is not so hard to update the tethering patch to 3.1.3, I have no idea how hard it is. However I know there is no real need for anyone to be running 3.1.3, there is a 3.1.2 tethering patch, jailbreak and unlock. Stay with that until 4.0 is released, seriously.
    I agree with what you're saying there entirely. As my iPhone is officially unlocked by my carrier (O2) My only real concern is to stay jailbroken and tethering. The latest update of snowbreeze solves the jailbreak for 3.1.3, so no issue for the community there, and tethering for 3.1.3 should have zero impact on any jailbreaking as the exploits/mods are all unrelated.


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by retro View Post
    I agree with what you're saying there entirely. As my iPhone is officially unlocked by my carrier (O2) My only real concern is to stay jailbroken and tethering. The latest update of snowbreeze solves the jailbreak for 3.1.3, so no issue for the community there, and tethering for 3.1.3 should have zero impact on any jailbreaking as the exploits/mods are all unrelated.
    Sn0wbreeze is not something that I feel can be trusted, these guys don't have the skills to fully develop their own jailbreaks, sn0wbreeze is just devteam/planebeing's xpwn wrapped in a windows GUI. Sn0wbreeze was illegally distributing Apple's 2G baseband bootloaders (which redsn0w makes you search for and download separately). These are not actions that make me want to trust my iPhone with their software.

    Sounds like you are relatively safe (O2 offer legitimate unlocks, you likely have a 3.1.2 SHSH). I am also lucky (factory unlocked, 3.1.2 SHSH) Not everyone is so lucky.

    If you want to upgrade to 3.1.3, it is your personal decision. Don't feel it entitles you to force someone else to spend hours/days in IDA Pro working out which bytes to change to enable tethering again or any of the other useful patches/hacks already available and well tested under 3.1.2. I would suggest that this same time might be better used finding an iBoot exploit for use against iPhone OS 3.2 or 4.0 or a new 24kpwn exploit to allow untethered jailbreak again for all.

    Those who are involved in both making jailbreaks and providing free support for jailbreak/unlock have spent a lot of time dealing with thousands of "oops blacksn0w broke my wifi" and the thankfully easier "blackra1n broke youtube" and of course the "ooops I accidentally upgraded to 2.2.1 (or now 3.1.3) and lost my unlock"

    There is a new baseband (that may still exhibit the race condition that was breaking wifi for even legitimate - never unlocked or jailbroken iPhone owners) in 3.1.3. Only one app store app requires 3.1.3 (and only if you write in Japanese) there are no new APIs or end user features (except a more accurate battery display for the 3GS)

    I seriously recommend - stay on 3.1.2. Most 3GS owners have already learnt from the 3.1/3.1.2 era "accidental upgrades" geohot came to the rescue with blacksn0w but it came with an Apple worm (wifi bug). I hope that most 3GS users now having been burnt once will not be burnt again by such a minor update.
    Last edited by Olethros; 02-08-2010 at 07:02 AM.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Newbie Array

    Join Date
    Mar 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Post Accidentally Upgraded 3.1.3

    Please Help me I accidentally upgraded my iphone 3g to 3.1.3 and now it is stock in the itunes connect but as i have seen after downloading the said upgrade(3.1.3 firmware) I click the upgrade then it extracted but in some reasons while on the upgrade status an error occur.

    I dont think if its been upgraded or it canceled but when I connect it to the itunes there is no Software and all the applications are wiped out even the name of it is wiped out.

    What will I do and what will be my first move open it.

    Eventually after man trials it always stay in the itunes connect...,

    Please give me some steps or advice on what will be an appropriate way to just exit my iphone to itunes connect and if I can get to my oldest firmware which is 2.1.2

    Thnx again...,

  8. #8
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by lonlol View Post
    Please Help me I accidentally upgraded my iphone 3g to 3.1.3 and now it is stock in the itunes connect but as i have seen after downloading the said upgrade(3.1.3 firmware) I click the upgrade then it extracted but in some reasons while on the upgrade status an error occur.

    I dont think if its been upgraded or it canceled but when I connect it to the itunes there is no Software and all the applications are wiped out even the name of it is wiped out.

    What will I do and what will be my first move open it.

    Eventually after man trials it always stay in the itunes connect...,

    Please give me some steps or advice on what will be an appropriate way to just exit my iphone to itunes connect and if I can get to my oldest firmware which is 2.1.2
    What version of iTunes are you running? There never was an iPhone OS 2.1.2 for iPhone 3G. Did you mean 3.1.2?
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  9. #9
    Senior Professional Array

    Join Date
    Mar 2008
    Posts
    285
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    Quote Originally Posted by Olethros View Post
    The advice was to avoid 3.1.3 - especially for 3GS. There are zero new features and the security fixes are not essential.

    This release was mostly designed by Apple to "flush out" any exploits the jailbreaking community might have so that Apple can lock down OS 4.0 much tighter and avoid the chance that like 3.0 it will be jailbroken and unlocked straight away. The jailbreakers are not stupid and are recommending avoiding 3.1.3 because they don't want to play Apple's game and prematurely reveal any exploits they may or may not have.
    The problem is that more and more programs are requiring 3.1.3, not 3.1.2. And some developers maintain that there are important bug fixes in 3.1.3! So what can we do?
    Last edited by odysseus; 04-03-2010 at 03:19 PM.

  10. #10
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by odysseus View Post
    The problem is that more and more programs are requiring 3.1.3, not 3.1.2. And some developers maintain that there are important bug fixes in 3.1.3! So what can we do?
    There is a cydia tweak that allows 3.1.2 to pretend to be 3.1.3 for these 3.1.3 only apps from the AppStore
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!


 

 

LinkBacks (?)

  1. 03-14-2010, 06:39 PM
  2. ?????
    Refback Post #0
    03-01-2010, 04:37 PM
  3. 02-23-2010, 11:55 PM

Similar Threads

  1. Replies: 27
    Last Post: 02-12-2010, 12:25 AM
  2. How can I create ipcc file for my Carrier Bundles
    By HassanMarei in forum General
    Replies: 6
    Last Post: 07-21-2009, 03:02 PM
  3. build custom carrier bundles for 3.0 3G?
    By seseberg in forum iPhone 3G
    Replies: 5
    Last Post: 07-01-2009, 08:33 PM
  4. Replies: 12
    Last Post: 05-14-2008, 08:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:57 AM.
twitter, follow us!