Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss HELP! "software" problem kills internal microphone iPhone 2G at the General - Hackint0sh.org; Hi everyone! My first post here... I've been searching for an answer for a week ...
  1. #1
    Newbie Array

    Join Date
    May 2009
    Location
    Switzerland
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default HELP! "software" problem kills internal microphone iPhone 2G

    Hi everyone!

    My first post here...

    I've been searching for an answer for a week on the net and on many different forums, but haven't found any answers yet.

    Maybe someone here on the forum can help me out?

    Here is the problem:

    I have two iPhones 2G on my desk right now... One belongs to my wife, the other to my sister in law. 3 weeks ago, my sister in law's 2G "lost" the function of the internal microphone WHEN RECEIVING OR DIALING VOICE CALLS. The microphone works when you use the "Voice Memos" app from apple. It also works when you put the call on "speaker" mode. That is why I think it's not a hardware problem, since the mic seems to work with other apps. Hope you guys are following what I mean

    My wife's iPhone 2G had suddenly the same problem. I searched for answers on the web but couldn't find any answers as mentionned above. I then tried to reset the phone, with NO SUCCESS. After a few tries, I decided to restore the iPhone with the original 3.0 software, then I created a custom IPSW with PwnageTool and jailbroke it. IT WORKED!!!

    5 days later, with no reason, in the morning after answering a call, my wife tells me the others can't hear her at all, except if she is on speaker mode. And the quality is very bad (she seems far away). Holes are clean, iphone is clean, so it can't be anything blocking the mic. And again, the "Voice Memos" app has NO problem whatsoever to record sounds from the internal mic.

    I decided to restore the phone again (what a pain...) and the result this time was 0. Keeps having the problem. I even restored a few times on 3.0 and tried redsn0W with no success either unfortunately. I even upgraded to 3.0.1 and to 3.1 to see if there is any change, used redsn0w for 3.0.1 jalibreak and the newest Pwnage Tool for 3.1 jailbreak. I even reated 2 custom IPSW files, one with Bootloader 3.9 and the other with 4.6 (no clue if this should/could help, I just did since I am desperate...). Installing either the one or the other gives NO CHANGE at all. Internal microphone still works very well with "Voice Memos" app, but not at all when taking a call or when calling someone.

    I tried the "headphones" trick, plug in fast and plug out fast, but no changes . When I change the volume, it shows "ringer", NOT "ringer (headphones)", so I think the headphone jack problem can be ruled out!

    Yesterday I received my sis in law's 2G iPhone by mail, since I told her I managed to fix the problem last time. I tried all the steps mentionned above (taking hours and hours) with her 2G phone, no success

    Now I have to sad ladies asking me everyday if I was able to fix it, and I have to give them a negative answer...

    Obviously, going to an apple store or sending it is NO OPTION, since these are 2G iPhones (out of warranty) and I am based in Switzerland (weren't sold there...) I bought one in NYC 2 years ago and the other one in London 18 months ago.

    I tested the phones with 2 cell providers (thought maybe this would make a difference), Swisscom and Orange, but it obviously didn't...

    Could anyone be so kind and let me know if I'm totally stuck here? If there is a PROVEN solution? If this is a hardware or software issue? If there is a workaround?

    If anyone can help me solve the problem, I'm willing to make a little donation on your PayPal account, or invite you for a fresh beer next time you are in Switzerland!

    Thank you very much everyone for reading this post and for your constructive answers! And sorry for my english...

    iDriano



  2. #2
    Newbie Array

    Join Date
    May 2009
    Location
    Switzerland
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Seems like noone has an answer...? Am I the only one suffering from this major problem?

  3. #3
    Newbie Array

    Join Date
    Oct 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default You're not alone

    Hi,

    I have EXACTLY the same problem. I was using a 2g iphone, with the 2.0 firmware still, jailbroken and everything was working fine. I bought it long time ago in France (at the very first moment they arrived to Europe) and I'm living in Luxembourg. Suddenly, the internal mic stop working.

    Since I was giving my iPhone to my 1.5-year-old son, hoping to have a good excuse to by the 3gs , I thought it was him that put it in his mouth or something like that, causing an hardware problem. I bought the 3gs but I would like to fix the 2g so my wife can use it.

    I finally update the 2g to the latest version, 3.1.2 and the internal mic doesn't work but only for calling. Voice Memo works just fine.

    I have no idea of what can be causing the problem. I'm willing to use any solution, e.g., using any firmware even if it is very old, jailbroken or not, doesn't matter. i just want to make it work.

    I will try to downgrade the iPhone to older versions of firmware, trying to find one that works.

    By the way, do you have by any chance discovered a solution to this problem? I'm willing to pay a couple of beers too, and Luxembourg is not so far away from Switzerland...

  4. #4
    Newbie Array

    Join Date
    May 2009
    Location
    Switzerland
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi statman!

    Tried the same things as you did... To be honest, the only thing I did not do is downgrade... When I got the phone (and it worked), it was on 2.X, and about 2 or 3 weeks after I upgraded it on 3.0, the internal mic died... Sad thing is I upgraded it to 3.1.2 now (though it might solve... was more kind of a desperate move...), and I have absolutely NO CLUE how to downgrade from 3.1.2 to PRE 3.X firmware... Ideal would be the last 2.0.

    As soon as I find out, I'll post it.

    Regarding your kid putting the iphone in his mouth and damaging the hardware: maybe it's really what happened and my wife did the same??? ;-)

    No problem for the beers, you're welcome in CH as well... couple of LUX friends here.

    Best,

    iDriano

  5. #5
    Newbie Array

    Join Date
    May 2009
    Location
    Switzerland
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi everyone!

    No one has ever dealt with the problem we both have? I have even upgraded to 3.1.2 today and used blackra1n to jailbreak it, but without success... :-(

    Do you experts know if there is a way to rollback a 1st gen iPhone 2G from 3.1.2 to 2.x firmware?

    I think all the troubles began with the 3.0 firmware...

    Any advice?

    Thank you very much for your time!!! :-)

    iDriano


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Any 2G iPhone can downgrade all the way back to 1.0 firmware if they really want to.

    Grab the appropriate firmware from this list iClarified - iPhone - Where To Download iPhone Firmware Files From
    Put your iPhone in DFU mode
    Option (or shift on windows) restore using the firmware you downloaded.
    If you get any errors in the range 1011, 1013, 1015 ignore them. If you get errors 1601, 1602, 1600 check you actually got the iPhone into DFU mode and try again.

    Use quickpwn to both jailbreak and hacktivate and you should be fine.

    Worth a try to see if that fixes the problem. I doubt it will though.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Newbie Array

    Join Date
    Nov 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by iDriano View Post
    No one has ever dealt with the problem we both have?
    iDrano, i am having the same problem. my friend thought he'd bricked his 2G iPhone, but i managed to resurrect it to with the 3.1.2 firmware and blackra1n, thanks to Geohot.

    now i'm having a similar problem to you - the microphone does not work in voice calls, regardless of whether the phone is on external or internal speaker. the microphone does work in voice memo app.

    have you found a solution yet? does rolling back to 2.0 firmware change anything?

    i am looking forward to working out a solution to this problem together.

    cheers!
    jonny

  8. #8
    Newbie Array

    Join Date
    May 2009
    Location
    Switzerland
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi!

    Thank you very much for your answer!

    I'll try it this week and post the results... I doubt as well that it will work, but hey, it's worth a try. Otherwise I'll have 2 iPod Touches instead of iPhones..

    Best,

    iDriano

  9. #9
    Newbie Array

    Join Date
    Nov 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    UPDATE

    my friend was using his phone over the weekend and it mysteriously began working. as far as we recall, there was nothing that we did to the phone to have any effect on it; it just began to work again...

    this is quite bizarre!

  10. #10
    Newbie Array

    Join Date
    Feb 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Hope this works

    Hi All,

    This might sound crazy, however as nothing else has worked you all might as well try this.

    Steps.

    1. Connect the ear plugs which you all got with the iphone.
    2. Play any song on the iphone.
    3. un plug the ear plug while the song is on WITHOUT pausing or stopping it.
    4. 99% it wont pause which ideally it is supposed to.
    5. Now, continue to plug and un plug your ear plug till the songs automatically pauses.

    This might take about 2 to 4 minutes. Once youe iphone pauses, restart your phone and see the difference.

    Let me know if this works.

    Regards,
    HiT


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 03-03-2011, 01:40 AM
  2. MacNN: Skyfire app "sells out," kills servers, now unavailable
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 11-04-2010, 04:10 AM
  3. Replies: 1
    Last Post: 04-12-2009, 11:36 PM
  4. [2.0] Software for "home zone"/"house" icon?
    By haustier in forum Free Toolchain Software (Cydia App's)
    Replies: 1
    Last Post: 08-07-2008, 03:15 PM
  5. "Unlock.app" can fix "no service","no wifi","IMEI 049.."
    By max9241 in forum iPhone "2G" (Rev. 1)
    Replies: 17
    Last Post: 11-11-2007, 04:12 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 10:27 AM.
twitter, follow us!