Results 1 to 6 of 6
Discuss EDGE settigs disappeared after rebooting the iPhone at the General - Hackint0sh.org; For some strange reason after every reboot my iphone lose the EDGE settings... The problem ...
  1. #1
    Professional Array Children Of Doom's Avatar

    Join Date
    Aug 2007
    Location
    Somewhere in time
    Posts
    93
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Question EDGE settigs disappeared after rebooting the iPhone

    For some strange reason after every reboot my iphone lose the EDGE settings...

    The problem is that my carrier (vodafone) use blank settings for the connection and have a time rate, and not a traffic rate as other carrier...

    If I forget to use a fake server for the connection, my iphone bleed all the money from my prepaid contract...

    Anyone know whre is the config file for the EDGE connection?

    THNX!
    ---iPhone 8Gb 1.0.2 OOB Hw unlocked, verginized, updated to 1.1.1, updated to 1.1.2, soft updated to 1.1.3, Ziphone 1.1.4, Pwned 1.1.4, Pwned 2.0, Pwned 2.0.1, Quickpwn 2.2.1, Quickpwn 3.0--- iPhone 3gs 32 GB --- MBpro 15"---



  2. #2
    Professional Array Children Of Doom's Avatar

    Join Date
    Aug 2007
    Location
    Somewhere in time
    Posts
    93
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    found by myself...

    The solution was to SSH/SCP into the iPhone and edit the /var/root/Library/Preferences/com.apple.carrier.plist file.
    Just look for the section that specifies the APN settings and fill in the blanks appropriately, for example:


    Code:
    <array>
                    <dict>
                            <key>apn</key>
                            <string>your apn</string>
                            <key>password</key>
                            <string>your password</string>
                            <key>username</key>
                            <string>your username</string>
                    </dict>
                    <dict>
                            <key>apn</key>
                            <string>your apn</string>
                            <key>password</key>
                            <string>your password</string>
                            <key>username</key>
                            <string>your username</string>
                    </dict>
            </array>
    ---iPhone 8Gb 1.0.2 OOB Hw unlocked, verginized, updated to 1.1.1, updated to 1.1.2, soft updated to 1.1.3, Ziphone 1.1.4, Pwned 1.1.4, Pwned 2.0, Pwned 2.0.1, Quickpwn 2.2.1, Quickpwn 3.0--- iPhone 3gs 32 GB --- MBpro 15"---

  3. #3
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default

    Quote Originally Posted by Children Of Doom View Post
    found by myself...

    The solution was to SSH/SCP into the iPhone and edit the /var/root/Library/Preferences/com.apple.carrier.plist file.
    Just look for the section that specifies the APN settings and fill in the blanks appropriately, for example:


    Code:
    <array>
                    <dict>
                            <key>apn</key>
                            <string>your apn</string>
                            <key>password</key>
                            <string>your password</string>
                            <key>username</key>
                            <string>your username</string>
                    </dict>
                    <dict>
                            <key>apn</key>
                            <string>your apn</string>
                            <key>password</key>
                            <string>your password</string>
                            <key>username</key>
                            <string>your username</string>
                    </dict>
            </array>

    That is the symbolic link and any chages may end up being erased (depends if you edited the link or the actual target file, UnknownCarrier.plist).

    Check

    http://www.hackint0sh.org/forum/show...t=10965&page=2

    At post #17 for the right solution

    http://www.hackint0sh.org/forum/show...t=10965&page=2

  4. #4
    Newbie Array

    Join Date
    Aug 2007
    Location
    Germany (South)
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Worked great for me, too, thanks a lot :-)

    Christian

  5. #5
    Newbie Array

    Join Date
    Jan 2008
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Need Help Please!!!!! Aviegas Help!!!

    Hi there!!!

    I've been reading all this post and I've done everyting:
    I have a 1.1.2. unlocked with UltraSIM working with spanish carrier MOVISTAR.

    With the workpad, I created a MOVISTAR_ES.plist with all this code:

    PHP Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
        <key>AllowEDGEEditing</key>
        <true/>
        <key>BookmarkURLs</key>
        <array>
            <dict>
                <key>BookmarkName</key>
                <string>Movistar</string>
                <key>BookmarkURL</key>
                <string>http://www.movistar.es/</string>
            </dict>
        </array>
        <key>CarrierName</key>
        <string>movistar</string>
        <key>IntlDataRoamingSwitch</key>
        <true/>
        <key>MyAccountURL</key>
        <string>http://www.movistar.es/</string>
        <key>MyAccountURLTitle</key>
        <string>Movistar</string>
        <key>Services</key>
        <array>
            <dict>
                <key>ServiceCode</key>
                <string>609</string>
                <key>ServiceName</key>
                <string>Atencion al Cliente</string>
            </dict>
            <dict>
                <key>ServiceCode</key>
                <string>+34609100609</string>
                <key>ServiceName</key>
                <string>Atencion Cliente Extranjero</string>
            </dict>
            <dict>
                <key>ServiceCode</key>
                <string>123</string>
                <key>ServiceName</key>
                <string>Buzon de Voz</string>
            </dict>        
            <dict>
                <key>ServiceCode</key>
                <string>+34609123123</string>
                <key>ServiceName</key>
                <string>Buzon de Voz Extranjero</string>
            </dict>
            <dict>
                <key>ServiceCode</key>
                <string>666</string>
                <key>ServiceName</key>
                <string>Control de Consumo</string>
            </dict>        
            <dict>
                <key>ServiceCode</key>
                <string>404</string>
                <key>ServiceName</key>
                <string>Emocion Voz</string>
            </dict>
            <dict>
                <key>ServiceCode</key>
                <string>4636</string>
                <key>ServiceName</key>
                <string>Programa de Puntos</string>
            </dict>
        </array>
        <key>ShowCallForwarded</key>
        <false/>
        <key>ShowCallForwarding</key>
        <false/>
        <key>ShowDialAssist</key>
        <false/>
        <key>ShowTTY</key>
        <false/>
        <key>StockSymboli</key>
        <array>
            <dict>
                <key>symbol</key>
                <string>TEF.MC</string>
            </dict>
        </array>
        <key>SupportedSIMs</key>
        <array>
            <string>21407</string>
        </array>
        <key>SupportsNITZ</key>
        <true/>
        <key>VVMIgnoresIntlDataRoaming</key>
        <true/>
        <key>VisualVoicemailServiceName</key>
        <string>ACDS</string>
        <key>apns</key>
        <array>
            <dict>
                <key>apn</key>
                <string>movistar.es</string>
                <key>password</key>
                <string>MOVISTAR</string>
                <key>username</key>
                <string>MOVISTAR</string>
            </dict>
            <dict>
                <key>apn</key>
                <string>movistar.es</string>
                <key>password</key>
                <string>MOVISTAR</string>
                <key>username</key>
                <string>MOVISTAR</string>
            </dict>
        </array>
        <key>voicemail_context</key>
        <integer>1</integer>
    </dict>
    </plist>
    I saved it with extension plist instead of txt extension and upload it to my iphobe with ibrickr on /System/Library/Frameworks/CoreTelephony.framework/Support/

    I did the same with the CarrierMap.plist file.

    PHP Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
        <key>310150</key>
        <string>ATT_US.plist</string>
        <key>310170</key>
        <string>ATT_US.plist</string>
        <key>310180</key>
        <string>ATT_US.plist</string>
        <key>310380</key>
        <string>ATT_US.plist</string>
        <key>310410</key>
        <string>ATT_US.plist</string>
        <key>310980</key>
        <string>ATT_US.plist</string>
        <key>311180</key>
        <string>ATT_US.plist</string>
        <key>21407</key>
        <string>MOVISTAR_ES.plist</string>
    </dict>
    </plist>
    I did the same with the workpad, saving it as plist and uploading it to the iphone.

    I switched it of and on again, but nothing new happened. No access to EDGE settings menu. Nothing.

    What I'm doing wrong? Please help me!!!

    Thanx in advance from Madrid!
    Last edited by totet; 01-21-2008 at 08:45 PM.


  6. #6
    Rookie Array

    Join Date
    Aug 2007
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi

    the problem with the edge menu not being available is different to the issue of edge settings disappearing which is the topic of this thread.

    For the issue of the edge menu not being available you need to

    add
    <key>AllowEDGEEditing</key>
    <true/>

    to the appropriate provider (ATT_US - TMobile_Germany - 02_UK - Orange_France - TIM_Italy) .plist file for your handset (ie what it was originally before you hacked it, or what provider it thinks it belongs ot since updating the firmware)
    in root/system/library/frameworks/coretelphonyframework/support

    remember, dont look for the name of your current carrier, as the chances are they arent supported. Look for whatever authorised provider the device thinks it belongs to.

    as per the info in this following thread:
    http://www.hackint0sh.org/forum/showthread.php?t=18814

    regards

    cj

 

 

Similar Threads

  1. Rebooting my iPhone 3G
    By surprise me in forum iPhone 3G
    Replies: 1
    Last Post: 03-17-2011, 08:04 PM
  2. camera keeps rebooting iPhone.
    By dollface in forum Hardware
    Replies: 2
    Last Post: 02-07-2010, 03:50 PM
  3. Replies: 4
    Last Post: 07-02-2008, 07:41 PM
  4. Iphone freezing and rebooting
    By EEE202 in forum General
    Replies: 0
    Last Post: 02-05-2008, 03:04 PM
  5. The iPhone unlock 1.1.2 OTB in Berlin thread just disappeared?
    By matlock in forum iPhone "2G" (Rev. 1)
    Replies: 61
    Last Post: 12-05-2007, 06:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:17 PM.
twitter, follow us!