Results 1 to 4 of 4
Discuss EDGE anf DNS problem at the General - Hackint0sh.org; When I use EDGE, Safari can't open any URL with domain, IP address works. I ...
  1. #1
    Rookie Array

    Join Date
    Nov 2007
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default EDGE and DNS problem

    When I use EDGE, Safari can't open any URL with domain, IP address works. I check the DNS and found one of two DNS servers is down, I wonder why iPhone can't use the other one DNS server for resolve domain name. And I put other 2 DNS servers into /etc/resolv.conf or /var/run/resolv.conf and make no sense, Safari still can't open URL with domain name, any ideas?

    iPhone with firmware 1.0.2
    Last edited by paveo; 12-04-2007 at 07:32 AM.



  2. #2
    Rookie Array

    Join Date
    Oct 2007
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by paveo View Post
    When I use EDGE, Safari can't open any URL with domain, IP address works. I check the DNS and found one of two DNS servers is down, I wonder why iPhone can't use the other one DNS server for resolve domain name. And I put other 2 DNS servers into /etc/resolv.conf or /var/run/resolv.conf and make no sense, Safari still can't open URL with domain name, any ideas?

    iPhone with firmware 1.0.2
    It happens exactly the same to me. I've installed the DNSTools app and I was able to dig yahoo.com and dig google.com. After that safari found the websites but not using www.google.com but using http://64... Any ideas? I've also put a dns I know to work in the /etc/resolv.conf but nothing is working with that modification.

    Besides, no problem in name resolution using wifi.

    Thanks

  3. #3
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by alela View Post
    It happens exactly the same to me. I've installed the DNSTools app and I was able to dig yahoo.com and dig google.com. After that safari found the websites but not using www.google.com but using http://64... Any ideas? I've also put a dns I know to work in the /etc/resolv.conf but nothing is working with that modification.

    Besides, no problem in name resolution using wifi.

    Thanks
    That seems to be a problem for some ppl. The IP and DNS is assigned by EDGE/GPRS provider and to be found in /etc/resolv.conf (thats the symlink). I tried to change that one, but its always overwritten by the system. If the nameservers hang or suck, no go.

    Would be interesting if ppl with this problem could try it and we could find a way to set DNS when GPRS/EDGE is used. Sure this is no problem with wifi, this DNS is handeled by the Router or the iPhone's settings.

    volkspost
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  4. #4
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by alela View Post
    It happens exactly the same to me. I've installed the DNSTools app and I was able to dig yahoo.com and dig google.com. After that safari found the websites but not using www.google.com but using http://64... Any ideas? I've also put a dns I know to work in the /etc/resolv.conf but nothing is working with that modification.

    Besides, no problem in name resolution using wifi.

    Thanks
    Looke here
    http://hackint0sh.org/forum/showthread.php?t=34740
    this should work for you

    volkspost
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

 

 

Similar Threads

  1. Anyone having Problem with At&t EDGE?????
    By dannyws6 in forum General
    Replies: 2
    Last Post: 04-23-2008, 07:55 PM
  2. Replies: 4
    Last Post: 04-06-2008, 06:18 PM
  3. [1.1.3 OTB] EDGE problem
    By skanero in forum General
    Replies: 6
    Last Post: 03-12-2008, 01:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:56 AM.
twitter, follow us!