I read this thread and followed the instructions, with the exception of using iBrickr instead, and the downgrade worked! The thing is, I accidently downgraded to 1.0.1 instead of 1.1.1 so I do't known if downgrading to 1.1.1 works but I can confirm that a downgrade to 1.0.1 works. Also, DFU mode DOES work on 1.1.2...

http://www.hackint0sh.org/forum/show...877#post114877

That is the link to the thread