Results 1 to 9 of 9
Discuss Don't upgrade to 1.0.1 at the General - Hackint0sh.org; Hi all, I upgraded to firmware 1.0.1 on my iPhone, and now it's gone to ...
  1. #1
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    Australia
    Posts
    228
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default Don't upgrade to 1.0.1

    Hi all,

    I upgraded to firmware 1.0.1 on my iPhone, and now it's gone to sh*t. First it worked fine with my shiny new silvercard, but then it spat. So, I tried to reactivate it using the key I generated, and I got this:

    $ ./tool --activate a.plist
    iPhoneActivatorTool 1.0
    2007-08-20 17:13:50.417 tool[611] Found iPhone Device: 1
    2007-08-20 17:13:50.417 tool[611] Connecting...
    2007-08-20 17:13:50.423 tool[611] Checking Pairing...
    2007-08-20 17:13:50.434 tool[611] Starting device session...
    2007-08-20 17:13:50.521 tool[611] ActivationState: Unactivated
    2007-08-20 17:13:50.521 tool[611] Deactivating your iPhone...
    2007-08-20 17:13:50.540 tool[611] New ActivationState: Unactivated
    2007-08-20 17:13:50.540 tool[611] Activating your iPhone...
    InvalidActivationRecord
    2007-08-20 17:13:50.608 tool[611] New ActivationState: Unactivated
    2007-08-20 17:13:50.608 tool[611] Your iPhone could not be activated.

    Not good.

    Anyone had this problem and fixed it?

    I haven't been having a good run of luck here haha.
    -Adam



  2. #2
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    227
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Quote Originally Posted by wombat View Post
    Hi all,

    I upgraded to firmware 1.0.1 on my iPhone, and now it's gone to sh*t. First it worked fine with my shiny new silvercard, but then it spat. So, I tried to reactivate it using the key I generated, and I got this:

    $ ./tool --activate a.plist
    iPhoneActivatorTool 1.0
    2007-08-20 17:13:50.417 tool[611] Found iPhone Device: 1
    2007-08-20 17:13:50.417 tool[611] Connecting...
    2007-08-20 17:13:50.423 tool[611] Checking Pairing...
    2007-08-20 17:13:50.434 tool[611] Starting device session...
    2007-08-20 17:13:50.521 tool[611] ActivationState: Unactivated
    2007-08-20 17:13:50.521 tool[611] Deactivating your iPhone...
    2007-08-20 17:13:50.540 tool[611] New ActivationState: Unactivated
    2007-08-20 17:13:50.540 tool[611] Activating your iPhone...
    InvalidActivationRecord
    2007-08-20 17:13:50.608 tool[611] New ActivationState: Unactivated
    2007-08-20 17:13:50.608 tool[611] Your iPhone could not be activated.

    Not good.

    Anyone had this problem and fixed it?

    I haven't been having a good run of luck here haha.
    -Adam

    Mine activated fine using iActivator.

  3. #3
    Rookie Array

    Join Date
    Jul 2007
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by wombat View Post
    Hi all,

    I upgraded to firmware 1.0.1 on my iPhone, and now it's gone to sh*t. First it worked fine with my shiny new silvercard, but then it spat. So, I tried to reactivate it using the key I generated, and I got this:

    $ ./tool --activate a.plist
    iPhoneActivatorTool 1.0
    2007-08-20 17:13:50.417 tool[611] Found iPhone Device: 1
    2007-08-20 17:13:50.417 tool[611] Connecting...
    2007-08-20 17:13:50.423 tool[611] Checking Pairing...
    2007-08-20 17:13:50.434 tool[611] Starting device session...
    2007-08-20 17:13:50.521 tool[611] ActivationState: Unactivated
    2007-08-20 17:13:50.521 tool[611] Deactivating your iPhone...
    2007-08-20 17:13:50.540 tool[611] New ActivationState: Unactivated
    2007-08-20 17:13:50.540 tool[611] Activating your iPhone...
    InvalidActivationRecord
    2007-08-20 17:13:50.608 tool[611] New ActivationState: Unactivated
    2007-08-20 17:13:50.608 tool[611] Your iPhone could not be activated.

    Not good.

    Anyone had this problem and fixed it?

    I haven't been having a good run of luck here haha.
    -Adam
    You mentioned about that you are trying to activate with self-generated key, but did you replace the new iPhoneActivation.pem file before you activate the iPhone?

  4. #4
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    Australia
    Posts
    228
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    yes, phone was jailbroken and ready. still didn't want to work.

    i fixed it in the end, here's what i did:

    1. downloaded the new 1.0.1 firmware, then found where itunes was storing it. it was in: ~/Library/iTunes/iPhone Software Updates/

    2. located the file called: "iPhone1,1_1.0.1_1C25_Restore.ipsw"
    3. renamed it to "old-iPhone1,1_1.0.1_1C25_Restore.ipsw"
    4. downloaded the 1.0.0 firmware from here: http://appldnld.apple.com.edgesuite....a_Restore.ipsw using firefox, so that it didn't expand the binary
    5. copied this file into where the version 1.0.1 firmware update was sitting, and named it: "iPhone1,1_1.0.1_1C25_Restore.ipsw"
    6. held power and home buttons simultaneously until i got the connect to itunes message
    7. disabled my internet connection
    8. connected to itunes and restored the iphone.
    9. jailbroke again, and then successfully activated the iphone

    the result of this is that the iphone now believes it has version 1.0.1 firmware, and it identifies as that too, even though it is the version i downloaded. it now works perfectly once again.

  5. #5
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    Australia
    Posts
    228
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    which reminds me, can we create a files section for different firmware versions? it'd be nice to have a repository of 'anonymous' links, which are hosted elsewhere than apple, as apple are bound to terminate these old firmware versions eventually.


  6. #6
    Rookie Array

    Join Date
    Jul 2007
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by wombat View Post
    yes, phone was jailbroken and ready. still didn't want to work.

    i fixed it in the end, here's what i did:

    1. downloaded the new 1.0.1 firmware, then found where itunes was storing it. it was in: ~/Library/iTunes/iPhone Software Updates/

    2. located the file called: "iPhone1,1_1.0.1_1C25_Restore.ipsw"
    3. renamed it to "old-iPhone1,1_1.0.1_1C25_Restore.ipsw"
    4. downloaded the 1.0.0 firmware from here: http://appldnld.apple.com.edgesuite....a_Restore.ipsw using firefox, so that it didn't expand the binary
    5. copied this file into where the version 1.0.1 firmware update was sitting, and named it: "iPhone1,1_1.0.1_1C25_Restore.ipsw"
    6. held power and home buttons simultaneously until i got the connect to itunes message
    7. disabled my internet connection
    8. connected to itunes and restored the iphone.
    9. jailbroke again, and then successfully activated the iphone

    the result of this is that the iphone now believes it has version 1.0.1 firmware, and it identifies as that too, even though it is the version i downloaded. it now works perfectly once again.
    You downgrade back to 1.0 by this method?

  7. #7
    Professional Array

    Join Date
    Aug 2007
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Default

    this method won't work because itunes need internet otherwise the down- or upgrade will cancel

  8. #8
    Senior Professional Array

    Join Date
    Jul 2007
    Location
    ATLANTA, GA
    Posts
    103
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    I wouldnt be too quick to respond that the 1.01 firmware should not be used. Id estimate over 50% of the people on here have upgraded to that firmware and using it just fine without any problems, of which Im included. I upgraded it and used the iActivator and it worked flawlessly, no issues or bumps, went as smooth as a baby's ass.

  9. #9
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    258
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    I'm using 1.0.1 with iAsign and TurboSIM with no problems at all.

 

 

Similar Threads

  1. Replies: 2
    Last Post: 07-20-2008, 05:20 PM
  2. [Upgrade]OTB 1.1.2 Upgrade to 1.1.4 W/O Unlock/Activate/Jailbreak
    By Allingby in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 05-13-2008, 10:36 AM
  3. Replies: 8
    Last Post: 03-18-2008, 04:37 AM
  4. Replies: 0
    Last Post: 01-25-2008, 08:37 PM
  5. [1.1.3] Jailbreak/Upgrade, does 1.1.2u unlock Survive upgrade?
    By mdfreeman in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 01-25-2008, 04:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:23 AM.
twitter, follow us!