Results 1 to 10 of 10
Discuss Custom Carrier Settings in 1.1.3 at the General - Hackint0sh.org; Has anyone been able to get custom carrier settings working on 1.1.3? I used to ...
  1. #1
    Newbie Array

    Join Date
    Feb 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Custom Carrier Settings in 1.1.3

    Has anyone been able to get custom carrier settings working on 1.1.3? I used to have my T-mobile settings workin when i was at 1.1.1 but since i upgraded to 1.1.3 they disappeared. Anyone have an idea how to get em working?



  2. #2
    Developer Array The_Real_BigBuckz's Avatar

    Join Date
    Jan 2008
    Posts
    251
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    32

    Default

    Do you mean the edge and gprs for t-mobile? if so just edit the carrier.plist, this can be found in /System/Library/Carrier Bundles/Unknown.bundle

  3. #3
    Newbie Array

    Join Date
    Oct 2007
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by HyceL View Post
    Has anyone been able to get custom carrier settings working on 1.1.3? I used to have my T-mobile settings workin when i was at 1.1.1 but since i upgraded to 1.1.3 they disappeared. Anyone have an idea how to get em working?
    Same problem here. Trying to enter the T-Mobile US APN (internet2.voicestream.com) to use GPRS/EDGE and my phone won't save the new APN value.

    Worked fine with unlocked 1.1.1, but unlocked 1.1.3 seems to not want to accept new values.

    I'll take a look at the carrier.plist

  4. #4
    Developer Array The_Real_BigBuckz's Avatar

    Join Date
    Jan 2008
    Posts
    251
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    32

    Default

    You could go to installer then "Tweaks 1.1.3" and install "T-mobile 1.1.3 TZones Hack"

  5. #5
    Newbie Array

    Join Date
    Feb 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    no i got my edge and everything working.. I'm talking about when u go to settings and then phone.. on the bottom u can get att services screen. when u click that u get some options where u can check your minutes, bill balance etc.. i had that customized for tmobile when i had 1.1.1 but now i'm trying to figure out how to get it back on 1.1.3.
    and one more q.. is there a binary plist editor for windows?


  6. #6
    Developer Array The_Real_BigBuckz's Avatar

    Join Date
    Jan 2008
    Posts
    251
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    32

    Default

    I've never edited plists in windows, but ther has to be one just run a search on this forum. If you are trying to get the sim applications to work then just insert your sim and restart your iphone I've heard it works.

  7. #7
    Newbie Array

    Join Date
    Oct 2007
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by sactoeric View Post
    Same problem here. Trying to enter the T-Mobile US APN (internet2.voicestream.com) to use GPRS/EDGE and my phone won't save the new APN value.

    Worked fine with unlocked 1.1.1, but unlocked 1.1.3 seems to not want to accept new values.

    I'll take a look at the carrier.plist
    Okay - here's what solved this for me: Reset Network settings. Once I did that, I was able to re-enter my APN for t-mobile and the phone remembers the settings and let's me use the data network.

    So, at the risk of stating the obvious: tap Settings -> General -> Reset -> Reset Network Settings. (this will clear any stored wifi passwords, too.)

    Works for me.

    I may still go for editing the carrier.plist file as well...

    Good luck.

  8. #8
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    315
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    25

    Default

    hes not talking about apn's or anything. hycel i know what you are talking about. i whent from 1.1.1 to 1.1.3 and i actually dont have that in the phone menu anymore (possibly the phone tries to determin what carrier you are on to put the correct menu but since it does not have our carrier listed it doesnt put anything there?)

    i played around with the plists a little but didnt get anywhere, I'm thinking this may require a hack similar to iWorld. so its mostly just a matter of figuring out where the plists it normally reads are and how it uses them.

    i will look at it again later and see what i come up with, also you do not need to keep plists in binary format. the phone will read the text ones aswell.

  9. #9
    Developer Array The_Real_BigBuckz's Avatar

    Join Date
    Jan 2008
    Posts
    251
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    32

    Default

    Hycel, if you can tell me how you modified it in 1.1.1 maybe I could port it accross to 1.1.3.

  10. #10
    Newbie Array

    Join Date
    Feb 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    the files we need to edit somehow are in System/Library/CarrierBundles
    There's one for ATT, o2, orange, tmobile germany and Tim Italy and an Unknown one. We need to edit one so it works with tmobile.
    Otachi you are right, when i got my tmobile card in the settings don't even show up. With Att card they do.
    BigBuckz i have to find the files i edited when i was back in 1.1.1 when i do i'll let you know what i did, maybe link the files here.


 

 

Similar Threads

  1. ***Carrier settings for MMS on 2g***
    By Slander98 in forum General
    Replies: 6
    Last Post: 12-25-2009, 11:22 PM
  2. Carrier Settings
    By whyask in forum Yellowsn0w (3G unlock)
    Replies: 1
    Last Post: 03-31-2009, 08:34 AM
  3. Carrier Settings
    By dolmar in forum General
    Replies: 0
    Last Post: 01-31-2008, 09:49 AM
  4. Carrier settings under 1.1.1.
    By gu014 in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 10-24-2007, 06:49 PM
  5. Settings -> Carrier ?!
    By spoonet in forum General
    Replies: 6
    Last Post: 07-17-2007, 07:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:11 AM.
twitter, follow us!