Results 1 to 4 of 4
Discuss Couple quick questions at the General - Hackint0sh.org; I just had 2 questions. First, does a DFU flash reflash the baseband if it's ...
  1. #1
    Newbie Array

    Join Date
    Jul 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Couple quick questions

    I just had 2 questions. First, does a DFU flash reflash the baseband if it's the same version? Or is it a one time deal?

    Also, I have gotten error 3194 on a 3g doing a downgrade, I had to flash it to 4.1 to get the phone running again, DFU & recovery mode would not work. The phone was locked with a passcode that I did not know fwiw. I thought 3194 was a signature issue from apple, IE only appling to 3GS and 4's.



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by equate975 View Post
    I just had 2 questions. First, does a DFU flash reflash the baseband if it's the same version? Or is it a one time deal?
    Generally no - the baseband only upgrades. If the baseband is corrupted you can often reflash the same baseband to fix the corruption.

    There is a vulnerability in the first batch of 3G iPhones that allows baseband downgrade via tools like fuzzyband. Only 3G iPhones with serials of xx827 or lower might work with fuzzyband.

    Quote Originally Posted by equate975 View Post
    Also, I have gotten error 3194 on a 3g doing a downgrade, I had to flash it to 4.1 to get the phone running again, DFU & recovery mode would not work. The phone was locked with a passcode that I did not know fwiw. I thought 3194 was a signature issue from apple, IE only appling to 3GS and 4's.
    Apple added a soft-shsh check with iOS 4.0 and higher. This is why you got the 3194 (apple only signs 4.1 now)

    You should have restore to any 3.1.x iOS version (they do not have a SHSH requirement) instead of restoring to 4.1 - now you have a phone that can't be unlocked with ultrasn0w.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Jul 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Generally no - the baseband only upgrades. If the baseband is corrupted you can often reflash the same baseband to fix the corruption.

    There is a vulnerability in the first batch of 3G iPhones that allows baseband downgrade via tools like fuzzyband. Only 3G iPhones with serials of xx827 or lower might work with fuzzyband.
    So lets say for example I had a phone with 05.13.04 that was corrupt, a reflash of 4.0.1 should re-write the corrupt baseband?

    Quote Originally Posted by Olethros View Post
    Apple added a soft-shsh check with iOS 4.0 and higher. This is why you got the 3194 (apple only signs 4.1 now)

    You should have restore to any 3.1.x iOS version (they do not have a SHSH requirement) instead of restoring to 4.1 - now you have a phone that can't be unlocked with ultrasn0w.
    facepalm, now I remember that.

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by equate975 View Post
    So lets say for example I had a phone with 05.13.04 that was corrupt, a reflash of 4.0.1 should re-write the corrupt baseband?
    In theory, yes
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. Couple of JB 4.2 questions..
    By bb1426 in forum iOS 4.x (iPhone OS 4.x)
    Replies: 1
    Last Post: 12-28-2010, 11:03 PM
  2. a Couple of AMD Questions
    By trumptor in forum Distributions
    Replies: 1
    Last Post: 08-29-2009, 01:59 AM
  3. [2.0] [first gen] couple of questions
    By mishad7 in forum General
    Replies: 0
    Last Post: 07-20-2008, 07:28 PM
  4. A couple questions
    By nnny in forum Free Toolchain Software (Cydia App's)
    Replies: 0
    Last Post: 08-21-2007, 11:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:59 PM.
twitter, follow us!