Results 1 to 10 of 10
Discuss Camera does not savepictures on jailbroken 1.1.4!! any ideas? at the General - Hackint0sh.org; just checking if anyone hadsame problem..or someone got any idea about it ...i jailbreaked and ...
  1. #1
    Advanced Array

    Join Date
    Dec 2007
    Posts
    34
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Exclamation Camera does not savepictures on jailbroken 1.1.4!! any ideas?

    just checking if anyone hadsame problem..or someone got any idea about it ...i jailbreaked and activated my 1.1.4 using modified ziphone file! now i cant seem to be able to take any pics using the cam app



  2. #2
    Senior Professional Array Twisty iphoney's Avatar

    Join Date
    Oct 2007
    Posts
    492
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    hey,
    sorry to hear abt your problem i can take pictures and they are saved perfectly on jb 1.1.4 with patched zibri.dat.
    thanks

  3. #3
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    319
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    22

    Default

    SSH into your iPhone and navigate to private/var/mobile/Media/DCIM
    Change permissions to 0777.
    Dont have to reboot. Test you camera now. Should be saving fine.
    iPhone 4 32GB

    Firmware : 4.1

    Carrier: M1 (Singapore)
    Unlocked : Yes
    Jailbroken : Yes
    Activated : Yes

    If this post has helped you, please rep me by clicking the thumbs up sign located to the directly to the left of your screen.

  4. #4
    peu
    peu is offline
    Respected Professional Array peu's Avatar

    Join Date
    Aug 2007
    Location
    Buenos Aires Argentina (I like ribs)
    Posts
    501
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    and inside the DCIM folder there is one called 100APPLE, set permissions on this one to 0700

    5>evaders>JB 6.12
    4S>5.01>>5.11>redsnow>JB 5.1.1
    4>Limera1n B1>4.3.2>IOS5 GM>redsnow>JB 5.0
    3GS>blackra1n RC3>3.1.2>Spirit>Unlock 3.1.2>Jailbreakme.com>Ultrasn0w 2.0>JB 4.01
    3G>redsn0w 0.72>ultrasn0w>Unlock 3.0>pwnage 3.14>JB 3.1.2
    2G>hardware unlock>elite-team virginizer>upgrade to 1.1.1>toc2rta JB>anysim 1.1>unlock 1.1.1>Restored to 1.1.3>Ziphone 2.2>Unlock 1.1.3>Modified Ziphone>iClarified unlock patch>Unlocked 1.1.4>QuickPWN>2.0.2>2.1>2.2>2.2.1>redsn0w 0.71>JB 3.0

  5. #5
    Newbie Array joshuatw's Avatar

    Join Date
    Jan 2008
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I'm having this problem too. I've changed the permissions on both DCIM and 100APPLE. Still not saving pictures. Any ideas?


  6. #6
    Newbie Array joshuatw's Avatar

    Join Date
    Jan 2008
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I just erased all the content on my phone, camera is working now...

  7. #7
    Rookie Array

    Join Date
    Oct 2007
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have the same problem.. When you say that you erased all the content does that mean you did a full restore? Loose sms an everything? Thanks

    EDIT: Never mind, I just set the permissions on the 100APPLE to 0777.
    Last edited by efish; 03-01-2008 at 01:26 AM.

  8. #8
    IzC
    IzC is offline
    Rookie Array

    Join Date
    Oct 2007
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    1. Install Term-vt100
    2. Login: root
    3. Password: alpine
    4. Type: cd /private/var/mobile/Media/DCIM/
    5. Type: chmod -R 777 ./DCIM/
    6. Close Term-vt100
    7. Take a picture and smile about your success

  9. #9
    Newbie Array

    Join Date
    Mar 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Lightbulb

    Actually the proper owner of /private/var/mobile/Media/DCIM should be mobile, not root. Just backup the DCIM folder contents and delete it. It'll get recreated with the right ownership and permissions the next time you take a picture with the camera.
    Last edited by iPhoneFan2345; 03-12-2008 at 03:43 AM. Reason: Edited for clarity

  10. #10
    Rookie Array

    Join Date
    Mar 2008
    Posts
    22
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by iinkr3dii View Post
    just checking if anyone hadsame problem..or someone got any idea about it ...i jailbreaked and activated my 1.1.4 using modified ziphone file! now i cant seem to be able to take any pics using the cam app
    I had this problem when I JB to 1.1.4 using ZiPhone. I then virginized my iPhone and then reinstalled 1.1.4 using ZiPhone.
    And the problem dint reappear.

    Try this as a last resort

    Dev


 

 

Similar Threads

  1. Replies: 0
    Last Post: 04-02-2011, 07:00 AM
  2. Replies: 0
    Last Post: 01-20-2011, 06:50 AM
  3. Jailbroken 3.0 - Camera/Camera Roll Issue?!?
    By mceyedol in forum iPhone 3G
    Replies: 0
    Last Post: 06-24-2009, 10:18 AM
  4. Replies: 1
    Last Post: 03-23-2009, 12:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:39 PM.
twitter, follow us!