I just bought an iPhone and its FW is 1.1.1 .
Now, should I downgrade and use it as ipod?
or should I just do nothing and wait for a 1.1.1 unlock solution?