Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 44
Discuss [1.2 Beta] Could this work? at the General - Hackint0sh.org; Originally Posted by magic.one Hi im with the same Idea. Im afraid to try it ...
  1. #21
    Respected Professional Array

    Join Date
    Sep 2007
    Posts
    695
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    55

    Default

    Quote Originally Posted by magic.one View Post
    Hi im with the same Idea. Im afraid to try it on my iPhone so good one of you did

    Heres my idea. You used the files from "/Developer/Platforms/Aspen.platform/Developer/SDKs/Aspen1.2.sdk/". All the Apps are in there, clear, but the rest of the folders e.g. "System/Library/" are way to small how I think. I would try the Apps from "/Developer/Platforms/Aspen.platform/Developer/SDKs/Aspen1.2.sdk/" and merge the rest of the files with "/Developer/Platforms/AspenSimulator.platform/Developer/SDKs/AspenSimulator1.2.sdk/". These folders are way bigger and contain different data as the other one.

    Just my thought. Btw. I heared that the dev Team got the Beta FW this way.

    regards,

    Jan
    Whoever said that lied. An IPSW is way different than taking a bunch of folders and putting them on a 1.1.4 iPhone.


  2. #22
    Developer Array

    Join Date
    Jul 2007
    Location
    Stuttgart, Germany
    Posts
    85
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Yea after giving me a moment of thinking I thought the same
    iPhone 3G 16GB 3.1.2 Black T-Mobile D
    iPhone 2G 8GB 3.1.2 Vodafone.de
    MacBook Pro 15" Early '08 2,4Ghz

  3. #23
    J to the T. Shaken, not Stirred Array thecompkid's Avatar

    Join Date
    Jul 2007
    Posts
    1,152
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    75

    Default

    It is definitely true that an .ipsw does a lot more than just copy some folders over, but that is what the base 1.1.4 is for. If you look at the folder containing these files, it looks like a skeleton system that is intended to be copied over an already working FW. Example: the normal calculator.app has an icon, info property list, the actual executable and some graphics, but the calc app in the sdk folder has only the executable. Why? Because nothing else changed from 1.1.4 so there was no reason to replace anything else.

    The process I am using is extremely time consuming due almost exclusively to the fact that a normal os partition (300mb) is nowhere near large enough to both contain the 1.1.4 os (~240mb) and the 1.2 beta files (130mb+).

    Stay tuned, I will be updating soon.

  4. #24
    Advanced Array

    Join Date
    Sep 2007
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    When I copied the app files I set the permissions to 0755.

    The mail app is working with all my previous settings (mail accounts etc.). Through the mail app there is no way to setup a new account.

  5. #25
    J to the T. Shaken, not Stirred Array thecompkid's Avatar

    Join Date
    Jul 2007
    Posts
    1,152
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    75

    Default

    Quote Originally Posted by akouris View Post
    When I copied the app files I set the permissions to 0755.

    The mail app is working with all my previous settings (mail accounts etc.). Through the mail app there is no way to setup a new account.
    If you delete all your accounts and open mail, then it should prompt you.


  6. #26
    Professional Array

    Join Date
    Sep 2007
    Posts
    56
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    But wouldn't he need to use the "Preferences" app from the SDK to do this (at least to incorporate the new mail functions)?

  7. #27
    Rookie Array

    Join Date
    Mar 2007
    Posts
    28
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yes - and there are no support files to enable new preferences and/or frameworks - this is not gonna work guys ...

  8. #28
    J to the T. Shaken, not Stirred Array thecompkid's Avatar

    Join Date
    Jul 2007
    Posts
    1,152
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    75

    Default

    Quote Originally Posted by hemiola View Post
    yes - and there are no support files to enable new preferences and/or frameworks - this is not gonna work guys ...
    All the support files are there. I am just using the applications folder as an example. Included along with the apps folder is a skeleton system folder with all the updated frameworks and a /usr folder with over 50mb of updated libraries.

    UPDATE: I'm exploring a new approach. Copying the /usr/ update folder screws up the symlinks, which could just be the root of all the problems. I'll try copying it on top of a working 1.1.4, then booting into standard to copy the rest.
    Last edited by thecompkid; 03-21-2008 at 04:36 PM.


  9. #29
    Developer Array

    Join Date
    Jul 2007
    Location
    Stuttgart, Germany
    Posts
    85
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    All Frameworks are located at /Developer/Platforms/AspenSimulator.platform/Developer/SDKs/AspenSimulator1.2.sdk/
    iPhone 3G 16GB 3.1.2 Black T-Mobile D
    iPhone 2G 8GB 3.1.2 Vodafone.de
    MacBook Pro 15" Early '08 2,4Ghz

  10. #30
    Rookie Array

    Join Date
    Mar 2007
    Posts
    28
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    you do realize these binaries are written and intended to be ran on x86 ? Not ARM ....


 

 
Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Will current 3.x apps work in 4.0 beta?
    By supra in forum iOS 4.x (iPhone OS 4.x)
    Replies: 5
    Last Post: 04-10-2010, 04:08 PM
  2. [*Sim] Does it work with Latest iPhone 2.0 Beta ?
    By TATANKA in forum Turbo-, Supersim and Simcloning Solution
    Replies: 3
    Last Post: 05-22-2008, 07:09 PM
  3. OSX 10.5... I can't get the beta to work... Please help.
    By kaputsport in forum Archiv (Leopard)
    Replies: 7
    Last Post: 05-02-2008, 02:17 AM
  4. [PwnageTool] Doesn't work with 2.0 beta 3
    By omnivector in forum PwnageTool
    Replies: 80
    Last Post: 04-15-2008, 08:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:07 AM.
twitter, follow us!