Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
Discuss [1.1.3 OTB][Problem] Can't access internet from SOME wifi routers at the General - Hackint0sh.org; Same here. The iPhone connects to the wifi network, gets a proper IP via DHCP. ...
  1. #11
    Newbie Array

    Join Date
    Jan 2008
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Same here. The iPhone connects to the wifi network, gets a proper IP via DHCP. And in fact, i found that it's a DNS problem: server names don't get resolved.
    If you try some IP rather than a server name (eg: 64.233.161.18, that leads to Google), you'll probably see that Safari can open the page.

    I also found that my Mac has the very same problem on the same wifi routers. Something is broken in the way Apple implemented DNS queries. This is a known problem in Leopard, for example.

    Manually setting some other DNS servers doesn't work either. (I tried openDNS and others)


  2. #12
    Rookie Array

    Join Date
    Mar 2008
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi,

    I was able to find out the brand of the router that is giving me problems, its a Cisco Aironet 340 series. Anyone have any experience with this router?
    Last edited by Sizzzlar; 03-16-2008 at 10:22 PM.

  3. #13
    Rookie Array

    Join Date
    Mar 2008
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by zabadu View Post
    Same here. The iPhone connects to the wifi network, gets a proper IP via DHCP. And in fact, i found that it's a DNS problem: server names don't get resolved.
    If you try some IP rather than a server name (eg: 64.233.161.18, that leads to Google), you'll probably see that Safari can open the page.

    I also found that my Mac has the very same problem on the same wifi routers. Something is broken in the way Apple implemented DNS queries. This is a known problem in Leopard, for example.

    Manually setting some other DNS servers doesn't work either. (I tried openDNS and others)
    Hi,

    Thanks for the reply...but I have tried using the IP numbers and still no luck.

  4. #14
    Rookie Array

    Join Date
    Mar 2008
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Update March 17, 2008

    1. The router I am trying to connect to is a Cisco Aironet 340 series.
    2. I have tried to ping a website using term-vt100 and I get 100% packet loss.
    3. I have tried to ping the router and I get 0% packet loss.

    The phone seems to see the router just fine, but won't access the internet. Still need help!

  5. #15
    Professional Array krimp's Avatar

    Join Date
    Aug 2007
    Posts
    73
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Arrow

    okay
    so the problem seems to be in the connection between the router and the iphone..

    but it could be a simple dns authentication .. try to look into someones laptop that works and copy their ip settings and turn the laptop off then try to access.

    also check the dns settings .. do they match with yours?

    the laptop will be assigned a new ip...

    when it logs in again..

    maybe the lease already runs out on the ip address u are using..


    see if this helps


  6. #16
    Developer Array javacom's Avatar

    Join Date
    Mar 2008
    Posts
    304
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    does your internet connection require proxy server setting ?

  7. #17
    Newbie Array

    Join Date
    Feb 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Back in the 'old' days with the jailbreakme.com jailbreak. I noticed that wifi at home didn't work for me on 1.1.1 but it did work on 1.1.2 (I used a neighbours wifi to jailbreak the first iPhone, we didn't own a wireless router yet). The router was able to see my iphone and my iphone was able to see and connect to my router. But I just couldn't go on the internet, the iphone that was already jailbroken and on 1.1.2 had no problems.

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 0
    Last Post: 08-18-2011, 12:50 AM
  2. 3G can't access cell network or Wifi internet to start the Jailbreak process
    By thedrsguy in forum Ultrasn0w (3G(S)/iPhone 4 unlock)
    Replies: 0
    Last Post: 08-06-2010, 12:05 AM
  3. [iLiberty+] Wifi connects but apps can't access Internet
    By killcreek in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 04-07-2008, 11:34 AM
  4. Help Using Wifi And Safari ! Cant Access Internet
    By chuyzarzosa in forum General
    Replies: 2
    Last Post: 01-04-2008, 12:38 PM
  5. Replies: 0
    Last Post: 11-04-2007, 01:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:07 AM.
twitter, follow us!