Results 1 to 5 of 5
Discuss 1.1.2 PROBLEM: no PhoneFormat with UK Region Format at the General - Hackint0sh.org; Hi, When i select UK in region Format, PhoneFormat is not working at all. When ...
  1. #1
    Senior Professional Array klim's Avatar

    Join Date
    Sep 2007
    Posts
    170
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Angry 1.1.2 PROBLEM: no PhoneFormat with UK Region Format

    Hi,

    When i select UK in region Format, PhoneFormat is not working at all.

    When i select any other region, it's works fine from
    /System/Library/Frameworks/UIKit.framework/PhoneFormats/UIPhoneFormats.plist

    I tried everything. Please help why it's not loading if i select UK?



  2. #2
    Respected Professional Array

    Join Date
    Aug 2007
    Location
    Paris, France
    Posts
    533
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    Quote Originally Posted by klim View Post
    Hi,

    When i select UK in region Format, PhoneFormat is not working at all.

    When i select any other region, it's works fine from
    /System/Library/Frameworks/UIKit.framework/PhoneFormats/UIPhoneFormats.plist

    I tried everything. Please help why it's not loading if i select UK?
    This is very odd indeed. As you state, the other formats work. Guess you need to wait for a UK 1.1.2. iPhone owner to confirm what's happening before determining whether you need to restore or not.

  3. #3
    Senior Professional Array klim's Avatar

    Join Date
    Sep 2007
    Posts
    170
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    I even can't change 12h format to 24h format, when i select USA format.
    Now this option gray.

    I need Monday to be the 1st day of week and 24h time system.
    Somebody know how to fix?

  4. #4
    Rookie Array

    Join Date
    Sep 2007
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    This is a bug. It existed in 1.1.1, and still isn't fixed in 1.1.2.

    Check out my post here:

    http://www.hackint0sh.org/forum/showthread.php?t=12473

    for the solution.

    Bagpuss.

  5. #5
    Senior Professional Array klim's Avatar

    Join Date
    Sep 2007
    Posts
    170
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Here is the solution! http://www.hackint0sh.org/forum/showthread.php?t=12473
    Thanks to Bagpuss!!

    I've finally found the solution to this.

    In all my testing, setting the international settings to UK did not result in the phone using the 'uk' section of the UIPhoneFormats.plist file.

    Upon further investigation, I have found that the locale being used is stored in the file '/private/var/root/Library/Preferences/.GlobalPreferences.plist'.

    When you set 'United Kingdom' as your locale in the international preference pane, the key that's written into this file is actually en_GB, and not en_UK.

    If you change your UIPhoneFormats.plist file to use 'gb' as the key, and not 'uk', then everything starts to work as it should.

    An example entry for 'gb' is as follows:

    <key>gb</key>
    <array>
    <string>01#1 ### ####</string>
    <string>011# ### ####</string>
    <string>01### ### ###</string>
    <string>02# #### ####</string>
    <string>03# #### ####</string>
    <string>0500 ### ###</string>
    <string>05# #### ####</string>
    <string>07### ### ###</string>
    <string>08## ### ####</string>
    <string>+44 1#1 ### ####</string>
    <string>+44 11# ### ####</string>
    <string>+44 1### ### ###</string>
    <string>+44 2# #### ####</string>
    <string>+44 3# #### ####</string>
    <string>+44 500 ### ###</string>
    <string>+44 5# #### ####</string>
    <string>+44 7### ### ###</string>
    <string>+1 (###) ###-####</string>
    <string>001 (###) ###-####</string>
    <string>00 $</string>
    </array>

    This simply appears to be an oversight on Apples part when introducting the international settings. One would hope that this is fixed in the 1.1.2 firmware that o2 are shipping.

    Hope this helps,

    Bagpuss.


 

 

Similar Threads

  1. iPhone4 region format issues
    By riyadhNY in forum iPhone 4
    Replies: 1
    Last Post: 07-22-2010, 05:04 PM
  2. [Advice] international payload-region format?
    By dia_cer0 in forum Free Toolchain Software (Cydia App's)
    Replies: 5
    Last Post: 04-02-2008, 05:59 AM
  3. Region format resetting to US after reboot
    By jelassaad in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 02-24-2008, 06:10 PM
  4. How to Add New Region Format in Setting
    By Wiroj in forum General
    Replies: 0
    Last Post: 11-14-2007, 08:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:46 AM.
twitter, follow us!