Page 1 of 2 12 LastLast
Results 1 to 10 of 12
Discuss 1.1.1 jailbreak and activation: Getting SSH and BSD on the phone at the General - Hackint0sh.org; I have followed the instructions and managed to: a) Jailbreake the phone (I am at ...
  1. #1
    Rookie Array esodin's Avatar

    Join Date
    Oct 2007
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question 1.1.1 jailbreak and activation: Getting SSH and BSD on the phone

    I have followed the instructions and managed to:
    a) Jailbreake the phone (I am at the root directory using iPhuck in step 3)
    b) Get write access (my fstab shows "rw" - end of step 3)

    I am now at "STEP 4: INSTALLING SSH AND BSD WORLD". The instructions for a mac seem fine, but I am doing this from Windows.

    I have tried to perform the "Mac" script manually (Linux is my preferred OS). Saving the "update" and "com.apple.update.plist" files using "getfile"

    When I try to use "putfile" (as in the phase2.script) iPhuc tells me: "No such command"

    Any help would be appreciated.



  2. #2
    Rookie Array

    Join Date
    Jul 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    The iphuc-jailbreak.exe doesn't have the putfile command. Download the one from the iphone dev team elite http://code.google.com/p/iphone-elite/downloads/list (is made for 1.1.1) and it will let you use putfile. Let me know if it works.

  3. #3
    Professional Array

    Join Date
    Sep 2007
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Default

    For the Windows ssh install go here

    http://cre.ations.net/blog/post/howt...on-your-iphone

    READ THE STEPS!!

    after you do this you should have ssh, scp access

    Use Putty to test it out

    If you dont have access, do this (this happend to me)

    Connect iphone to you computer

    Go to:
    http://iphone.natetrue.com/

    get this file:
    au.asn.ucc.matt.dropbear.plist and copy it to the folder where you uncompressed sshkit too

    Open up a cmd window in windows
    CD to the shhkit folder
    run iphoneinterface in the command prompt.
    Now do:

    putfile /System/Library/Launch/Daemons/au.asn.ucc.matt.dropbear.plist

    exit

    now reboot your iphone

  4. #4
    Rookie Array esodin's Avatar

    Join Date
    Oct 2007
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks, guys. I figured it out. Ellopr was spot on: I had "iphuc-jailbreak.exe" running rather than the regular version and tried to run it from there.

    I now have SSH and will try the activation once I get home from work this afternoon (I am in Australia).

  5. #5
    Senior Professional Array slimnickyy's Avatar

    Join Date
    Sep 2007
    Location
    London
    Posts
    418
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    Quote Originally Posted by esodin View Post
    Thanks, guys. I figured it out. Ellopr was spot on: I had "iphuc-jailbreak.exe" running rather than the regular version and tried to run it from there.

    I now have SSH and will try the activation once I get home from work this afternoon (I am in Australia).
    Please if you can, detail how you go about activation and whether you get it to work. Detail what you do, what you used, etc if possible as there are a few of us that cannot understand the dev team directions (for activation)


  6. #6
    Rookie Array esodin's Avatar

    Join Date
    Oct 2007
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Ok, I'll post back here as soon as have got it to work.

  7. #7
    Rookie Array

    Join Date
    Oct 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i cannot get ssh to work with my phone either.. i have added the other files..
    putfile /System/Library/LaunchDaemon/au..... but still nothing..i tried it with the phone unactivated on AT&T and with the phone activated on AT&T and still can't get it to connect either way. i have redone the process several times thinking i have done it wrong, but i know i have done everything to the T and sitll nothing. Neither putty nor winscp will connect...i either get a connection refused or connection time out error...anyone have any ideas or having the same problem???

  8. #8
    Rookie Array esodin's Avatar

    Join Date
    Oct 2007
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Are you sure that your WiFi access-point has security turned off?

    You may want to delete the "known-hosts" file in your ".ssh" or equivalent directory. It could be that the ssh key needs to be refreshed.

    I also found connection to be lagging (5-10 seconds at times) (I think) it helped to keep the iPhone awake by stroking it (that sounded bad)

    (sorry I live in the Linux world and ssh from there - installation was on Windows though)
    Last edited by esodin; 10-12-2007 at 04:10 AM.

  9. #9
    Rookie Array

    Join Date
    Oct 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    the ssh works fine when in the 1.0.2 firmware so its not my router I haven't checked the known host but I thought I already modified it so I'll see when I get home any other suggestions anyone I'd has anyone run into the same problem

  10. #10
    Rookie Array esodin's Avatar

    Join Date
    Oct 2007
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by benison_123 View Post
    the ssh works fine when in the 1.0.2 firmware ...
    if you had to enter a key (WEP) when you used it under 1.0.2 it would have been reset when you upgraded. There should be a function on your router that allows you to see if the iPhone ever asked for an IP. Also, if you use DHCP it's very likely that this address might have changed (depends on your lease time settings)

    I would check (using the access to your router) if the iPhone showes up on your network at all; then what IP address it has.

    Good luck!


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 01-28-2011, 11:15 AM
  2. 3GS Jailbreak w/o Activation
    By smacman in forum iPhone 3GS
    Replies: 13
    Last Post: 09-09-2009, 02:16 PM
  3. Activation During Jailbreak help
    By xbcsharpshooter in forum purplera1n (3GS jailbreak)
    Replies: 6
    Last Post: 07-25-2009, 04:07 PM
  4. Replies: 0
    Last Post: 10-12-2007, 06:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 10:08 PM.
twitter, follow us!