Page 1 of 3 123 LastLast
Results 1 to 10 of 25
Discuss [SpringBoard] crashes due its icon limit to 72 at the Free Toolchain Software (Cydia App's) - Hackint0sh.org; Hi, just to share an experience after a crash and reading another thread : http://www.hackint0sh.org/forum/showthread.php?t=15475 ...
  1. #1
    Newbie Array

    Join Date
    Aug 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [SpringBoard] crashes due its icon limit to 72

    Hi, just to share an experience after a crash and reading another thread : http://www.hackint0sh.org/forum/showthread.php?t=15475


    I had a crash yesterday (white apple on a black screen staying forever), after installing a bunch of applications I

    Config : iPhone US 1.1.2 jailbreak & unlocked with AppTapp & AnySIM since 1 month, no SummerBoard running. Since then runned fine.

    - first tried a few hits : tried to reset (home + power button), plugged, unplugged to AC etc => no success
    - thought it was the magnets in the case I received for christmas : took it out => no success
    - overheating : left it alone a few hours => no success
    - then when I plugged it in USB on my computer (Mac), I realized it was recognized by iTunes & iPhoto and disappeared a while ago, and coming back, etc
    => I realized it was an infinite loop

    - then I tried to SSH it and it answered. I was happy to see that it was not crashed, only the UI seemed out of service.

    - checked the disk space : 10 MB left on /, plenty of on /private/var. As I moved my /Applications to /var/private/Applications, and as /tmp is also located on /private/var partition, I guessed it wasn't a disk space issue neither.

    - checked the /var/logs/CrashReporter directory and found a reference to an unexisting SpringBoard crash file (LastetCrash.plist pointed out to a SpringBoard-date-hour.plist file which didn't exist). In the Panic subdirectory I had severals files, and all of them stated the following inside "Debugger message: WDT timeout", and didn't point out a specific process but a kernel exception.

    - after a few reboots, I noticed SpringBoard process was present very briefly and crashed as soon as it was launched (when logged on ssh, you can do a "top" or repeat "ps auxw | grep Spring" )

    - the iphone was booting correctly, SpringBoard was failing to initialize, and system was ok for about 6 minutes, then the kernel detected SpringBoard was not present and rebooted after a kernel panic.
    => this gives you a 6 minutes timeframe each time to test out a solution :-)

    - I tried to disable the Brightness auto-adjust in SSH, but the modifications I made to the Preferences.app .plist file didn't help (don't know it they worked or not, but problem not solved)

    - after a few hours Googling about SpringBoard process initialization, I found out that there is a /System/Library/CoreServices/SpringBoard.app/M68AP.plist file containing all the icons and there order. For iPod touch, it is called N54AP.plist

    - tried to modify this file without sucess, then just backuped it ("cd /System/Library/CoreServices/SpringBoard.app/ " then "cp M68AP.plist M68AP-backup.plist" and deleted it ("rm M68AP.plist") => SUCCESS !
    After a reboot, the iPhone stopped displaying the white apple and I had my "slide to unlock" welcome screen with my background.

    When I slided to unlock I had a black screen (no icons, no dock), and instead of my carrier name at the top left, i had "iPod". It meaned that SpringBoard is starting correctly, but as it is not finding the M68AP.plist file, it falls back to a blank configuration.

    At this point, I tried several modifications in the M68AP.plist & reboots, found on the web a clean one from the original distribution, without success.

    As SpringBoard is like the Windows Explorer or the Mac Finder, only a UI manager, so it means that your OS apps can run correctly without it, but you'll have to launch them manually.

    I then decided to uninstall the applications installed yesterday, one by one.

    BEGIN LOOP
    To do that while logged on SSH, slide to unlock your SpringBoard, then on the SSH, do a "cd /Applications/Installer.app" and a "./Installer &" -> that will launch the Installer on the iPhone, and you can do whatever you want.

    After each app uninstall, in the SSH session, I tried to put back my M68AP.plist ("cd /System/Library/CoreServices/SpringBoard.app/" then "cp M68AP-backup.plist M68AP.plist") and restart SpringBoard to see if it starts correctly ("killall SpringBoard"). It within 20 seconds I still had the small circling sign on the iPhone screen, I wiped out the M68AP.plist ("rm M68AP.plist") -> Installer quits, and back to SpringBoard empty black screen. Had to redo the same procedure again to uninstall a n additionnal app.
    GOTO BEGIN LOOP :-)

    Then the magic happened, when I had 72 icons to display (I discovered that some apps don't have an icon to display on Springboard), Springboard restarted again, got my icons back, my carrier name and iPhone worked like it did yesterday before the app install (ie like a charm) !

    I've been able to reproduce the problem at will, each time I install an app raising the icon number to 73, same crash, no matter what application it is. Once an application is uninstalled to lower the icon to display to 72, everything fixed !

    So conclusion : no need to restore & activate again, just be sure that you have less than 72 icons to display in SpringBoard (5 pages and a half). Hope it will save *hours* for the next one in the case :-)






    @aeg0 & @bekochu : you guys seemd to have similar behaviours, are you able to reproduce that like me ?

    @aakash.goenka : just had a look on you crash reports from the 12/19, I'm not a specialist, somehow here is what I guessed : your SpringBoard is crashing, I don't know why -> generates the SpringBoard-date-hour.plist. It tries to restart, crashes again, and after a while, the system detects that SpringBoard process has not been present for too long, so it goes in a kernel panic -> generate the PANIC/date-hour-panic.plist, with the "WDT timeout" which stands for "WatchDog Timer timeout" (a watchdog is a process monitoring if a specific process is present and restarts it if it fails). It doesn't fix your problem, but hope it gives at least an idea where to focus...

    Anyone has a clue about this limit ?



  2. #2
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    215
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    LoL

    i'm not laughing at you or at your problem...i'm laughing with you

    Yesterday i had exactly the same problem...and worse..i had SSH Off

    Had to install NateTrues SSH-Kit for dropbear use.

    Including the Official icons i have atm 76 icons on SpringBoard, don't know if the limit is exactly the problem, but i solved it by replacing the entire SpringBoard.app folder with a fresh one directly from the decrypted 1.1.1 image.

    Now i'm happy again

  3. #3
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    157
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    sorry to jump in guys, but im a bit of a newbie with apps.

    Does this crash seem to occur when 70+ buttons are on the homepage(springboard)?

  4. #4
    Newbie Array

    Join Date
    Aug 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    @zool : :-D glad to hear that I wasn't living the worst scenario, and also that you made it out of the infinite loop hell. On my side, that's why I always leave SSH & AFPd running.
    You're in 1.1.1 ? 76 is the limit before crash in your case ? excluding or including dock icons ?

    @Sbouri : yep, in my case 72. Zool seems to have a different number (76). Perhaps it's not a hard limit but something depending on memory, weather, a butterfly in Asia... ;-)
    --
    iPhone 1.1.2 US / BL39
    feel free to PM me as I don't follow the threads on a regular basis !

  5. #5
    Advanced Array flopethedope's Avatar

    Join Date
    Dec 2007
    Posts
    33
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    :/
    Sucks for you. I've got 173 icons on my springboard with no problems.


  6. #6
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    215
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    Quote Originally Posted by sling3 View Post
    @zool : :-D glad to hear that I wasn't living the worst scenario, and also that you made it out of the infinite loop hell. On my side, that's why I always leave SSH & AFPd running.
    You're in 1.1.1 ? 76 is the limit before crash in your case ? excluding or including dock icons ?
    Yeps, i'm on 1.1.1 (and happy ehehhe) and the 76 icon count is excluding the Dock icons, so in fact i have 81 Total (5 icons on dock)
    As i said before, don't know if the number of icons was the reason of the problem since almost nobody else is having the same error.
    It "crashed" after i installed Colloquy (Modded) from BigBoss repository, and i heard that app was giving many people weird problems (in fact the app was taken out of installer)
    So...maybe it was the Butterfly flapping her wings in Tokyo ....

  7. #7
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    152
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Hi there,

    I also started to get the endless apple logo loop bug today.

    Don't know if it's due to me reaching the 72 icon limit (I wasn't aware of).

    I have ssh turned off

    Tried to install NateTrues SSH-Kit for dropbear.

    Files installed fine, but I still get a "connection refused" error when trying to login using putty and/or winscp (with scp fallback active).

    Any idea what I'm missing here ?

  8. #8
    Senior Professional Array

    Join Date
    Sep 2007
    Location
    Chile
    Posts
    172
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    Hi All, @ 1st is interesting how you solved your problem, but I can't understand why you don't have installed Summerboard?

    Z00L: How haveyou insalled NateTrues SSH-Kit for dropbear?
    I've installed OpenSSH, but I've it turned off and through Services I turn it on when I need to.

    Thanks & Happy New Year!
    macdo
    iPhone
    • FV 1.0 until 2008Feb28 -> Virginize -> 1.1.3 FW iTunes Restore -> ZiPhone 2.4 & Fully Working.
    • March08: Restored to 1.1.4 iPlus 2.0 and Sold it
    • Now waiting...

  9. #9
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    152
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Ok, solved.

    NateTrues SSH-Kit worked on second try.

    After some trial and error, I'm now back with all my apps and icons.

    By the way, I have 78 icons (+ the 4 dock ones) so I'm not sure the number of icons is the problem here.

    I recovered my iPhone by uninstalling the last app I had installed (iTunes wiki or whatever it is called).

    Not going to try it again any time soon ... :p

  10. #10
    Professional Array

    Join Date
    Oct 2007
    Location
    Tiuana
    Posts
    79
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by flopethedope View Post
    :/
    Sucks for you. I've got 173 icons on my springboard with no problems.


    173 icons?? of what?!


 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Springboard crashes after UltraSnow 1.2
    By kbk_75 in forum iOS 4.x (iPhone OS 4.x)
    Replies: 3
    Last Post: 03-26-2011, 07:50 AM
  2. [2.0][SpringBoard] Apps Limit ?
    By x98car in forum Free Toolchain Software (Cydia App's)
    Replies: 4
    Last Post: 12-09-2008, 04:51 PM
  3. 144+5 Icon Limit
    By lordofdaflies in forum General
    Replies: 2
    Last Post: 10-12-2008, 07:03 AM
  4. [Springboard] Installed Applications Limit?
    By s0346944 in forum Free Toolchain Software (Cydia App's)
    Replies: 16
    Last Post: 05-25-2008, 11:58 PM
  5. [Springboard] Any workaround for the icons limit ?
    By lordofdaflies in forum Free Toolchain Software (Cydia App's)
    Replies: 4
    Last Post: 05-07-2008, 04:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:54 PM.
twitter, follow us!