Results 1 to 10 of 10
Discuss problems with 2.0.2 firmware and copying any.app at the Free Toolchain Software (Cydia App's) - Hackint0sh.org; I recently upgraded to firmware 2.0.2 using winpwn 2.5beta and now have lots of problems. ...
  1. #1
    Senior Professional Array ninja_pimp's Avatar

    Join Date
    Oct 2007
    Posts
    326
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default problems with 2.0.2 firmware and copying any.app

    I recently upgraded to firmware 2.0.2 using winpwn 2.5beta and now have lots of problems.

    mail.app - unable to check my email it loads then simply throws me out to springboard ( tried using bossprefs to fix user permissions but no luck)

    unable to make applications works now...
    i'm using itunes 7.7.1 then downgraded to 7.7.0 to see if it helped.

    here are my steps I use
    ------
    Direct method (.app):

    1) Download the ‘modified’ game/app and extract the application.app folder to your desktop.

    2) Copy application.app into /Applications via SSH or SFTP and set it’s permissions to 775 (chmod 775 application.app )

    3) Create a folder called “Documents” in /var/mobile/ and set permissions to 777. (*only needs to be done once)

    4) Reboot your iPhone

    iTunes method (.ipa):

    This method requires replacing a framework file on your iPhone, but makes the installation of apps very easy:

    How to install ‘modified’ IPA’s:

    1) SSH into your phone, navigate to the folder: “/System/Library/PrivateFrameworks/MobileInstallation.framework”
    NOTE: MobileInstallation.framework is a FOLDER!
    2) Backup the file “MobileFramework” from the directory above.
    NOTE: Rename it to MobileFramework.bak
    3) Download this patched file - HERE
    4) Copy the patched MobileFramework file into the “/System/Library/PrivateFrameworks/MobileInstallation.framework”
    NOTE: MobileInstallation.framework is a FOLDER!
    5) Set permissions to that new file to 775
    Note: CHECK AGAIN! VERY IMPORTANT!
    6) Navigate to “/private/var/mobile/”
    7) Set permissions to the folder “Applications” to 777
    NOTE: make sure reclusive is checked (meaning it sets all files within the folder to 777)
    8) Navigate into the “/private/var/mobile/applications/ folder
    9) Create a “Documents” folder in the “/private/var/mobile/applications/” folder.
    10) Set the permission to 777
    11) Navigate to the root level.
    12) Navigate into the “/applications/” folder.
    13) Create a “Documents” folder in the “/applications/” folder. Set permission to 777
    12) Reboot your iPhone - IMPORTANT! Otherwise Apps will not install!
    13) Restart iTunes
    14) Download one OFFICIAL App from the app store, if you haven’t already.
    Note: Free app are fine. Just needs to be an OFFICIAL App.

    To install .ipa apps, simply double click them and sync them with your iPhone! If the apps do not show up, just reboot your iPhone!

    -----

    the problem is if i copy say netshare.app to //applications and reboot my iphone, the app does not appear on the springboard!!

    if i do the IPA method with itunes, afte syncing it does not appear. sometimes i get errors on an app it trys but the ones that dont report an error simply don't appear

    any ideas why this is? or is it that 2.0.2 has security patch in it to prevent a user from copying via SSH and uploading a cracked IPA? Please note the files do copy over fine and are in place but simply won't appear on the springboard. and the mobilesintalltion file was copied over...

    when i had 2.0 the direct copy method worked flawless, on 2.0 i never could get the IPA method to work so i always SSH and simply copy the file over.


    anyone else seeing these problems.

    please note this also happens with paid programs, i paid for netshare and now that i'm on 2.0.2 i can't re-download it so my only option is to SSH and copy it over which fails, so i'm stumped.
    Last edited by ninja_pimp; 09-08-2008 at 02:59 PM.



  2. #2
    Rookie Array

    Join Date
    Jan 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yes, this happens on my phone too (mail not loading etc). reflashed it and it's fine and it works, but some of the apps are starting to not load again.

  3. #3
    Board Hero Array lordofdaflies's Avatar

    Join Date
    Dec 2007
    Location
    INDIA
    Posts
    1,134
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    76

    Default

    if u upgraded from 1.1.x and used ur back up to restore iphone u will face mail crashes etc

    u need to restore and set up phone as new
    about the ipa files, u need to change on of the files, dont remember which

    ok u need to change the mobileinstallation.framewor and replace with the patch, cant share here

    what i do is i change the name of the app from app.ipa to app.zip and unzip the file

    then i use the ssh method o installing
    MacBook Pro OS X SNOW Leopard
    iPhone 4 16GB iOS 4.2
    iPad WiFi 64GB iOS 4.2
    BlackBerry Curve 3G (9300)

  4. #4
    Senior Professional Array ninja_pimp's Avatar

    Join Date
    Oct 2007
    Posts
    326
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    yeah i learnt that thing about restore from backup

    i can ssure you i'm doing setup as new iphone, i do not restore from backup

    i have given up on 2.02
    now that i'm on 2.0 it seems alot more stable
    but last night for no reason, the mail started to fail
    then a few hours later the fone failed, meaning i could not open my contacts or the dial pad.
    they would start to launch then blow me out to springboard

    i have tried boss prefs, fix user permissions. reboot, but no dice
    i have tried changing permissions via ssh to 755 then back to 775 and reboot but no dice

    the only thing that ends up fixing it is to put in DFU and restore my custom IPSW file

    i'm just not understanding why some apps start to fail for no reason and if so how to fix it w/o having to restore.
    restoring is easy but sure is time consuming.

    the restore process can take about 10 to 15min then synving to itunes to put music and contacts back, thats another 30min

    then SSH and copy over your settings and tweaks thast another 60min

    when i do the ssh, after a change, i always reboot and erify all works

    but sure enough a day later maybe, or hours later something fails to work

  5. #5
    Senior Professional Array ninja_pimp's Avatar

    Join Date
    Oct 2007
    Posts
    326
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    the good news is i figured out why apps would not appear
    it was bossprefs hiding the icons
    i dont know why but boss prefs can go crazy sometimes, so trick is not to use poof because if you do, when ever you add new apps it will aut hide them for some odd reason

    so if icons dont appear check bossprefs, it may be hiding your apps.
    sometimes i'll turn it on to display, respring and the icon still is hidden so i can back to bossprefs and sure enough its still hiding even though i told it to display
    it can take 2 to 3 tries to make poof work properly

    i'm using bossprrefs 2.12 which has its own built in poof i believe
    i do not use poof


  6. #6
    Rookie Array

    Join Date
    Sep 2007
    Posts
    17
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Dear ninja_pimp

    I don't see the download link. Can use send it to me via email vannhanp@gmail.com

    Thanks,

  7. #7
    Senior Professional Array ninja_pimp's Avatar

    Join Date
    Oct 2007
    Posts
    326
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    what?
    d/l link to what?

  8. #8
    Senior Professional Array ninja_pimp's Avatar

    Join Date
    Oct 2007
    Posts
    326
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    I've got 2.0 running now and all my standard apps run fine
    if i use cydia to download an app it will run fine
    but here is the part i'm stuck on

    i have my collection of apps that I know for a fact work on 2.0 because they have done so before

    an example is flashlight.app
    a freeware app and for thsi thread thats all i have, i'm not using cracked ipa or warez stuff.

    i will mention i have paid for digital clock from app store, then SSH and ripped the digitalclock.app file and backed it up, reason being is itunes has problems when i sync to paid apps. i dont get it, if i use appstore to downlaod a paid app then sync to itunes, itunes has a hissy fit and says it can not transfer the app, but my computer is already Authroized, then it breaks my app.

    so i try to remove all apps, then reboot, then resync but my app remains broke. there is no way to get the app to work again even after chmod it to 775, only fix REstore iphone.

    so now i just skip appstore apps or syncing them because i can't make it work.

    i upload flashlight.app then chmod it to 775
    i reboot
    go to my springboard and i see the app but when i launch it, it thinks and even loads the title load screen but then exits back out to springboard

    sadly this happens to all apps i upload
    so i'm thinking it has to be a permissions problem
    i try 775 and 755 and i do it to the folder and everything inside it (recursive)

    this is my chief problem right now
    can anyone explain or help me understand how to fix this problem

    it seems whatever i i copy to the applications folder wont run

    I make a folder called "Documents" chmod it to 777 and place in 2 directories
    in private/var/stash/applications
    and
    private/var/mobile

    for example today: i restored it, never used the app store, i ssh, copy oveer the files, apply chmods, reboot
    new icons appear but they wont run
    in the past they used to but ever since i used winpwn2.5.2 things seem squirly when it comes to making apps run


    also in

  9. #9
    Rookie Array

    Join Date
    Sep 2007
    Posts
    17
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by ninja_pimp View Post
    what?
    d/l link to what?
    The link for the download patch file

    Quote Originally Posted by ninja_pimp View Post
    ...
    iTunes method (.ipa):

    This method requires replacing a framework file on your iPhone, but makes the installation of apps very easy:

    How to install ‘modified’ IPA’s:

    1) SSH into your phone, navigate to the folder: “/System/Library/PrivateFrameworks/MobileInstallation.framework”
    NOTE: MobileInstallation.framework is a FOLDER!
    2) Backup the file “MobileFramework” from the directory above.
    NOTE: Rename it to MobileFramework.bak
    3) Download this patched file - HERE
    4) Copy the patched MobileFramework file into the “/System/Library/PrivateFrameworks/MobileInstallation.framework”
    NOTE: MobileInstallation.framework is a FOLDER!
    ...

  10. #10
    Senior Professional Array ninja_pimp's Avatar

    Join Date
    Oct 2007
    Posts
    326
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    ok i made huge progress, i'm not sure exactly how ti works but...
    upkload your apps as you would apply permissions and such
    then download one free app from appstore
    reboot
    then my apps open as normal
    its like installing an appstoire app does all the code signing for the rest of my apps

    so i experiments more...
    this also works with IPA (cracked apps or games)

    there is something about download an appstore app that fixes the permissions.

    the reason all this was nor working was because i did not d/l anything from appstore. i simply wanted to see if my regular 2.0 apps works, some of these apps i got from cydia repos and i thought it would work

    thought i'd pass this along


    i did read a thread where you have to code sign the packages, yet i was able to bypass all that with a single appstore download!!


    the next test
    sync with itunes
    usually itunes breaks my appstore apps i download, it will say can not transfer because i'm nto authorized
    i re-authorize, recheck it, but same problem everytime, then all my apps on phone either dont work or some do
    very odd


 

 

Similar Threads

  1. Problems upgrading to firmware 2
    By bcj999 in forum iPhone "2G" (Rev. 1)
    Replies: 25
    Last Post: 03-19-2009, 11:15 AM
  2. Lots of problems with firmware 2.2
    By elie.fares in forum General
    Replies: 10
    Last Post: 12-01-2008, 03:12 PM
  3. [Firmware] Baseband problems.
    By Triaxial in forum iPhone Developer Exchange
    Replies: 0
    Last Post: 07-12-2008, 08:16 PM
  4. Firmware problems
    By hakim in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 12-11-2007, 09:06 PM
  5. Problems with Turbosim and firmware 1.0.1?
    By nutdhanai in forum Turbo-, Supersim and Simcloning Solution
    Replies: 5
    Last Post: 08-18-2007, 10:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:37 PM.
twitter, follow us!