Results 1 to 4 of 4
Discuss problem - running script from springboard at the Free Toolchain Software (Cydia App's) - Hackint0sh.org; hi, when i tried to run scripts from springboard the first one was no problem ...
  1. #1
    Newbie Array

    Join Date
    Oct 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default problem - running script from springboard (solved)

    hi,

    when i tried to run scripts from springboard the first one was no problem (icon on springboard, scipt executed), but when i create a second "app" with the same info.plist there is no icon on the springboard to execute it.

    What do i have to change in the info.plist-file if i want to create/run more "apps" with my own script file? (CFBundleExecutable changed)

    info.plist :

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>CFBundleDevelopmentRegion</key>
    <string>English</string>
    <key>CFBundleExecutable</key>
    <string>app.sh</string>
    <key>CFBundleIdentifier</key>
    <string>com.unique.identifier</string>
    <key>CFBundleInfoDictionaryVersion</key>
    <string>6.0</string>
    <key>CFBundleName</key>
    <string>TEST</string>
    <key>CFBundlePackageType</key>
    <string>APPL</string>
    <key>CFBundleShortVersionString</key>
    <string>0.1.0</string>
    <key>CFBundleSignature</key>
    <string>????</string>
    <key>CFBundleVersion</key>
    <string>1.0</string>
    </dict>
    </plist>


    thx Luki14
    Last edited by Luki14; 10-07-2009 at 02:18 PM.



  2. #2
    Advanced Array

    Join Date
    Sep 2009
    Location
    Germany
    Posts
    39
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Luki14 View Post

    <string>com.unique.identifier</string>
    make sure you change this to a unique identifier.. both icons can't have the same identifier...

  3. #3
    Newbie Array

    Join Date
    Oct 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    thx spitphire, i changed the identifier, but it doesn't matter, there is only one of the two apps on the springboard.

    ...if i delete the other apps folder (test.app) in the /Applications/ dir, the icon is on the home screen and you can use it.

    mfg Luki14

  4. #4
    Newbie Array

    Join Date
    Oct 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    it works now, thx for the help!!!!

 

 

Similar Threads

  1. stuck on Running script HELP!!!!!
    By chrisjeymy1 in forum Installation
    Replies: 4
    Last Post: 09-11-2010, 09:42 PM
  2. Springboard Icon to Run Script?
    By bkhahn in forum Free Toolchain Software (Cydia App's)
    Replies: 10
    Last Post: 03-07-2010, 05:14 PM
  3. output script running from springboard
    By spitphire in forum Free Toolchain Software (Cydia App's)
    Replies: 2
    Last Post: 10-01-2009, 11:50 AM
  4. Running a script for a incoming call
    By t0pcat in forum General
    Replies: 2
    Last Post: 10-19-2007, 09:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:58 PM.
twitter, follow us!