Page 7 of 11 FirstFirst 1234567891011 LastLast
Results 61 to 70 of 110
Discuss iPhone Games - NES Emulator at the Free Toolchain Software (Cydia App's) - Hackint0sh.org; Don't really know what else I can tell you guys. The steps I detailed worked ...
  1. #61
    Advanced Array LuciferChaos's Avatar

    Join Date
    Aug 2007
    Location
    Chicago
    Posts
    35
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Don't really know what else I can tell you guys. The steps I detailed worked fine for me... I think nervegas said in his documentation that if you have the headphones plugged in when you do it, it won't work through the speakers after you unplug them. Are you doing the nosound while you have headphones plugged in? If so, don't have the headphones plugged in when you do nosound. But that shouldn't be the issue with the "no command" error... You guys have the bin-kit installed too right? Oh, and after you put the .profile onto your iPhone, you have to shut down the iPhone by holding the power button until the slider comes up to power off. Make sure you slide to power off completely, then restart. If you have done all of that, I can't say why it doesn't work for you...

    Also theres a new build - v0.28 - "0.28 [nervegas] Added save SRAM support (to save SRAM for games like Zelda)" - from the changelog
    Last edited by LuciferChaos; 08-11-2007 at 09:29 PM.


  2. #62
    Newbie Array

    Join Date
    Jul 2007
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I'm having the same problem. The sound works fine through my headphones, but not through the speaker. I have tried restarting my phone with my headphones unplugged and plugged in, as well as doing the nosound command both ways. The sound just doesn't come out of the speaker no matter what I try and the Speaker button at the top doesn't seem to do anything.

  3. #63
    Rookie Array

    Join Date
    Aug 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i've gotten it working through the speaker now.

    -install nesapp
    -reboot
    -run nosound from term
    -run nes

    just like luciferchoas said. for some reason mine is working now although i dont think i am doing anything different.

  4. #64
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    261
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    I got speaker to work too.

  5. #65
    Senior Professional Array theviolator's Avatar

    Join Date
    Jul 2007
    Posts
    145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    LuciferChaos, your setup works nicely....I cant understand NerveGas instructions..but yours works


  6. #66
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Quote Originally Posted by sizzle View Post
    quick question, I am able to add applications just fine, have ssh installed, I installed NESApp.app and it launches fine and i'm doing this from a mac. As I understand it, the ROMs must be put into /var/root/Media/ROMs/NES/ my question is does anyone know the exact command to enter in terminal to copy the Roms over there? it seems like what I am trying isnt working, thanks!
    Easiest way is to use a Windows/GUI based app to transfer the files in to the correct folders from the outset. Try WinSCP on Windows or rbrowser on MAC. You literally just drag and drop your files from PC/MAC to iphone this way (you'll need SSH server installed on iphone, which you say you have).

    If you'd prefer to do this via terminal session (directly on iphone) simply launch MobileTerminal on iphone, go to directory where the NES ROM files are located and move them over to the NES ROMS directory. e.g.

    cd /<FULLPATHOFDIRCONTAININGROMS>
    mv <ROMFILENAME> /var/root/Media/ROMs/NES/

  7. #67
    Advanced Array

    Join Date
    Aug 2007
    Posts
    31
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Can anyone help at all - I have installed the NES.app ok and it appears on my springboard, however when I launch it I just get a white screen then it goes back to the menu ?

    Any ideas !?!?

  8. #68
    Rookie Array ztaafen's Avatar

    Join Date
    Aug 2007
    Location
    Sundsvall, Sweden
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by xbrillx View Post
    Can anyone help at all - I have installed the NES.app ok and it appears on my springboard, however when I launch it I just get a white screen then it goes back to the menu ?

    Any ideas !?!?
    Do you have any ROMs (the games) instaleld? They don't come with the emulator.

  9. #69
    Advanced Array

    Join Date
    Aug 2007
    Posts
    31
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Ignore my last post - all sorted now.

    Just needed to :


    chmod +x /Applications/NESApp.app/*
    chmod +x /var/root/Media/ROMs/NES/*

  10. #70
    Senior Professional Array theviolator's Avatar

    Join Date
    Jul 2007
    Posts
    145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    chmod +x /var/root/Media/ROMs/NES/*
    <---- You dont need to do that Roms dont need to be executable


 

 

Similar Threads

  1. [Emulator] GBA and NES can't save games
    By joelsveda in forum Free Toolchain Software (Cydia App's)
    Replies: 12
    Last Post: 08-27-2008, 11:25 AM
  2. iphone nes emulator?
    By Tupapi in forum General
    Replies: 6
    Last Post: 10-24-2007, 12:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:29 AM.
twitter, follow us!