Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Discuss BSD Subsystem and 1.1.1 at the Free Toolchain Software (Cydia App's) - Hackint0sh.org; I completed the whole jailbreak process on my phone to 1.1.1. The readme for the ...
  1. #1
    Newbie Array

    Join Date
    Oct 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default BSD Subsystem and 1.1.1

    I completed the whole jailbreak process on my phone to 1.1.1. The readme for the process says to upload the BSD system to the phone along with some extras. I did this and finished everything. Now I have AppTapp running and when I try to install Apollo IM it told me I needed to instal the BSD subsystem first.

    Am I going to have any problems if I install this BSD subsystem over the one in the jailbreaking process?



  2. #2
    Advanced Array rklosinski's Avatar

    Join Date
    Sep 2007
    Posts
    42
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I used the ssh installation instructions here

    http://forums.macrumors.com/showthre...81#post4308881

    its was a pain, but it worked

  3. #3
    Senior Professional Array

    Join Date
    Aug 2007
    Location
    Australia
    Posts
    166
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    Quote Originally Posted by mike9285 View Post
    Am I going to have any problems if I install this BSD subsystem over the one in the jailbreaking process?
    Great question, I understood that the BSD subsystem installed during the jailbreak of 1.1.1 was just an updated version of the original one, optimised to work with the 1.1.1 frameworks. So I'd probably suggest not installing the one from AppTapp, as it's more likely that the Apollo IM app just needs to be recompiled for the 1.1.1 frameworks rather than you having done something wrong whilst jailbreaking...

    I think it might be the same for quite a few of the old apps, but someone correct me if other people have this working?

  4. #4
    Advanced Array

    Join Date
    Sep 2007
    Posts
    33
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I got it working by "fooling" Installer.app that I had the BSD Subsystem application installed.

    Edit the file /var/root/Library/Installer/LocalPackages.plist and add the following

    Code:
            <dict>
                    <key>bundleIdentifier</key>
                    <string>com.natetrue.iphone.iphone_binkit</string>
                    <key>category</key>
                    <string>System</string>
                    <key>contact</key>
                    <string>iphone@nullriver.com</string>
                    <key>date</key>
                    <string>1189568672</string>
                    <key>description</key>
                    <string>Unix tools for the iPhone.</string>
                    <key>location</key>
                    <string>http://conceitedsoftware.com/iphone/zips/BSD_Subsystem-1.5.zip</string>
                    <key>maintainer</key>
                    <string>Nullriver, Inc.</string>
                    <key>name</key>
                    <string>BSD Subsystem</string>
                    <key>scripts</key>
                    <dict>
                            <key>install</key>
                            <array>
                                    <array>
                                            <string>CopyPath</string>
                                            <string>bin</string>
                                            <string>/bin</string>
                                    </array>
                                    <array>
                                            <string>CopyPath</string>
                                            <string>sbin</string>
                                            <string>/sbin</string>
                                    </array>
                                    <array>
                                            <string>CopyPath</string>
                                            <string>usr</string>
                                            <string>/usr</string>
                                    </array>
                                    <array>
                                            <string>CopyPath</string>
                                            <string>var</string>
                                            <string>/var</string>
                                    </array>
                                    <array>
                                            <string>CopyPath</string>
                                            <string>System</string>
                                            <string>/System</string>
                                    </array>
                                    <array>
                                            <string>CopyPath</string>
                                            <string>etc</string>
                                            <string>/etc</string>
                                    </array>
                            </array>
                    </dict>
                    <key>size</key>
                    <string>6967995</string>
                    <key>source</key>
                    <string>http://iphone.nullriver.com/</string>
                    <key>url</key>
                    <string>http://iphone.natetrue.com/</string>
                    <key>version</key>
                    <string>1.5</string>
            </dict>
    You then should be able to install software that requires the BSD Subsystem. Apollo works for me! Just don't update or uninstall this package, as it may cause unwanted ... effects.

  5. #5
    Senior Professional Array

    Join Date
    Aug 2007
    Location
    Australia
    Posts
    166
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    Nice job When upgrading to 1.1.1, do you lose all your installed apps (ie. SSH, BSD, NES etc etc) or are they all still there and you can re-link them to springboard?

    Just curious if you have to get installer.app and start afresh.


  6. #6
    Advanced Array

    Join Date
    Sep 2007
    Posts
    33
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by ricochet View Post
    Nice job When upgrading to 1.1.1, do you lose all your installed apps (ie. SSH, BSD, NES etc etc) or are they all still there and you can re-link them to springboard?

    Just curious if you have to get installer.app and start afresh.
    All of the applications themselves were gone, however their preferences were intact.

    For those who don't know you can't install Installer.app with it's installer, you need to pull it out of the installer by right clicking it and clicking "Show Package Contents" and going to /Contents/Resources and taking the Installer.app from there and scp it over manually to /Applications on the iPhone, then edit the /System/Library/CoreServices/SpringBoard.app/M68AP.plist file and put it in there before the MobileStore entry like so:

    Code:
    <dict>
         <key>displayIdentifier</key>
         <string>com.nullriver.iphone.Installer</string>
    </dict>
    I'm not sure how to get into packages in Windows though...
    Last edited by Ra'jel; 10-12-2007 at 10:27 AM.

  7. #7
    Newbie Array

    Join Date
    Oct 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hey Ra'jel, do you know why the documentation says to edit that plist and put everything before MobileStore? I read that icons won't show up if they are listed after the MobileStore, but mine show up just fine. It doesn't seem like there are any negative side effects either.

  8. #8
    Advanced Array

    Join Date
    Sep 2007
    Posts
    33
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by mike9285 View Post
    Hey Ra'jel, do you know why the documentation says to edit that plist and put everything before MobileStore? I read that icons won't show up if they are listed after the MobileStore, but mine show up just fine. It doesn't seem like there are any negative side effects either.
    Not sure why, I just do it anyways..

  9. #9
    Newbie Array

    Join Date
    Sep 2007
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Did anyone test the BSD Subsystem 1.5 with 1.1.1? Or does anyone know if BSD Subsystem 2.0 will ever be available via Installer.app?

    Thanks.

  10. #10
    The Computer Guy! Array compuguy1088's Avatar

    Join Date
    Sep 2007
    Location
    In the Sub-Basement of Solitude
    Posts
    112
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by pvanberlo View Post
    Did anyone test the BSD Subsystem 1.5 with 1.1.1? Or does anyone know if BSD Subsystem 2.0 will ever be available via Installer.app?

    Thanks.
    That would be a great thing if they would update that package!


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. [1.1.3] Need SSH without BSD Subsystem...how?
    By Mark151 in forum General
    Replies: 7
    Last Post: 02-27-2008, 06:32 PM
  2. Getting rid of BSD Subsystem ..?
    By Xarvik in forum General
    Replies: 16
    Last Post: 10-28-2007, 10:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:42 PM.
twitter, follow us!