Page 1 of 2 12 LastLast
Results 1 to 10 of 19
Discuss [1.1.3] Soft Updated > Installer crashes at the Free Toolchain Software (Cydia App's) - Hackint0sh.org; I did the official Dev Team Upgrade and all went just fine. Now the problem ...
  1. #1
    Newbie Array

    Join Date
    Dec 2007
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [1.1.3] Soft Updated > Installer crashes

    I did the official Dev Team Upgrade and all went just fine.

    Now the problem is that I can't install anything, so I reinstalled Installer (via the button on the right upper corner of the "uninstall" tab) and now when I try to open Installer it inmediatly crashes... What can I do now???



  2. #2
    Newbie Array

    Join Date
    Oct 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I had the same issue. I, myself, couldn't solve it, so I just reverted back to 1.1.2 and I'm going to wait for all the kinks to be worked out in the coming weeks.

  3. #3
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    207
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    Quote Originally Posted by marco_lugo00 View Post
    I did the official Dev Team Upgrade and all went just fine.

    Now the problem is that I can't install anything, so I reinstalled Installer (via the button on the right upper corner of the "uninstall" tab) and now when I try to open Installer it inmediatly crashes... What can I do now???
    Just a thought - Your Installer is an old version - make sure you REFRESH the sources list and then you may see that there is the latest version - Start there

  4. #4
    Newbie Array

    Join Date
    Dec 2007
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default .

    Actually I had the latest version of both, BSD subsystem and Installer...

  5. #5
    Newbie Array

    Join Date
    Oct 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Xserve2 View Post
    Just a thought - Your Installer is an old version - make sure you REFRESH the sources list and then you may see that there is the latest version - Start there
    I insured that I was running the latest version of Installer (3.0b10). These crashes that occured whenever I tried to install ANY package via installer 3.0b10, not a previous version.


  6. #6
    Newbie Array

    Join Date
    Dec 2007
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    But my actual problem is that now I tap on Installer icon, it opens an all white screen like 1 second and then crashes back to the Home screen. I haven't ssh installed, and now I dont know what to do.

  7. #7
    Former Bender
    Guest

    Default

    Manually reinstall it with iBrikr

  8. #8
    Professional Array

    Join Date
    Nov 2007
    Posts
    73
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Can someone please help me? I had an OTB 1.1.2, and I used the dev team jailbreak to 1.1.3.

    Now everytime I try and install something from Installer, I get the error message: "Main script execution failed"

    What can I do to fix this please?

  9. #9
    Professional Array

    Join Date
    Jan 2008
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Arrow

    Ok these are actually two very simple problems!

    First, the solution to the "Main script execution failed" error.
    Make sure you are running Installer 3.0b10 and connect to your phone via SSH with Putty (Terminal on OSX?) then issue the following commands:
    Code:
    cd /Applications
    chmod +s Installer.app/Installer
    chown -R root:wheel Installer.app
    This allows Installer.app to be run under the 'mobile' user. This should only be necessary with the Dev Team method because they have everything setup to run under the 'mobile' user or something (as it should be to be compatible with the SDK). Nate's method doesn't set you up this way, so this fix shouldn't be needed, but the SDK might be broken... time will tell.

    Second, the problem with Installer crashing on the "Installing..." step is that you are simply out of room on your root partition! The 1.1.3 Firmware is the biggest yet, and almost completely fills the ~300mb root partition (especially once BSD, SSH, and Installer have been installed). After these three are installed (which everyone really should have), you are left with like 1mb left in your root partition on 1.1.3. Obviously, not enough. There are guides out there on how to move your /Applications folder to your /private/var partition so I'll leave you to find them yourselves. Bosstool.app used to do this for you, but seems to be broken with 1.1.3. Also note that most of the guides have you copy your Applications directory to /var/root... I think with 1.1.3 (Dev Team method at least) this should be changed to /var/mobile.

    Umm.. I think that's it, any questions?

  10. #10
    Rookie Array

    Join Date
    Oct 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    OK.. What about those people who have tried the following.. and the installer still crashes back to the desktop every time it is run..

    Reinstalling installer.app manually. (From Versions year dot through to current)

    Have cleared root partition space.

    Have moved apps to larger partition.

    Have tried various commands via ssh to remove temp directories etc.

    Anyone, please!?!

    This happens to me on 1.1.1 and 1.1.3


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 05-08-2008, 04:51 PM
  2. Replies: 7
    Last Post: 02-11-2008, 02:24 PM
  3. Replies: 0
    Last Post: 02-09-2008, 01:47 AM
  4. Updated Installer, now crashes!!
    By cuaresmatic in forum Free Toolchain Software (Cydia App's)
    Replies: 0
    Last Post: 01-30-2008, 02:13 PM
  5. Updated Installer, now crashes!!
    By cuaresmatic in forum Free Toolchain Software (Cydia App's)
    Replies: 0
    Last Post: 01-30-2008, 02:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:13 AM.
twitter, follow us!