any firmware will do, either 1.1.1 or 1.0.2

pm me if anyone has any for sale

thanks