Hi,

Im interested in a CommBoard, which holds 04.02.13_G or lower...Bootloader could be 4.6 oder 3.9, with 3.9 preferred. And of course it should be working

Also searching for a Rear Cover with no damages done by opening...

Im located in Germany.

Just send me a PM, if you got something to offer.