Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28
Discuss Blacksn0w & 3.1.3 - 5.11.07 ONLY! at the Blacksn0w (3G(S) unlock) - Hackint0sh.org; Originally Posted by sajberista Anything new? I would like to test something, if you need? ...
  1. #21
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by sajberista View Post
    Anything new? I would like to test something, if you need?
    I don't have the skills to really interpret that crash log, need to wait for the original author of this patch to check it out. Or geohot if he could drag himself away from PS3 hacking.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!


  2. #22
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by Olethros View Post

    Initial reports I have seen are that this patch works for 3GS but not for 3G iPhones, there could be other explanations for this (different telephone carriers). We need more test results to be sure.
    Olethros,
    I tested this on iphone 3G with tmobile US.
    When I launchctl unload, launchctl load, launchctl start - it started to search but did not lock in the signal. I decided to backup my com.apple.CommCenter.plist and copy over the one that came with blacksn0w then shutdown the phone, then start the phone. It worked.
    ** If you just want to support hackint0sh.org with a donation click here **

  3. #23
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by Dirkdiggler View Post
    Hi,
    first of all thanks for you help.

    i also opened ssh and connected to iphone via fugu, where I am able to submit a command. I did this also on root level.
    So where did you type in that command?
    BR
    Pat
    i typed it in at the command prompt #.
    Like i said in previous post, typing in the command did not immediately lock in the signal for me. I had to copy the com.apple.CommCenter.plist to /System/Library/LaunhDaemons (back up the original one first) then shutdown and startup phone again.

    Remember, you have to chmod 755 blacksn0w.dylib after you copy it to /usr/lib
    ** If you just want to support hackint0sh.org with a donation click here **

  4. #24
    Newbie Array

    Join Date
    Mar 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dtube View Post
    i typed it in at the command prompt #.
    Like i said in previous post, typing in the command did not immediately lock in the signal for me. I had to copy the com.apple.CommCenter.plist to /System/Library/LaunhDaemons (back up the original one first) then shutdown and startup phone again.

    Remember, you have to chmod 755 blacksn0w.dylib after you copy it to /usr/lib
    I do this like you said chmod 755 to blacksn0w.dylib and overwrite commenter file but when i restart my phone only restarting. Any solution?

  5. #25
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    i have no idea what you did.
    I tried it on my 3g running OS 3.1.3 with 05.11.07 Baseband and it worked.
    ** If you just want to support hackint0sh.org with a donation click here **


  6. #26
    Rookie Array

    Join Date
    Oct 2009
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    The big news here is not only did msft.guy get blacksn0w running under 3.1.3, he also fixed a bug at the same time.

    I have a 3GS at 3.1.2 and one at 3.1.3, both with 05.11.07 baseband. The 3.1.2 phone needed "Reset network settings" almost every time I powered it off. The 3.1.3 phone was not unlockable until now (no 3.1.2 SHSH on file).

    On his blog, msft.guy noted that he fixed something in blacksnow:

    I also changed the patch from mov r1, 1 to mov r0, 1 because I suspect that's what it was supposed to do, instead of returning whatever garbage CFRelease left in r0 :-)
    So, I decided to do the same thing on my 3.1.2 phone with regular blacksn0w. I patched blacksn0w.dylib and used ldid to fix the signatures. To my surprise, the WiFi bug appears to be gone! I have powered off and on 6 times and each time WiFi works right away. I have also used SBSettings to reboot the phone several times and that also works.

    This bug looks like it was causing the user to have to "Reset network settings" all the time on some phones, probably due to some kind of corruption.

    I am going to continue to do some more testing and try to contact Geohot.

    msft.guy : Please PM or contact me if you would: info AT pushfix.info

  7. #27
    Supporter Array

    Join Date
    Mar 2010
    Posts
    68
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    @dtube: thanks, totally forgot about chmod
    @sajberista: if you can port-forward SSH on your phone, I can take a look.
    GTalk: msft.guy аt gmail.com

  8. #28
    Newbie Array

    Join Date
    Mar 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    thanks msft.guy
    it worked flawlessly on iphone 3gs custom fw. 3.1.3
    downloaded modified package via cydia from pushfix.info and voila!

    update. downloaded package somehow conflicts with appsync. when appsync installed unlock doesn't work. manual install from the first post gets rid of this problem, works fine afterwards.
    update2. i have forgot to do chmod on .dylib, but funny thing, it works anyway.
    Last edited by Felar Furlong; 03-28-2010 at 05:13 PM.

 

 
Page 3 of 3 FirstFirst 123

Similar Threads

  1. Blacksn0w issues
    By Nightroamer in forum Blacksn0w (3G(S) unlock)
    Replies: 8
    Last Post: 06-13-2010, 02:15 AM
  2. Blacksn0w with spirit??
    By xequtor in forum Spirit (jailbreak)
    Replies: 6
    Last Post: 05-05-2010, 02:07 PM
  3. Blacksn0w RC2 Final
    By Pushfix in forum Blacksn0w (3G(S) unlock)
    Replies: 10
    Last Post: 04-22-2010, 01:47 AM
  4. Blacksn0w RC2 Final
    By Vincentec in forum Blackra1n (3G(S) jailbreak)
    Replies: 0
    Last Post: 04-13-2010, 06:32 PM
  5. help with blacksn0w and 3.1.3 with 5.11 baseband
    By aarons6 in forum Blacksn0w (3G(S) unlock)
    Replies: 1
    Last Post: 03-05-2010, 07:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:35 PM.
twitter, follow us!