Page 1 of 14 1234567891011 ... LastLast
Results 1 to 10 of 140
Discuss RESOLUTION: Blacksn0w Reboot Loop / No WiFi Signal / Reset Network Settings / Unlock at the Blackra1n (3G(S) jailbreak) - Hackint0sh.org; In order to quell the rising number of posts that we have in relation to ...
  1. #1
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Exclamation RESOLUTION: Blacksn0w Reboot Loop / No WiFi Signal / Reset Network Settings / Unlock

    In order to quell the rising number of posts that we have in relation to this issue, I'm putting everything into one post and will make it sticky.

    ISSUE:
    iPhone 3G/S gets stuck on a boot loop where the phone boots, shows the Apple logo (or GeoHot's face, depending on where you get the error), gives the Apple spinner, sits, then reboots, and repeats the process over and over. Alternately, the iPhone 3G/S gets stuck on a boot loop, shows the Apple Logo (or Geohot's face), gives the Apple spinner, and sits. This usually occurs on iPhone 3GS models with the latest bootrom, after a user has told the device to "Reset Network Settings" after WiFi connectivity has been lost. The problem can also occur if after the iPhone soft reboots after you have lost WiFi connectivity, for example, after an application install such as MobileSubstrate / SBSettings.

    CAUSE:
    This is caused by a race condition that exists on the iPhone 3G/S related to the WiFi implementation and is UNRELATED to the jailbreak and unlock itself -- this occurs on both jailbroken and unjailbroken phones as well as carrier-locked and software-unlocked phones. Admittedly, it occurs more with soft-unlocked devices, but this is because the unlock exacerbates the existing problem with the race condition -- not because the unlock is unstable or potentially dangerous (it's not!). Quite the contrary, the most updated unlock actually resolves the race condition -- which Apple's own software still has yet to resolve. That said, this issue CAN be fixed in several methods and the newest version of blacksn0w (RC2 Final) contains a fix that solves this problem permanently.

    UPDATE: Preferred FIX #1: (This only applies if you: ARE using an iPhone 3GS, DO NOT have a 3.1.2 SHSH on file, HAVE NOT previously upgraded to 3.1.3, and HAVE a legitimate SIM to activate with)
    1) Follow the steps as documented by the dev team here: http://wikee.iphwn.org/howto:removellb
    2) FOLLOW THE STEPS VERY, VERY CAREFULLY. Understand that this is a LAST DITCH effort -- if you do this wrong, go too quickly, don't follow instructions, or ignore a warning, YOU WILL make the situation worse.
    3) This process completes with your phone being restored to 3.1.3 without the baseband being updated.
    4) Use the latest Spirit to jailbreak.
    5) Use Blacksn0w RC2 to unlock.

    FIX #2: (Not as reliable as FIX #1, but has less prerequisites and doesn't require re-flashing)
    1) Download the latest version of blackra1n.
    2) Plug the phone into your iPhone USB connector, plugged into a Windows machine running iTunes and blackra1n.
    3) The phone will show as connected but will NOT charge. THIS IS EXPECTED BEHAVIOR.
    4) Keep blackra1n open and keep the phone plugged in, and go do something for 8 to 12 to 16 hours. This is a VERY IMPORTANT STEP.
    5) When you come back to your phone/PC, your phone should be at the home screen and charged.
    6) If you have WiFi when your phone reboots, open Cydia, add the devteam's source (cydia.pushfix.info) and update Blacksn0w to RC2.

    IF YOU HAVE NO WIFI AFTER COMPLETING FIX 2:
    1) Uninstall blacksn0w (either remove the package from Cydia, or remove /usr/lib/blacksn0w.dylib and re-add the original com.apple.CommCenter.plist)
    2) Reboot your phone.
    3) You should now have WiFi back.
    4) Add the Blacksn0w repository (cydia.pushfix.info) and install Blacksn0w RC2
    5) Reboot your phone

    WHAT IS REALLY HAPPENING:
    When the phone gets stuck in the reboot loop, it is unable to charge via the USB connector plugged into the PC because the iPhone doesn't get that far in the boot process before the race condition exhibits. The device gets far enough to mount the root filesystem and to provide filesystem access over USB, however. When you leave it plugged in and walk away, what you're really doing is allowing the iPhone to completely discharge its battery. When it does this, it will power off. Once it has powered off, it will begin charging via the USB cable. Once it has sufficient charge to power on, it will power on. During the power-on process, blackra1n will see the iPhone and will kickstart it.

    This should return your phone to 100% working (and unlocked!) status.

    If anyone has any additions or corrections, post them in the comments below and I'll keep this updated.
    Last edited by dtube; 05-13-2010 at 09:08 AM. Reason: Added LLB removal / updated fix. - remove pwnagetool in step 4 in fix#1
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  2. Thanks cotarelo thanked for this post.


  3. #2
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    @n1ckn4m3,
    Thanks for making this sticky post.
    From what I have observed, this boot-loop issue happens to more iphone 3GS (with new bootrom) than on iphone 3G and 3GS with old bootrom.

    Most often, people with 3GS new bootrom got into this problem when they lost wifi and they performed a "reset network settings". Also, this problem can occur after a soft reboot (like after installing mobilesubstrate / sbsettings).

    For users who follow steps above and able to the phone again, the question is what can you do at this point. Well ... this has several scenarios:

    Scenario 1: Iphone booted up and still no-wifi.
    - In this case, your only option is to remove blacksn0w unlock temporarily.

    If you installed blacksn0w via cydia, uninstall is easy.

    If you installed blacksn0w via blackra1n.app on the phone, removal is tricky because there is no uninstall for it. In this case, if you had openssh on the phone, you can ssh to /usr/lib and take out blacksn0w.dylib and put back the original com.apple.CommCenter.plist

    - Once blacksn0w is removed, you can reboot the phone and it should bootup ok.

    - Now, use cydia, put in source Cydia.pushfix.info and install Blacksn0w RC2 Final. This modified version should help with the reboot-loop issue.

    Scenario 2: iphone booted up and has wifi.

    - In this case, go ahead and use Cydia, add in source Cydia.pushfix.info and update your existing blacksn0w unlock to Blacksn0w RC2 Final.

    Good luck
    Last edited by dtube; 04-23-2010 at 08:00 AM.
    ** If you just want to support hackint0sh.org with a donation click here **

  4. #3
    Newbie Array

    Join Date
    Apr 2010
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    hi!2
    first, let me thanyou for the solution, and please forgive me for my "bad english" i think i have the same problem, but i'm not sure if the solution applies in my case.
    In my case after GeoHot's face, the phone goes black (i think it turns off because is not backlight). So there's no loop, i have to turn it on manually.
    But the origin is the same, i've installed SBsettings on cydia, then reboot the phone and then i'm stuck here.
    If you think this is the same problem, please give me more details on the solution:
    - i have to connect the phone on Recovery Mode, DFU or something else??
    - in my case, before GeoHot's face, the phone turns off, so do you think the battery will discharge ?
    - Sometimes, and i dont know how, the phones doesn't show GeoHot's face, just itunes logo, and then after 10 minutes reboot and then again. i have to reach this state? How can i do it??

    Thanks in advance, and please erase this post if this doesn't goes here.

  5. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by paburox View Post
    i think i have the same problem, but i'm not sure if the solution applies in my case.
    In my case after GeoHot's face, the phone goes black (i think it turns off because is not backlight). So there's no loop, i have to turn it on manually.
    But the origin is the same, i've installed SBsettings on cydia, then reboot the phone and then i'm stuck here.
    Don't assume that installing SBSettings from Cydia then restarting will always cause this specific problem. Can you clarify in more detail what happened in your case.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  6. #5
    Newbie Array

    Join Date
    Apr 2010
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    hi
    after jailbreak of a new 3gs iphone with 3.1.2 firmware using blackra1n, everything was like usual. Phone booted, then from blackra1n icon i've installed Cydia. Then on Cydia, i accepted complete upgrade, then i installed Sbsettings.
    When it finished, asked me to reboot the device like always. When Itunes's icon shows up, run Blackra1n, Geohot's face shows up for about 5 seconds, then phone screen goes black. You can turn the phone on, manually then repeat the process and the same happens.

    i hope you can help me,

    thanks in advance


  7. #6
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by paburox View Post
    hi
    after jailbreak of a new 3gs iphone with 3.1.2 firmware using blackra1n, everything was like usual. Phone booted, then from blackra1n icon i've installed Cydia. Then on Cydia, i accepted complete upgrade, then i installed Sbsettings.
    When it finished, asked me to reboot the device like always. When Itunes's icon shows up, run Blackra1n, Geohot's face shows up for about 5 seconds, then phone screen goes black. You can turn the phone on, manually then repeat the process and the same happens.

    i hope you can help me,

    thanks in advance
    This is likely not the same situation -- the race condition exhibits when you lose WiFi and then the phone reboots, and as the sticky post states, is usually associated with 3GS devices that have been soft-unlocked, and you don't mention having unlocked the device at any step, nor does your phone exhibit the behavior explained above -- you're having a different issue altogether, related to the jailbreaking process itself. When you reboot the phone after it turns off, is it still jailbroken? If so, why are you running blackra1n again on the device in the first place? You should only need it to kickstart if you're using a 3G/3GS with the latest bootrom. Once you've jailbroken the device once, you don't need to do it again.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  8. #7
    Newbie Array

    Join Date
    Apr 2010
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    thanks,
    the iphone is still jailbroken after reboot, and yes, the phone has the latest bootrom, so i need to run blackra1n again to kisckstart.

  9. #8
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by paburox View Post
    thanks,
    the iphone is still jailbroken after reboot, and yes, the phone has the latest bootrom, so i need to run blackra1n again to kisckstart.
    OK, that is behavior by design -- running blackra1n again on the phone is unnecessary after it has kickstarted. Since you're not using the soft-unlock, I'm not sure I know what problem you're experiencing -- the phone works fine once it has been kickstarted, correct? If so, then that is to be expected -- the new bootrom requires the kickstart in order to boot.

    If you're still having trouble, let me know what you're trying to accomplish and we should be able to help.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  10. #9
    Newbie Array

    Join Date
    Apr 2010
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    thanks,
    maybe i'm not understanding well, or i am not stating correctly.
    The iphone has 3.1.2 with new bootrom, and i did the jailbreak with blackra1n.
    Then after a reboot request on Cydia, i can't use the phone. Whe you turn it on, shows apple image, then itunes icon with the usb plug. That's because its a tethered jailbreak. Normally, i run blackra1n again and after GeoHot's picture the iphone starts.
    What's happening now it's that after Geohot's picture the screen shuts off. And the phone does nothing.

  11. #10
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by paburox View Post
    thanks,
    maybe i'm not understanding well, or i am not stating correctly.
    The iphone has 3.1.2 with new bootrom, and i did the jailbreak with blackra1n.
    Then after a reboot request on Cydia, i can't use the phone. Whe you turn it on, shows apple image, then itunes icon with the usb plug. That's because its a tethered jailbreak. Normally, i run blackra1n again and after GeoHot's picture the iphone starts.
    What's happening now it's that after Geohot's picture the screen shuts off. And the phone does nothing.
    Gotcha. My mistake. In this case, I would recommend making sure you have the latest version of blackra1n first. Make sure you don't have the latest version of iTunes if you are using Windows, it interferes with blackra1n. If that doesn't help, you may want to use your SHSH (do you have one on file for 3.1.2?) and do a restore to 3.1.2, then jailbreak using redsn0w. It's a much more reliable and robust tool. That should bring the phone back to working, then only use blackra1n for the kickstart -- that's what it's best at, but it really provides an inferior jailbreak compared to redsn0w.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!



 

 
Page 1 of 14 1234567891011 ... LastLast

Similar Threads

  1. No Signal, No Wifi, No Carrier option in settings. please help
    By Duncan 'Fresher' Stafford in forum iOS 4.x (iPhone OS 4.x)
    Replies: 0
    Last Post: 09-10-2011, 06:12 PM
  2. Replies: 1
    Last Post: 09-28-2010, 02:12 PM
  3. Replies: 7
    Last Post: 03-25-2010, 08:58 PM
  4. Replies: 0
    Last Post: 01-28-2008, 04:50 PM
  5. Replies: 2
    Last Post: 09-26-2007, 06:59 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:28 PM.
twitter, follow us!