Results 1 to 2 of 2
Discuss is there a way to automatically use -legacy flag? at the Archiv (Leopard) - Hackint0sh.org; Hi, is there a way to configure Tiger to automatically use the -legacy flag? TIA...
  1. #1
    Newbie Array

    Join Date
    Dec 2007
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question is there a way to automatically use -legacy flag?

    Hi, is there a way to configure Tiger to automatically use the -legacy flag?

    TIA



  2. #2
    Newbie Array

    Join Date
    Oct 2006
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yes, edit your /Library/Preferences/SystemConfiguration/com.apple.Boot.plist file
    by adding -legacy under "Kernel Flags" key like this:
    Code:
    <key>Kernel Flags</key>
    <string>-legacy</string>
    you can use more than just one string:
    Code:
    <key>Kernel Flags</key>
    <string>-v -legacy</string>
    just make sure you're logged in as root when editing com.apple.Boot.plist because administrator rights are not enough.

    simplest way is:
    - in terminal, type 'sudo -s' (without the quotes)
    - enter your password when asked
    - type 'nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist' (no quotes)
    - edit the file
    - when done, press Ctrl-o to save (your pc Ctrl, not mac command key) and Ctrl-x to exit

    that's it
    Last edited by zarac; 12-26-2007 at 02:33 AM.

 

 

Similar Threads

  1. Only cpus=1 flag boot working
    By Charles Lunn in forum Using Leopard
    Replies: 0
    Last Post: 04-11-2011, 11:29 AM
  2. with boot 132 use -f flag
    By idorux in forum Installation
    Replies: 0
    Last Post: 03-30-2010, 09:10 PM
  3. Can't boot without Busratio=30 flag
    By Techguy in forum Installation
    Replies: 0
    Last Post: 03-02-2010, 10:19 PM
  4. OMN'S DSDT FIX, getting Past CPUS=1 Flag
    By originalmacnut in forum Hardware
    Replies: 32
    Last Post: 07-09-2009, 03:27 PM
  5. iDeneb v1.4 only boots with -x flag
    By Ravester in forum Installation
    Replies: 3
    Last Post: 06-15-2009, 05:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:10 PM.
twitter, follow us!