Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Discuss Screensavers crash on AMD 1049 at the Archiv (Leopard) - Hackint0sh.org; So I just noticed that certain screensavers are crashing system prefs when i try to ...
  1. #1
    Professional Array

    Join Date
    Nov 2006
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default Screensavers crash on AMD 1049

    So I just noticed that certain screensavers are crashing system prefs when i try to select them in 10.4.9. They all work fine on 10.4.8

    Flurry, computer name, RSS, iTunes artwork, and spectrum work GREAT...

    The others that require slides DON'T --> Beach, cosmos, nature, paper shadows, forest...
    When I try and select them, system prefs crashes...attached is the log...

    AMD Venice 3400+ running 10.4.9
    Attached Files



  2. #2
    Newbie Array

    Join Date
    Oct 2006
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    same problem with changing screensavers here
    (i attached the crash log)

    cpu: AMD athlon64 3200+ (939) - sse3
    mobo: ASUS a8v (via k8t800 pro, vt8237)
    gpu: NVIDIA 7600gt agp 256mb (gainward golden sample)

    installed using tubgirl's OSX_1048_AMD.iso and upgraded to tubgirl's 10.4.9_test using netkas's instructions from his blog (also downloaded amd 8.9.1 kernel and some other files from irc.osx86.hu - room #1049)
    using agpgart v2.1, natit v0.02 dual, and nvidiaEFI v1.02

    btw, can you open "Extensions" in "System profiler"?
    it crashes on me as well
    Attached Files

  3. #3
    Professional Array

    Join Date
    Nov 2006
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    yeah, i can open extensions in system profiler without a problem...

    but still clueless about the saver issue..

  4. #4
    Newbie Array

    Join Date
    May 2006
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I just tried updating my nForce4 AMD maching to 10.4.9 with 8.9.1 kernel. Screensaver options are opening up just fine here, just a ton of other problems (USB2, About crash, few minor issues). Used Netkas update method.

  5. #5
    Professional Array

    Join Date
    Nov 2006
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Maybe it's an opengl framework or soemthin that's not cpuid patched?

    Can ANYONE on AMD test this to see if they have screen savers?
    DK


  6. #6
    Professional Array

    Join Date
    Sep 2006
    Posts
    94
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    I can confirm this is happening with a P4 sse2 processor too (8.9.1 kernel).
    It doesnt happen if I replace the kernel with the 8.8.1
    Last edited by blackchungo; 04-11-2007 at 01:26 AM.

  7. #7
    Newbie Array

    Join Date
    Mar 2007
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Same problem here. Selecting the Screen Savers tab in "Desktop & Screen Savers" in System Preferences crashes System Prefs on my Pentium M SSE2 machine when running the 8.9.1 kernel. The crash does not happen if I replace the kernel with the older 8.8.1.

  8. #8
    Professional Array

    Join Date
    Nov 2006
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Holy smokes! It is a 10.4.9 kernel issue!

    Just went back to 10.4.8 kernel (ND-23) and now the savers work...

    maybe the 1049 kernel not playing nice?
    Last edited by kramer2k; 04-10-2007 at 11:14 PM.

  9. #9
    Newbie Array

    Join Date
    May 2006
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi all ,

    I have the same problem with screensaver with the new kernel Intel SSE2 8.9.1
    I replaced it with the 8.8.1 and all is ok now.

    Just for your information

  10. #10
    Newbie Array

    Join Date
    Apr 2007
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Division by zero in ASI_NumberOfCPUs, eh? Perhaps netkas should hack this into 10.4.9's cpuid_set_info function:
    //Bug in Northwood HHT P4 and possibly some AMD multicore
    if (cpuid_cpu_info.cpuid_cores_per_package == 0)
    cpuid_cpu_info.cpuid_cores_per_package = 1;
    In the meantime, could one of you post your "sysctl -a" output? Wouldn't be surprising if there's a suspicious zero value for a variable such as ncpu, cores_per_package, etc.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 04-12-2011, 06:10 PM
  2. Ghosts/Artifacts in Menu Headings, Translucent Menubar, Unavailable Screensavers
    By blueroses79 in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 08-15-2010, 06:24 AM
  3. [apps][possible crash?] which apps can crash the iphone
    By rbby228 in forum Free Toolchain Software (Cydia App's)
    Replies: 1
    Last Post: 09-17-2008, 02:39 PM
  4. Please help! 1.1.2 sms crash
    By HB328_DTDD in forum General
    Replies: 6
    Last Post: 01-13-2008, 01:46 PM
  5. After update to 1049 AMD Myzar, USB devices funky
    By desynch in forum Archiv (Leopard)
    Replies: 0
    Last Post: 04-18-2007, 03:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:18 AM.
twitter, follow us!