There's a few games that I'd like to get from the app store which only run on 2.2.1 FW. I'm running 2.2 and I don't want to upgrade to 2.2.1 just so I can run them.

Is there any way to patch the games ipa so that I can run it on 2.2?