i'm having problems and wondering how to fix this.

i just upgraded to 2.0.2 using winpwn 2.5beta
everything went smooth
but now my collection of app store apps and games wont work anymore.

I SSH into my iphone and copy some folders over to /applications then i chmod (recursively) the folder to 0775
i respring and or reboot the iphone, but the app does not appear on the springboard??

this is the exact steps i did for 2.0

i place a folder called documents inside \applications and one in \mobile
i chmod them both to 0777
no change

i even tried copying over the hacked mobileinstallation file but no luck

i use itunes 771
before i upgraded to 2.02 i backed up my apps folder
such examples is like phonesaber, its a simple free app, i place it in /applications chmod it to 775, respring
but it simply wont appear

now i tried this with another app and that one worked but its the only one i got to work so i'm confused

can any one throw me a bone please

yes its true i can use app store to download them but i have some apps and games that are not on the app store that worked fine on 2.0 and wish to add to 2.0.2
honestly i'd rather do it via ssh that way i know whats going in my fone, i'd rather learn how to do ti myself, i wish to learn and understand why it works and or does nto.