Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Discuss [Video] QE/CI/Rotation on AppleTV OSX Install at the AppleTV 1 - Hackint0sh.org; Looks like crap on putfile so if you want the full image http://www.mediafire.com/?bezyfcjtidl This is ...
  1. #1
    Rookie Array

    Join Date
    Mar 2007
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [Video] QE/CI/Rotation on AppleTV OSX Install

    Looks like crap on putfile so if you want the full image
    http://www.mediafire.com/?bezyfcjtidl

    This is done using 10.4.8 Jas Install DVD to Media Partition of ATV using Semthex's 10.4.8 ATV kernel

    Then Adding the following Kexts/Bundles/Plugins from a 10.4.9 install

    NVDANV10Hal.kext
    NVDANV20Hal.kext
    NVDANV30Hal.kext
    NVDANV40Hal.kext
    NVDAResman.kext
    GeForce.kext
    GeForce2MXGLDriver.bundle
    GeForce3GLDriver.bundle
    GeForceFXGLDriver.bundle
    GeForceGA.plugin
    GeForceVADriver.bundle

    and a custom version of Natit found below....
    http://www.mediafire.com/?7dmljmiwoyz

    And also Editing the NVDAResman.kext/Contents/Info.plist IOPCIMatch line to be
    <string>0x01D710DE</string>

    This boots up and QE/CI/Rotation all report fine. As well as all available resolutions in Resman.

    To do this you need an understanding of Kexts/Permissions....Make sure all of the Contents/MacOS/xyz files in the above kexts are +x

    My screenshot is taken from VNC because my tv will not display any of the resolutions properly. Others please try this to see if your tv works.

    Credit Goes to Diab0lik for supplying this custom version of Natit. He will be making revisions to this version of Natit as well to find out if we can make further progress.
    Last edited by arodd; 04-08-2007 at 11:44 AM.



  2. #2
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    261
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    Huh?
    What is this?

  3. #3
    u72
    u72 is offline
    Newbie Array

    Join Date
    Apr 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by iMags View Post
    Huh?
    What is this?
    Quartz Extreme & Core Image

  4. #4
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    261
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    for what?
    why do we need this?

  5. #5
    Rookie Array

    Join Date
    Aug 2006
    Posts
    28
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by iMags View Post
    for what?
    why do we need this?
    to have stuff like dvd player or other fun stuff like the water ripple of widgets.


  6. #6
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    261
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    cool!
    How to install it?

  7. #7
    Rookie Array

    Join Date
    Mar 2007
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    -=Further Information=-

    HDMI/DVI Outputs a black screen. However it does output a resolution because the tv/lcd monitors I have tested on change display modes appropriately. Also after inactivity the monitor goes to sleep, and then moving the mouse changes the monitors display mode again. Something is just preventing the display from showing the OS.

    Component Output works but will only output 4:3 Interlaced NTSC/PAL resolutions. No success with SwitchResX yet.

    Once the resolution is applied it will also change the resolution on all other boots to any partition including atvos. The best case is to boot to atvos and set the appropriate resolution and then bless to the OSX install.

    Using the plugins/bundles from the ATVOS /System/Library/Extensions/ folder disables QE/CI/Rotation so it seems 10.4.9 kexts are working best. 10.4.8 kexts provide close to the same results.

    The difference between the 4.8/4.9 kexts is this....
    4.9= DVI/HDMI output to an HDTV shows up properly as a television and allows setting overscan/HD resolutions
    4.8= DVI/HDMI output to an HDTV shows up as a normal digital panel and doesn't allow overscan/Has less resolutions.

    Component didn't seem to be any different between 4.8/4.9 It shows up as a Television no matter what is connected to it.

    Removing Natit from the equation provides the same results except the Card is detected properly(even without natit) and QE/CI/Rotation are still enabled.

    Adding MacVidiaEFI kext shows similar results as Natit. Doesn't seem to be any better/worse through all of the equations.

    Prasys thinks the black screen is caused by a lack of a proper framebuffer driver. This may be the case if Component doesn't use the framebuffer because the component output works.

    Some of the problems in this thread seem to be similar http://www.macvidia.com/index.php?op...topic=1031.390

  8. #8
    Rookie Array

    Join Date
    Mar 2007
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Someone should try MacVidiaEFI in combination with the Laptop Kext from Macvidia to see if this will activate the DVI/HDMI screen.

    Since this is a laptop chipset the display may just be inactive. Almost identical to when you hold play in ATV os and the graphics shut off but the device stays running. It still outputs the resolution to the tv/monitor it's just blacked out.

    Maybe it sends an acpi lid closed message to the graphics driver.

  9. #9
    Rookie Array

    Join Date
    Aug 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    arodd >

    does anyone wrote an how-to guide for unix newbies on how to do that?

  10. #10
    Developer Array

    Join Date
    Mar 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Working like a charm with a Mac OS X 10.4.0 install, modified kernel and 10.4.8 video extensions on a HDMI TV in 720p.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Video's weird rotation and only audio
    By ChristiaanW in forum General
    Replies: 0
    Last Post: 04-04-2010, 10:28 PM
  2. Can appletv install OSX server?
    By joejoe109 in forum AppleTV 1
    Replies: 2
    Last Post: 04-02-2009, 01:26 PM
  3. [Install] OSX on an AppleTV
    By Myca in forum AppleTV 1
    Replies: 17
    Last Post: 11-08-2008, 10:08 PM
  4. Replies: 2
    Last Post: 10-31-2007, 08:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:11 AM.
twitter, follow us!