Page 1 of 2 12 LastLast
Results 1 to 10 of 19
Discuss SUCCESS!! Dual Booting ATV/OSX with Internal Drive at the AppleTV 1 - Hackint0sh.org; I've got OSX dual booting by installing OSX to the media partition and it works ...
  1. #1
    Rookie Array

    Join Date
    Mar 2007
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default SUCCESS!! Dual Booting ATV/OSX with Internal Drive

    I've got OSX dual booting by installing OSX to the media partition and it works great. It doesn't interfere with ATV OS

    I essentially Installed a fresh copy of osx to a 3.5" hard-drive(hackint0sh). Then popped in the ATV drive to my pc along with the fresh install. Then used Disk Utility to recover the osx partition from the 3.5" to the Media partition making sure to not reformat/erase partition. It will coexist with the Media/Scratch folders on the 4th partition.

    Setup the usual mach_kernel/boot.efi mod using semthex's kernel and the guide from appletvhacks.net.

    Then Bless with the below command via SSHing to the ATV after you put the drive back in.

    bless --folder=/mnt/System/Library/CoreServices --file=/mnt/System/Library/CoreServices/boot.efi --setBoot --nextonly

    Then reboot

    This will tell it to use the boot.efi file from the media partition and boot osx, but only on the next reboot....

    I wrote a script that does the bless command and then reboots automatically

    Now all we need is someone to write a plugin to call a script to bless and reboot so we can do it from the atv menu and not have to use ssh.

    To get back to ATV OS you would just need to reboot.

    Another Interesting thing I found was my AppleTV has a 1.5ghz i'm going to run some xbenches to confirm that it's actually performing at this.
    Screenshot....

    Last edited by arodd; 04-08-2007 at 01:21 AM.



  2. #2
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    261
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    WTF!
    That is awesome!!!
    I will do the same thing

  3. #3
    Rookie Array

    Join Date
    Apr 2007
    Location
    Maine
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    iMags, let us know how you make out!
    Sounds great.

  4. #4
    Rookie Array

    Join Date
    Apr 2006
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Have you tried rEFIt? refit.sf.net

  5. #5
    Newbie Array

    Join Date
    Apr 2007
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by arodd View Post

    Another Interesting thing I found was my AppleTV has a 1.5ghz i'm going to run some xbenches to confirm that it's actually performing at this.
    Didn't hackintosh installs have problems with representing actual CPU speed? My 3 Ghz P4 was reported as 4 Ghz by system profiler.

    Both the shipped ATV OS, and bootable off USB thumb drive Mac OS, that I patched together from install made on an intel mini and semthex' kernel, report 1Ghz CPU, so this looks like a representation bug.


  6. #6
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    261
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    Didn't work!
    After blessing it only boots back up to the aTV OS, as it normally would.

    Help?

    UPDATE:
    It works now.
    Thanks to arodd who helped me
    Last edited by iMags; 04-09-2007 at 10:00 AM.

  7. #7
    Rookie Array

    Join Date
    Apr 2007
    Location
    Maine
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    iMags, I hope you are not married as I sense you have spent the better part of Easter weekend working on this project.
    Seriously, thanks for all the effort. I, for one, really appreciate the time you (and others) have put into this, and the various other, projects.
    Keep up the good work.

  8. #8
    Rookie Array

    Join Date
    Mar 2007
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I helped iMags get it working in the #appletv room in IRC....so add another to thelist of those who have got it working.

  9. #9
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    261
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    21

    Default

    Yep... It's working alright.
    ..great actually.

    Thanks again arodd

  10. #10
    Advanced Array josh256's Avatar

    Join Date
    Apr 2007
    Posts
    31
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default bless command works (from root)...

    .. but I too am rebooting into aTV as opposed to the media partition.

    What was the solution for iMags?
    Last edited by josh256; 04-10-2007 at 05:23 AM. Reason: typo


 

 
Page 1 of 2 12 LastLast

LinkBacks (?)

  1. 02-04-2009, 08:55 AM
  2. 01-17-2009, 02:16 PM
  3. 01-14-2009, 05:06 PM

Similar Threads

  1. External Hard Drive Dual Booting
    By Zythyr in forum Dual Booting
    Replies: 0
    Last Post: 07-02-2010, 09:52 AM
  2. Dual Booting - Shared drive..
    By spitphire in forum Dual Booting
    Replies: 0
    Last Post: 11-08-2009, 02:33 PM
  3. nForce Driver works on OSX/USB Drive but not on Internal Drive..
    By earwiggs in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 08-14-2009, 02:10 AM
  4. Replies: 0
    Last Post: 02-24-2009, 12:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:54 AM.
twitter, follow us!