Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Discuss the state of OS X on aTV? at the AppleTV 1 - Hackint0sh.org; I'm trying to get a sense of what can be done with an AppleTV box. ...
  1. #1
    Rookie Array

    Join Date
    Aug 2007
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default the state of OS X on aTV?

    I'm trying to get a sense of what can be done with an AppleTV box.

    1) Really no video acceleration? From such a nice, CI/QE-compatible video card? Is the real OS X incapable of using the drivers/kexts/whatever in the aTV OS, to make use of the graphics card?

    2) If that's right, does that mean no Front Row? Even using something like Andrew Escobar's Front Row Enabler, which allows FR to run on older Macs?

    3) Really no sound? Anyone know why? Does it have to do with the analog sound outputs being unrecognized by OS X? What about using a sound-over-USB device, like the Griffin iMic?

    I'd love to change my aTV from a dedicated Front Row 2.0 box to a real OS X box with Front Row 1.3, EyeTV 2.4, NAS-style file serving and internet sharing... for half the price of a Mini. Is this a pipe dream?



  2. #2
    Newbie Array

    Join Date
    Mar 2007
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quite curious to hear about this too.
    And would it be good enough as a little server, wireless router and NAS?

  3. #3
    Rookie Array

    Join Date
    Aug 2007
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Going to reply in my own thread...

    Not entirely surprised at the lack of response, given the noobness of the questions. In fact I half-suspected some kind of rude response... I only recently bought an Atv and haven't spent much time on these boards.

    Anyway, I found a Griffin iMic, I will take it home and test it for sound out when I load up OS X on the box.

    Of course, any input from people who have experience with these issues would be very welcome.

  4. #4
    Newbie Array

    Join Date
    Apr 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    sound on osx on atv DOES work but its very very quiet and a little stuttery

    I also tried a griffin imic. it works but stutters a little

    As for graphics accelleration, mine all report fine QE,CI and rotation all report as ok.

    I installed osx from a dvd (jas osx) onto a fresh hard disc, then performed the necessary kernel patches

  5. #5
    Newbie Array

    Join Date
    Apr 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Last edited by maltloaf; 08-12-2007 at 04:16 PM.


  6. #6
    Rookie Array

    Join Date
    Aug 2007
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Sweet. I'm going to get hacking tonight!

    EDIT: Wait, wait: I though video-out isn't working. I thought you just get a black screen over HDMI unless you delete the Nvidia drivers, which means no more hardware acceleration. At least, that's what I understand from the stickied "HOWTO boot OS X from an external drive" thread.

    - Does that issue only crop up when you're booting from an external drive? Does video out work properly when booting from the aTV itself?

    - Maltloaf, what process did you use to load OS X onto the aTV?

    I was going to follow that stickied thread and, once booted from an external drive, simply restore an image of a clean, Semthex-modded OS X installation on the aTV internal drive, then let it boot from there from then on.

    Maybe that's a mistake? Maybe I should follow the traditional route of ripping the drive out (not worried about the warranty)? Would this make a difference in terms of the graphics card?

    I'm confused...
    Last edited by silas; 08-14-2007 at 12:09 AM.

  7. #7
    Rookie Array

    Join Date
    Aug 2007
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Wait a minute:

    What'd I do wrong?



    I get no graphics acceleration and no sound. Sound will issue from the Griffin iMic, but is so stuttery as to be unrecognizable.

    What is this "jas osx" you speak of?

  8. #8
    Professional Array

    Join Date
    Apr 2007
    Posts
    67
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    "sound on osx on atv DOES work but its very very quiet and a little stuttery"

    Yipes! I didn't know this. This is not good and if true, will steer me away from AppleTV w/OS X to Mac Mini.

  9. #9
    Newbie Array

    Join Date
    Apr 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    jas osx is a dvd i downloaded from a torrent site, its 10.4.8 based and has hacks pre installed for it to run on different hackintosh type machines. I did a normal install, on a p4 pc and then put in the hacked kernel and put it in the atv.

    i havent completely solved the hdmi issue but i found a work around that works every time.

    If you move the mouse so that the cursor would be top left (so just keep going up and left) and click, then press up four times, then enter, you put the machine to sleep. Wake it with any key and the DVI display comes up perfectly.

    Its an issue when you do a cold boot, but mines been up weeks as im only using it as an internet terminal at the moment.

    cheers,

    malty

  10. #10
    DxQ
    DxQ is offline
    Advanced Array

    Join Date
    Apr 2007
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Sound IS available on OS X, you just have to find the right files. :-)


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Sad state of affairs
    By )law( in forum General
    Replies: 4
    Last Post: 11-20-2008, 12:29 PM
  2. The state of things
    By kazee in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 10-29-2007, 01:13 AM
  3. How to check SIM STATE?
    By wireless in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 10-25-2007, 07:35 PM
  4. State restore 1.02
    By Abdo Abdala in forum General
    Replies: 8
    Last Post: 09-28-2007, 04:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:31 PM.
twitter, follow us!