Results 1 to 5 of 5
Discuss Patchstick hangs at boot at the AppleTV 1 - Hackint0sh.org; Hello, I have an Apple TV 1.1 ! I'm using the patchstick.zip from the awkwardwiki ...
  1. #1
    Rookie Array

    Join Date
    Aug 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Patchstick hangs at boot

    Hello,

    I have an Apple TV 1.1 !
    I'm using the patchstick.zip from the awkwardwiki and I have an Powerbook G3.
    Because of this someone send me the needed kernel extensions from an intel mac.
    And I modiefied the cp command in the createPatchstick shellscript.
    I have mounted the dmg with the boot.efi.

    When I create the stick there is no failure at the output.
    So i put it in and reboot from it and I got this

    /sbin/launchd error 86 trying /sbin/mach_init

    and it hangs up.

    any idea what is wrong?

    greets teldec



  2. #2
    Rookie Array Maraklov's Avatar

    Join Date
    Apr 2007
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    it sounds like it's trying to find "mach_init.d" which is a directory that i believe launchd looks for to load things from. it should be located at /etc/mach_init.d on your appletv, if you can ssh in at all. perhaps just check your createpatchstick script to make sure it's putting it in the right place and run it again.

    hope that's some help.

  3. #3
    Rookie Array

    Join Date
    Aug 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    hello again,

    cp root/mach_kernel /Volumes/Patchstick-root/
    cp root/com.apple.Boot.plist /Volumes/Patchstick-root/
    cp root/Info.plist /Volumes/Patchstick-root/System/Library/Extensions/AppleFileSystemDriver.kext/Contents/
    cp root/launchd /Volumes/Patchstick-root/sbin/launchd
    chmod 755 /Volumes/Patchstick-root/sbin/launchd


    thats all and when I look at launchd i think its not started on apple tv because of the missing echos .

    i made a picture
    greets
    Last edited by teldec; 08-06-2007 at 07:42 AM.

  4. #4
    Rookie Array

    Join Date
    Aug 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    solved ssh works.

  5. #5
    Newbie Array

    Join Date
    Apr 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    teldec, I got the same problem as you.
    How did you solved it?


 

 

Similar Threads

  1. Boot hangs after upgrade from 10.6.3 to 10.6.6
    By changedsoul in forum Installation
    Replies: 0
    Last Post: 01-20-2011, 04:12 AM
  2. iATKOS v7 hangs at boot
    By palz in forum Installation
    Replies: 1
    Last Post: 04-05-2010, 10:20 PM
  3. Replies: 10
    Last Post: 02-03-2010, 03:44 AM
  4. iDeneb v.1.3 10.5.5 boot hangs
    By davenotz in forum Installation
    Replies: 0
    Last Post: 12-04-2008, 03:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:42 AM.
twitter, follow us!