Page 28 of 31 FirstFirst ... 81819202122232425262728293031 LastLast
Results 271 to 280 of 310
Discuss nitoTV 0.7.0 released, leopard support, photo tweaks, add rss ui + more at the AppleTV 1 - Hackint0sh.org; Originally Posted by atvusr Now, Bluetooth is working on my AppleTV 3.0.2 ..." Thanks a ...
  1. #271
    Newbie Array

    Join Date
    Feb 2010
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Closer....

    Quote Originally Posted by atvusr View Post
    Now, Bluetooth is working on my AppleTV 3.0.2 ..."

    Thanks a lot for your help atvusr!

    I think I'm close but I'm still stuck on "Bluetooth Loading"

    My Setup is:
    - ATV OS 3.0.2
    - ATV Flash 4.1.2 (NitoTV 0.9.0)

    This is what I did:

    I Run Smart Installer, then

    I opened "MacOSXUpdCombo10.4.9Intel.dmg" from "/Frontrow/Documents", and extracted the files you pointed.

    With Cyberduck I copied the files to "Documents", then with Terminal I move all the files from "Documents" to their respective folders like this:

    sudo mv IOBluetoothFamily.kext /System/Library/Extensions/
    sudo mv IOBluetoothHIDDriver.kext /System/Library/Extensions/
    sudo mv IOBluetooth.framework /System/Library/Frameworks/
    sudo mv "Bluetooth Setup Assistant.app" /System/Library/CoreServices/
    sudo mv BluetoothUIServer.app /System/Library/CoreServices/
    sudo mv bluetoothlauncher /System/Library/CoreServices/
    sudo mv Bluetooth.menu "/System/Library/CoreServices/Menu Extras/"
    sudo mv SPBluetoothReporter.spreporter /System/Library/SystemProfiler/
    sudo mv Bluetooth.bundle /System/Library/SystemConfiguration/
    sudo mv Bluetooth.prefPane /System/Library/PreferencePanes/
    sudo mv Keyboard.prefPane /System/Library/PreferencePanes

    Then I restart my Apple TV, after I see the "Apple screen" I connect the dongle (this is the Dlink DBT-122 that I was using in my Mac) and go into NitoTV SystemPreferences and see "Bluetooth" and a 'new' "Keyboard and Mouse" Preference Pane.

    The first one doesn't pass the "loading bluetooth" and the second one says "cannot load Keyboard and mouse" Preference Panel.

    What am I doing wrong? Am I missing something?
    Last edited by Nano07; 05-15-2010 at 11:39 AM.


  2. #272
    Rookie Array

    Join Date
    Mar 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Nano07 View Post
    What am I doing wrong? Am I missing something?
    There seems to be no /System/Library/Frameworks/IOBluetoothUI.framework and /usr/sbin/blued in your list.

    Have you set the appropriate Owner and Permissions (chown, chmod) to the Bluetooth files ?

    It's the best to set Owner and Permissions for the Bluetooth files to the same as the other system files in the appropriate directories. A "sudo chown -R 0:0" and "chmod -R 755" should work for the first try.
    Last edited by atvusr; 05-15-2010 at 04:20 PM.

  3. #273
    Newbie Array

    Join Date
    Feb 2010
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I must have messed it up at some stage... I tried fixing permissions like this:

    sudo chmod -R 755 /System/Library/Extensions/IOBluetoothFamily.kext
    sudo chmod -R 755 /System/Library/Extensions/IOBluetoothHIDDriver.kext
    sudo chmod -R 755 /System/Library/Frameworks/IOBluetooth.framework
    sudo chmod -R 755 /System/Library/Frameworks/IOBluetooth.framework
    sudo chmod -R 755 /System/Library/Frameworks/IOBluetoothUI.framework
    sudo chmod -R 755 “/System/Library/CoreServices/Bluetooth Setup Assistant.app”
    sudo chmod -R 755 /System/Library/CoreServices/BluetoothUIServer.app
    sudo chmod -R 755 /System/Library/CoreServices/bluetoothlauncher
    sudo chmod -R 755 “/System/Library/CoreServices/Menu Extras/Bluetooth.menu”
    sudo chmod -R 755 /System/Library/SystemProfiler/SPBluetoothReporter.spreporter
    sudo chmod -R 755 /System/Library/SystemConfiguration/Bluetooth.bundle
    sudo chmod -R 755 /System/Library/PreferencePanes/Bluetooth.prefPane
    sudo chmod -R 755 /System/Library/PreferencePanes/Keyboard.prefPane

    and then ownership like this

    sudo chown 0:0 /System/Library/Extensions/IOBluetoothFamily.kext
    sudo chown 0:0 /System/Library/Extensions/IOBluetoothHIDDriver.kext
    sudo chown 0:0 /System/Library/Frameworks/IOBluetooth.framework
    sudo chown 0:0 /System/Library/Frameworks/IOBluetoothUI.framework
    sudo chown 0:0 “/System/Library/CoreServices/Bluetooth Setup Assistant.app”
    sudo chown 0:0 /System/Library/CoreServices/BluetoothUIServer.app
    sudo chown 0:0 /System/Library/CoreServices/bluetoothlauncher
    sudo chown 0:0 “/System/Library/CoreServices/Menu Extras/Bluetooth.menu”
    sudo chown 0:0 /System/Library/SystemProfiler/SPBluetoothReporter.spreporter
    sudo chown 0:0 /System/Library/SystemConfiguration/Bluetooth.bundle
    sudo chown 0:0 /System/Library/PreferencePanes/Bluetooth.prefPane
    sudo chown 0:0 /System/Library/PreferencePanes/Keyboard.prefPane

    but on some files I errors. See this:

    -bash-2.05b$ sudo mv IOBluetoothUI.framework /System/Library/Frameworks/
    override rwxr-xr-x root/wheel for /System/Library/Frameworks/IOBluetoothUI.framework? (y/n [n]) y
    mv: rename IOBluetoothUI.framework to /System/Library/Frameworks/IOBluetoothUI.framework: Read-only file system

    I've also tried running smart installer again to see if it fixed it but i got "nothing to install"

  4. #274
    Rookie Array

    Join Date
    Mar 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Nano07 View Post
    ... but on some files errors ...

    -bash-2.05b$ sudo mv IOBluetoothUI.framework /System/Library/Frameworks/
    override rwxr-xr-x root/wheel for /System/Library/Frameworks/IOBluetoothUI.framework? (y/n [n]) y
    mv: rename IOBluetoothUI.framework to /System/Library/Frameworks/IOBluetoothUI.framework: Read-only file system
    It seems, that the system partition is read only (default after ATV boot), try a "sudo mount -uw /".

    The command "chown" should also be executed with the option "-R", because there are directories.
    Last edited by atvusr; 05-15-2010 at 01:26 PM.

  5. #275
    Newbie Array

    Join Date
    Feb 2010
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks, ""sudo mount -uw /" fixed that isssue.

    Now I was able to fix permissions and also ownership, I restarted ATV but now something strange happens. As soon as I plug the dongle, the ATV goes really slow... i click on the remote and it takes several seconds to react.

    Anyway, when I manage to get into the Bluetooth pane, it gets stuck in "Loading Bluetooth"

    I'll see if I can start from scratch again.

    Do you know if I do a will lose all the movies that I have in "frontrow/movies" if I do a system restore?


  6. #276
    Rookie Array

    Join Date
    Mar 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Start from scratch again

    Quote Originally Posted by Nano07 View Post
    As soon as I plug the dongle, the ATV goes really slow... i click on the remote and it takes several seconds to react.

    I'll see if I can start from scratch again. Do you know if I do a will lose all the movies that I have in "frontrow/movies" if I do a system restore?
    It seems there is something gone wrong with the Bluetooth file installation.

    After my Bluetooth installation, ATV works fine with no performance lost at all.

    If you make a factory restore, all content on the ATV is lost. Make a Backup first.
    Last edited by atvusr; 05-15-2010 at 04:20 PM.

  7. #277
    Newbie Array

    Join Date
    Feb 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default nitoTV 0.9.1v2 Smart Installer fails on 3.0.2

    I am trying to run the SmartInstaller on nitoTV 0.9.1v2. It fails with the message "*** Uncaught exception: <NSInvalidArgumentException> launch path not accessible"

    Here are the steps I've taken...

    Somehow my Apple TV became hosed (screensaver, but no on screen menus, etc.). I did a factory restore then updated to 3.0.2. Used the patchstick to get SoftwareUpdate and Launcher in the menu and SSH'd into the box. I downloaded the 10.4.9 Combo Update and placed that in the ~/Documents directory. I downloaded nitoTV, unzipped it, and ran ./installme.

    nitoTV shows up in the menu and everything looks right. When I run the smart installer I get that error message though.

    I've done this twice now starting from factory restore. No syncing with a computer and the USB drive is unplugged until after SmartInstaller runs.

    Any ideas?

    Here's the full log entry...

    -bash-2.05b$ cat nitoInstall.log
    2010-06-14 19:56:21.397 nitoHelper[219] Installed JavaScriptCore.framework to fix installer for 3.0

    2010-06-14 19:56:21.445 nitoHelper[219] Installed new smbfs.kext successfully!

    This software is copyright 2008 Turbo (Mike Byrne) and MAY NOT be distributed.
    All rights reserved.
    Contact turbo@0xfeedbeef.com for more information

    Installing kext enabler... OK!
    Installing Turbo's SSE3 emulator... OK!

    Done.
    2010-06-14 19:56:23.124 nitoHelper[219] Unmodified 3.0.2 detected

    2010-06-14 19:56:23.125 nitoHelper[219] *** Uncaught exception: <NSInvalidArgumentException> launch path not accessible
    I'm using atvusb-creator-1.0.b13 to make the patchstick.

  8. #278
    Advanced Array

    Join Date
    Dec 2007
    Posts
    46
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    besides the Combo update you also need a OS.dmg in Documents

  9. #279
    Newbie Array

    Join Date
    Feb 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by ral67 View Post
    besides the Combo update you also need a OS.dmg in Documents
    I thought that was only needed for AFP?

  10. #280
    Newbie Array

    Join Date
    Feb 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Update after updating recovery.dmg

    I used the ATV OS 1.0 dmg to update recovery.dmg. A lot more stuff installs first, but it eventually fails in the same place and I still can't see my external drive. This is frustrating after having it running fine on 3.0 and 3.0.1 for so long.

    Code:
    -bash-2.05b$ cat nitoInstall.log 
    2010-06-15 02:00:45.057 nitoHelper[178] Root filesystem already writable
    
    2010-06-15 02:01:08.179 nitoHelper[178] valid recovery image found!
    
    2010-06-15 02:01:08.406 nitoHelper[178] AppleShareClient.framework installed successfully!
    
    2010-06-15 02:01:08.473 nitoHelper[178] AppleShareClientCore.framework installed successfully!
    
    2010-06-15 02:01:08.822 nitoHelper[178] AppleShare installed successfully!
    
    2010-06-15 02:01:08.882 nitoHelper[178] Tokenizers installed successfully!
    
    2010-06-15 02:01:09.010 nitoHelper[178] AppleFileServer.app installed successfully!
    
    2010-06-15 02:01:09.143 nitoHelper[178] ByteRangeLocking.framework installed successfully!
    
    2010-06-15 02:01:09.245 nitoHelper[178] BezelServices.framework installed successfully!
    
    2010-06-15 02:01:09.360 nitoHelper[178] CommonCandidateWindow.framework installed successfully!
    
    2010-06-15 02:01:09.511 nitoHelper[178] DMNotification.framework installed successfully!
    
    2010-06-15 02:01:09.651 nitoHelper[178] OpenTransport.framework installed successfully!
    
    2010-06-15 02:01:09.788 nitoHelper[178] Calculate.framework installed successfully!
    
    2010-06-15 02:01:09.922 nitoHelper[178] ContentIndex.framework installed successfully!
    
    2010-06-15 02:01:10.050 nitoHelper[178] LatentSemanticMapping.framework installed successfully!
    
    2010-06-15 02:01:10.178 nitoHelper[178] SystemUIPlugin.framework installed successfully!
    
    2010-06-15 02:01:10.229 nitoHelper[178] a2p installed successfully!
    
    2010-06-15 02:01:10.271 nitoHelper[178] atlookup installed successfully!
    
    2010-06-15 02:01:10.287 nitoHelper[178] certtool installed successfully!
    
    2010-06-15 02:01:10.332 nitoHelper[178] libXplugin.1.0.dylib installed successfully!
    
    2010-06-15 02:01:10.381 nitoHelper[178] libXplugin.1.dylib installed successfully!
    
    2010-06-15 02:01:10.389 nitoHelper[178] libXplugin.dylib installed successfully!
    
    2010-06-15 02:01:10.477 nitoHelper[178] pam_afpmount.so installed successfully!
    
    2010-06-15 02:01:10.521 nitoHelper[178] pngtclConfig.sh installed successfully!
    
    2010-06-15 02:01:10.588 nitoHelper[178] libtclsqlite3.dylib installed successfully!
    
    2010-06-15 02:01:10.594 nitoHelper[178] tcldomxmlConfig.sh installed successfully!
    
    2010-06-15 02:01:10.596 nitoHelper[178] tdomConfig.sh installed successfully!
    
    2010-06-15 02:01:10.597 nitoHelper[178] tifftclConfig.sh installed successfully!
    
    2010-06-15 02:01:10.598 nitoHelper[178] tkimgConfig.sh installed successfully!
    
    2010-06-15 02:01:10.637 nitoHelper[178] xsltConf.sh installed successfully!
    
    2010-06-15 02:01:10.644 nitoHelper[178] zlibtclConfig.sh installed successfully!
    
    2010-06-15 02:01:10.695 nitoHelper[178] appletalk installed successfully!
    
    2010-06-15 02:01:10.714 nitoHelper[178] automount installed successfully!
    
    2010-06-15 02:01:10.727 nitoHelper[178] blued installed successfully!
    
    2010-06-15 02:01:10.844 nitoHelper[178] named installed successfully!
    
    2010-06-15 02:01:10.896 nitoHelper[178] named-checkconf installed successfully!
    
    2010-06-15 02:01:10.985 nitoHelper[178] named-checkzone installed successfully!
    
    2010-06-15 02:01:11.027 nitoHelper[178] portmap installed successfully!
    
    2010-06-15 02:01:11.074 nitoHelper[178] slp_reg installed successfully!
    
    2010-06-15 02:01:11.087 nitoHelper[178] slpd installed successfully!
    
    2010-06-15 02:01:11.124 nitoHelper[178] tim installed successfully!
    
    2010-06-15 02:01:11.127 nitoHelper[178] timutil installed successfully!
    
    2010-06-15 02:01:11.174 nitoHelper[178] xinetd installed successfully!
    
    2010-06-15 02:01:11.215 nitoHelper[178] mount_afp installed successfully!
    
    2010-06-15 02:01:11.355 nitoHelper[178] mount_autofs installed successfully!
    
    2010-06-15 02:01:11.357 nitoHelper[178] mount_cd9660 installed successfully!
    
    2010-06-15 02:01:11.371 nitoHelper[178] mount_cddafs installed successfully!
    
    2010-06-15 02:01:11.383 nitoHelper[178] mount_nfs installed successfully!
    
    2010-06-15 02:01:11.385 nitoHelper[178] mount_ntfs installed successfully!
    
    2010-06-15 02:01:11.400 nitoHelper[178] mount_smbfs installed successfully!
    
    2010-06-15 02:01:11.402 nitoHelper[178] mount_udf installed successfully!
    
    2010-06-15 02:01:11.412 nitoHelper[178] mount_webdav installed successfully!
    
    2010-06-15 02:01:11.611 nitoHelper[178] URLMount installed successfully!
    
    2010-06-15 02:01:11.649 nitoHelper[178] cd9660.fs installed successfully!
    
    2010-06-15 02:01:11.734 nitoHelper[178] cddafs.fs installed successfully!
    
    2010-06-15 02:01:11.746 nitoHelper[178] ftp.fs installed successfully!
    
    2010-06-15 02:01:11.762 nitoHelper[178] nfs.fs installed successfully!
    
    2010-06-15 02:01:11.773 nitoHelper[178] ntfs.fs installed successfully!
    
    2010-06-15 02:01:11.790 nitoHelper[178] udf.fs installed successfully!
    
    2010-06-15 02:01:11.810 nitoHelper[178] ufs.fs installed successfully!
    
    2010-06-15 02:01:11.855 nitoHelper[178] webdav.fs installed successfully!
    
    2010-06-15 02:01:11.910 nitoHelper[178] ftpd installed successfully!
    
    2010-06-15 02:01:11.960 nitoHelper[178] syslog installed successfully!
    
    2010-06-15 02:01:12.089 nitoHelper[178] International.framework installed successfully!
    
    2010-06-15 02:01:12.237 nitoHelper[178] PreferencePanes.framework installed successfully!
    
    2010-06-15 02:01:12.365 nitoHelper[178] IntlPreferences.framework installed successfully!
    
    2010-06-15 02:01:15.694 nitoHelper[178] PreferencePanes installed successfully!
    
    2010-06-15 02:01:15.789 nitoHelper[178] Active Directory.dsplug installed successfully!
    
    2010-06-15 02:01:15.809 nitoHelper[178] AppleTalk.dsplug installed successfully!
    
    2010-06-15 02:01:15.858 nitoHelper[178] Bonjour.dsplug installed successfully!
    
    2010-06-15 02:01:15.878 nitoHelper[178] SLP.dsplug installed successfully!
    
    2010-06-15 02:01:15.902 nitoHelper[178] SMB.dsplug installed successfully!
    
    2010-06-15 02:01:16.009 nitoHelper[178] CoreAudioKit.framework installed successfully!
    
    2010-06-15 02:01:16.240 nitoHelper[178] Language Chooser.app installed successfully!
    
    2010-06-15 02:01:17.569 nitoHelper[178] Menu Extras installed successfully!
    
    2010-06-15 02:01:17.622 nitoHelper[178] bluetoothlauncher installed successfully!
    
    2010-06-15 02:01:17.687 nitoHelper[178] BluetoothIOM.plugin installed successfully!
    
    2010-06-15 02:01:17.720 nitoHelper[178] PB_Bluetooth.plugin installed successfully!
    
    2010-06-15 02:01:17.813 nitoHelper[178] Bluetooth.bundle installed successfully!
    
    2010-06-15 02:01:17.862 nitoHelper[178] SPBluetoothReporter.spreporter installed successfully!
    
    2010-06-15 02:01:18.402 nitoHelper[178] CFMSupport installed successfully!
    
    2010-06-15 02:01:18.544 nitoHelper[178] AppleScript.component installed successfully!
    
    2010-06-15 02:01:18.617 nitoHelper[178] DictionaryService.component installed successfully!
    
    2010-06-15 02:01:18.657 nitoHelper[178] CarbonSpellChecker.bundle installed successfully!
    
    2010-06-15 02:01:18.773 nitoHelper[178] AppKitScripting.framework installed successfully!
    
    2010-06-15 02:01:19.036 nitoHelper[178] Scripting.framework installed successfully!
    
    2010-06-15 02:01:19.323 nitoHelper[178] OSAKit.framework installed successfully!
    
    2010-06-15 02:01:19.535 nitoHelper[178] AppleScript.framework installed successfully!
    
    2010-06-15 02:01:19.710 nitoHelper[178] ScriptingAdditions installed successfully!
    
    2010-06-15 02:01:19.776 nitoHelper[178] /Library/Perl installed successfully!
    
    2010-06-15 02:01:24.150 nitoHelper[178] /Volumes/OSBoot 1/System/Library/Perl installed successfully!
    
    2010-06-15 02:01:24.520 nitoHelper[178] /System/Library/CoreServices/RemoteManagement installed successfully!
    
    2010-06-15 02:01:27.758 nitoHelper[178] Installed ftp server LaunchDaemon successful!
    
    2010-06-15 02:01:29.242 nitoHelper[178] Installed JavaScriptCore.framework to fix installer for 3.0
    
    2010-06-15 02:01:29.305 nitoHelper[178] Installed new smbfs.kext successfully!
    
    2010-06-15 02:01:29.398 nitoHelper[178] kextloader already installed!
    
    2010-06-15 02:01:29.733 nitoHelper[178] Unmodified 3.0.2 detected
    
    2010-06-15 02:01:29.749 nitoHelper[178] *** Uncaught exception: <NSInvalidArgumentException> launch path not accessible
    Last edited by weldon; 06-15-2010 at 04:15 AM.


 

 

LinkBacks (?)

  1. 02-26-2010, 04:56 PM
  2. 07-21-2009, 03:49 PM
  3. 02-17-2009, 08:56 AM
  4. 02-17-2009, 05:14 AM

Similar Threads

  1. MacRumors: Potential First Released Photo Taken by an iPhone 5
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 09-07-2011, 05:10 PM
  2. MacNN: Windows Phone 7 released to manufacturing, gets tweaks
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 09-01-2010, 11:30 PM
  3. MacNN: Chinese iPhone gets tweaks to support WAPI standard
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 05-04-2010, 04:10 PM
  4. MacNN: Cocktail 4.6 adds Snow Leopard support, interface tweaks
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 11-10-2009, 05:40 AM
  5. nitoTV for leopard?
    By nitosoft in forum AppleTV 1
    Replies: 8
    Last Post: 02-12-2009, 07:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:49 AM.
twitter, follow us!