Page 27 of 31 FirstFirst ... 7171819202122232425262728293031 LastLast
Results 261 to 270 of 310
Discuss nitoTV 0.7.0 released, leopard support, photo tweaks, add rss ui + more at the AppleTV 1 - Hackint0sh.org; Thanks nito for nitoTV! Like to give some feedback. Tried to upgrade to the most ...
  1. #261
    Newbie Array

    Join Date
    Mar 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Upgrade to atvOS 3.02

    Thanks nito for nitoTV!

    Like to give some feedback.
    Tried to upgrade to the most recent atvOS 3.0.2 with my patchstick from last year. That didn't work anymore (spent quite some time to get this good old patchstick going). Anyhow, I switched over to using atvusb-creator and got a new patchstick. Despite that I only wanted the 'ssh tools' installed, atvusb-creator installed everything ( I guess my fault somewhere during the install process).
    Realized that out of the additionally installed tools I could use SoftwareMenu.
    I then installed nitoTV 0.8.6. After a reboot, SoftwareMenu disappeared, while all the other additional menus (XBMC, Launcher etc) remained in position.
    Went through the nitoTV install section like SmartInstaller etc and all went fine.
    Then I did a little research to get the SoftwareMenu back ... it seems that the SoftwareMenu was moved into another directory called SoftwareMenu (/System/Library/CoreServices/Finder.app/Contents/PlugIns/SoftwareMenu.frappliance/SoftwareMenu.frappliance). Just moved the directory up and SoftwareMenu was back on the block.
    I then did my Bluetooth setup, but unfortunately Bluetooth (keyboard & Mouse) did not work out of the nitoTV box. Had to modify a few files and now my Bluetooth keyboard & Mouse are working fine with atv 3.0.2.
    Then I tried to mount my 'movie server' using a SMB mount. While it worked fine with nfs, I had my issues with SMB. It seems I am not allowed to start the path absolute using the / ... Once I left it out, the mount was fine. Did a automount and whenever I booted ATV, the movie directory was mounted.
    Well, then I did the upgrade to nitoTV 0.8.7 and all my mounts disappeared.
    I am now unable to save a new mount. Not even my shell script to mount the drive worked anymore. It seems that previously a directory under /mnt/Scratch/Volumes/mydirectory was created and linked with /Users/frontrow/Movies/mydirectory. While the symbolic link in the /Users/frontrow/Movies/ directory remains, the directory /mnt/Scratch/Volumes/mydirectory was removed during boot. I now have to manually create the /mnt/Scratch/Volumes/mydirectory dir and then use my mount script to get the mount again. In addition, I always see the OSBoot mount when going to the Files section. After removing the /mnt/Scratch/Volumes/OSBoot dir and a reboot, the dir is back. Not so for the one(s) I need.
    Well, I am not sure this is a SoftwareMenu or nitoTV issue ... but as far as I see it started after my 0.8.7 upgrade.
    Otherwise I am enjoying AppleTV enhanced with nitoTV!

  2. Thanks atvusr thanked for this post.

  3. #262
    Rookie Array

    Join Date
    Mar 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Bluetooth Keyboard & Mouse on AppleTV 3.0.2

    Quote Originally Posted by grufty View Post
    I then did my Bluetooth setup, but unfortunately Bluetooth (keyboard & Mouse) did not work out of the nitoTV box. Had to modify a few files and now my Bluetooth keyboard & Mouse are working fine with atv 3.0.2.
    Which files has you modified?

    Which Bluetooth-Hardware (Receiver, Keyboard, Mouse) do you use?

  4. #263
    Newbie Array

    Join Date
    Mar 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default ATV Bluetooth

    Quote Originally Posted by atvusr View Post
    Which files has you modified?

    Which Bluetooth-Hardware (Receiver, Keyboard, Mouse) do you use?
    ATV OS 3.0.2 - My Bluetooth setup

    Before the nitoTV install I placed the MacOSXUpdCombo10.4.10Intel.dmg into the ~frontrow/Documents directory (SmartInstaller is expecting 10.4.9 or 10.4.10).
    Some of the following directories were created, but had a different version or missing files. I only show the directories, not all files within.
    /System/Library/Frameworks/IOBluetooth.framework :
    drwxr-xr-x 5 root wheel 170 Jun 13 2007 IOBluetooth.framework
    /System/Library/Frameworks/IOBluetoothUI.framework :
    drwxr-xr-x 5 root wheel 170 Jun 13 2007 IOBluetoothUI.framework
    /System/Library/PreferencePanes/Bluetooth.prefPane :
    drwxr-xr-x 3 frontrow frontrow 102 Mar 14 2007 Bluetooth.prefPane
    /System/Library/CoreServices/Bluetooth Setup Assistant.app :
    drwxr-xr-x 3 root wheel 102 Jun 13 2007 Bluetooth Setup Assistant.app
    /System/Library/CoreServices/BluetoothUIServer.app :
    drwxr-xr-x 3 root wheel 102 Jun 13 2007 BluetoothUIServer.app
    /System/Library/CoreServices/bluetoothlauncher :
    -rwxr-xr-x 1 root wheel 84672 Mar 1 22:44 bluetoothlauncher
    /usr/sbin/blued :
    -r-xr-xr-x 1 root wheel 423964 Feb 23 2007 /usr/sbin/blued (10.4.9)
    /System/Library/CoreServices/Language Chooser.app :
    drwxr-xr-x 3 root wheel 102 Mar 15 2007 Language Chooser.app
    /System/Library/CoreServices/Menu Extras :
    drwxr-xr-x 3 root wheel 102 Feb 27 2007 AirPort.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 Battery.menu
    drwxr-xr-x 3 root wheel 102 Mar 14 2007 Bluetooth.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 Clock.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 Displays.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 Eject.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 Fax.menu
    drwxr-xr-x 3 root wheel 102 Jan 29 2007 IrDA.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 PCCard.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 RemoteDesktop.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 User.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 VPN.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 Volume.menu
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 iChat.menu
    /System/Library/Printers/IOMs/BluetoothIOM.plugin :
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 BluetoothIOM.plugin
    /System/Library/Printers/PBMs/PB_Bluetooth.plugin :
    drwxr-xr-x 3 root wheel 102 Oct 7 2006 PB_Bluetooth.plugin
    /System/Library/SystemConfiguration/Bluetooth.bundle :
    drwxr-xr-x 3 root wheel 102 Mar 14 2007 Bluetooth.bundle
    /System/Library/SystemProfiler/SPBluetoothReporter.spreporter :
    drwxr-xr-x 3 root wheel 102 Feb 23 2007 SPBluetoothReporter.spreporter (this directory has somehow many more files then the one installed by nitoTV, not sure if they are required though)

    Make sure that the Extensions/IOBluetoothFamily.kext, Extensions/IOBluetoothHIDDriver.kext match the Frameworks/IOBluetooth.framework and Frameworks/IOBluetoothUI.framework dates.

    Above file/date combinations work for me. Other file/date combinations might work too.

    I am using an old Linksys BT100 USB Bluetooth adapter.

  5. Thanks atvusr thanked for this post.
  6. #264
    Rookie Array

    Join Date
    Nov 2009
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have a weird problem that started last night for me. I have been using NitoTV to play my AVI through my NAS using the Quicktime Player. Previously I was able to press the "Up" button on my remote and it would show the elapsed time of the program. Now, it shows the AppleTV Volume greyed out and it doesn't show anything else. I haven't changed any settings, but does anyone know how to get rid of this and have it function as before?

    Thanks in advance!

    - MrPink077

  7. #265
    Rookie Array

    Join Date
    Mar 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Bluetooth Keyboard & Mouse on AppleTV 3.0.2

    Quote Originally Posted by grufty View Post
    ATV OS 3.0.2 - My Bluetooth setup
    Thanks a lot for the hints!

    These are similar to the hints on wiki.awkwardtv.org in the How-To "Enable Bluetooth".

    I have my AppleTV updated from the Factory Restore to 3.0.2 and nitoTV 0.8.8 installed with an MacOSXUpdCombo10.4.9Intel.dmg as well as an valid Recovery.dmg in the ~/Documents directory.

    I've copied the files and directories:

    /usr/sbin/blued

    /System/Library/Extensions/IOBluetoothFamily.kext

    /System/Library/Extensions/IOBluetoothHIDDriver.kext

    /System/Library/Frameworks/IOBluetooth.framework

    /System/Library/Frameworks/IOBluetoothUI.framework

    /System/Library/CoreServices/Bluetooth Setup Assistant.app

    /System/Library/CoreServices/BluetoothUIServer.app

    /System/Library/CoreServices/bluetoothlauncher

    /System/Library/CoreServices/Menu Extras/Bluetooth.menu

    /System/Library/SystemProfiler/SPBluetoothReporter.spreporter

    /System/Library/SystemConfiguration/Bluetooth.bundle

    /System/Library/PreferencePanes/Bluetooth.prefPane

    only from the MacOSXUpdCombo10.4.9Intel.dmg and have set the appropriate owner & permissions.

    Copying these files only from an MacOSXUpdCombo10.4.10Intel.dmg works too, if this version was used with the nitoTV Smart Installer.

    Also, I copied the Keyboard.prefPane to /System/Library/PreferencePanes. It's not necessary, but it allows some settings and it shows the Battery level.

    I'm using an Sitecom CN-516 (v2-002) USB micro Bluetooth adapter (contains a Cambridge Silicon Radio chipset), which supports MacOS 10.3.9 and above.

    Now, Bluetooth is working on my AppleTV 3.0.2, so that I can use my Apple Wireless Mighty Mouse (Model A1197) with some Apps, e.g. Firefox 3.6.3, EyeTV 3.0.3, MPEG Streamclip 1.9.2 or Elgato Turbo.264 1.3. The Apple Wireless Keyboard (Aluminum, 2007 Model A1255, MB167*/A, 3 AA Batteries) might work too. I have not this Keyboard, so I cannot test it. I'm using VirtualKeyboard 3.7.1 instead.

    The only problem at the moment is, that the Bluetooth adapter will not recognized, when he was plugged-in before powering up the AppleTV. If the adapter is plugged-in after the system is completely loaded, he is recognized and works fine. Same problem with the Bluetooth adapter under Linux, but after a "sudo /etc/init.d/bluetooth start", the adapter is initialized and works fine with Linux. I don't know, whether there is a OS X 10.4 equivalent of the "/etc/init.d/bluetooth start" command.
    Last edited by atvusr; 04-25-2010 at 08:45 PM.


  8. #266
    Rookie Array

    Join Date
    Nov 2009
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Unhappy

    I don't know if anyone reads this anymore because no one seems to respond anymore.

    After the last release of NitoTV for ATV, which supposedly was a bug-fix update, has caused a NEW bug for me. I am currently using NitoTV to stream AVI (DIVX/XVID) files from my NAS (smb) on my gigabit network. Unfortunately I am getting random freezes (video and audio) that pauses on the screen but continues playing the file because when it resumes (5-7 seconds later) it is where it should be and I have missed quite a few seconds of the movie/show.

    Is anyone else having similar issues or knows why this is happening it would be greatly appreciated.

    - MrPink077

  9. #267
    Developer Array

    Join Date
    Jul 2008
    Posts
    471
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    29

    Default

    Quote Originally Posted by MrPink077 View Post
    I don't know if anyone reads this anymore because no one seems to respond anymore.

    After the last release of NitoTV for ATV, which supposedly was a bug-fix update, has caused a NEW bug for me. I am currently using NitoTV to stream AVI (DIVX/XVID) files from my NAS (smb) on my gigabit network. Unfortunately I am getting random freezes (video and audio) that pauses on the screen but continues playing the file because when it resumes (5-7 seconds later) it is where it should be and I have missed quite a few seconds of the movie/show.

    Is anyone else having similar issues or knows why this is happening it would be greatly appreciated.

    - MrPink077
    This has to be a correlation to the new release, not a causation from it. the new release literally has nothing changed in the core of nitoTV, just the smart installer and an smbfs.kext tar.gz package contained in the resources folder.

  10. #268
    Rookie Array

    Join Date
    Nov 2009
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by nitosoft View Post
    This has to be a correlation to the new release, not a causation from it. the new release literally has nothing changed in the core of nitoTV, just the smart installer and an smbfs.kext tar.gz package contained in the resources folder.
    Quote Originally Posted by MrPink077 View Post
    I have a weird problem that started last night for me. I have been using NitoTV to play my AVI through my NAS using the Quicktime Player. Previously I was able to press the "Up" button on my remote and it would show the elapsed time of the program. Now, it shows the AppleTV Volume greyed out and it doesn't show anything else. I haven't changed any settings, but does anyone know how to get rid of this and have it function as before?

    Thanks in advance!

    - MrPink077
    If there's no changes, and in addition I never got a response from my previous issue (The Up Button) do you suggest a reinstall/reload to see if this fixes the problems? Or is there something else I could do to fix this?

    - MrPink077

  11. #269
    Newbie Array

    Join Date
    Sep 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    could you please explain hpow to extract the files (for Bluetooth) from the .dmg file?

  12. #270
    Rookie Array

    Join Date
    Mar 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Bluetooth files

    Quote Originally Posted by rsalazar335 View Post
    How to extract the files (for Bluetooth) from the .dmg file
    1. Mount the MacOSXUpdCombo10.4.xIntel.dmg in Finder

    2. In the new window right click the MacOSXUpdCombo10.4.xIntel.pkg and select "Show Package Contents"

    3. Go into the Contents folder and copy the Archive.pax.gz to a temporary folder (ensure that enough space, approx. 1.5 GB, is available)

    4. For extraction use the Terminal command "sudo pax -r -z -f Archive.pax.gz" or use Pacifist

    5. Now you have access to the appropriate Bluetooth files

    For simple file handling you can use muCommander as well as Fugu. I had prepared a special Bluetooth.tar.gz file myself from the Bluetooth files, so that I have to transfer only one file to the ATV. Via ssh I can simply with "tar -zxf Bluetooth.tar.gz -C /" install the files.
    Last edited by atvusr; 05-15-2010 at 12:05 AM.


 

 

LinkBacks (?)

  1. 02-26-2010, 04:56 PM
  2. 07-21-2009, 03:49 PM
  3. 02-17-2009, 08:56 AM
  4. 02-17-2009, 05:14 AM

Similar Threads

  1. MacRumors: Potential First Released Photo Taken by an iPhone 5
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 09-07-2011, 05:10 PM
  2. MacNN: Windows Phone 7 released to manufacturing, gets tweaks
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 09-01-2010, 11:30 PM
  3. MacNN: Chinese iPhone gets tweaks to support WAPI standard
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 05-04-2010, 04:10 PM
  4. MacNN: Cocktail 4.6 adds Snow Leopard support, interface tweaks
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 11-10-2009, 05:40 AM
  5. nitoTV for leopard?
    By nitosoft in forum AppleTV 1
    Replies: 8
    Last Post: 02-12-2009, 07:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:03 AM.
twitter, follow us!