Results 1 to 7 of 7
Discuss Color Composite with OS 2.4? at the AppleTV 1 - Hackint0sh.org; Has anyone gotten this to work? Will it ever be possible?...
  1. #1
    Rookie Array

    Join Date
    Jul 2006
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Color Composite with OS 2.4?

    Has anyone gotten this to work? Will it ever be possible?



  2. #2
    Newbie Array

    Join Date
    Oct 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yeah, i got it to work (it's working right now, actually), but it's wonky as hell. you pretty much have to keep working through nitoTV, installing, adding it to rc.local using the kext manager, rebooting, wash rinse repeat, until it works. it usually takes me 2-3 times doing a combination of those things above to get it to stick - but that only lasts until you reboot. still, it's possible to do it if you don't mind the aggravation.

  3. #3
    Developer Array

    Join Date
    Jul 2008
    Posts
    471
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    29

    Default

    Quote Originally Posted by tajedaa View Post
    yeah, i got it to work (it's working right now, actually), but it's wonky as hell. you pretty much have to keep working through nitoTV, installing, adding it to rc.local using the kext manager, rebooting, wash rinse repeat, until it works. it usually takes me 2-3 times doing a combination of those things above to get it to stick - but that only lasts until you reboot. still, it's possible to do it if you don't mind the aggravation.
    there may be a way to get it working better through a startup item im not sure. through 2.4 it has always worked fine for me (having it in rc.local) the one time frame i had to use a tv routinely that only had component. i guess it could be more unpredictable based on the tv that is being used.

  4. #4
    Newbie Array

    Join Date
    Aug 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi, I have done the following steps to have the color composite on startup:

    preconditions: NitoTV with Turbo's Kextloader is installed.

    Download this Package and unzip: http://files.me.com/christoph.feil/hz2o3q
    (no password - if prompted for a password just enter anything)

    Copy them over
    scp -1 -r Composite frontrow@appletv.local:Composite

    Then Login on the appletv with
    ssh appletv.local
    sudo mount -uw /
    sudo chmod -R 755 /Users/frontrow/Composite/TVComposite.kext
    sudo chown -R root:wheel /Users/frontrow/Composite/TVComposite.kext
    sudo chown root:wheel /Users/frontrow/Composite/ATV_Color
    sudo chmod +x /Users/frontrow/Composite/ATV_Color
    sudo chown root:wheel /Users/frontrow/Composite/StartupParameters.plist
    sudo mkdir /System/Library/StartupItems/ATV_Color
    sudo mv /Users/frontrow/Composite/TVComposite.kext /System/Library/Extensions/TVComposite.kext
    sudo mv /Users/frontrow/Composite/ATV_Color /System/Library/StartupItems/ATV_Color
    sudo mv /Users/frontrow/Composite/StartupParameters.plist /System/Library/StartupItems/ATV_Color
    rm -r /Users/frontrow/Composite
    sudo reboot

    After the reboot I have selected 576i resolution! If it is still black/white just reboot again. Then it should work!
    Regards Chris

  5. #5
    Newbie Array

    Join Date
    Nov 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Then Login on the appletv with
    ssh appletv.local
    sudo mount -uw /
    sudo chmod -R 755 /Users/frontrow/Composite/TVComposite.kext
    sudo chown -R root:wheel /Users/frontrow/Composite/TVComposite.kext
    sudo chown root:wheel /Users/frontrow/Composite/ATV_Color
    sudo chmod +x /Users/frontrow/Composite/ATV_Color
    sudo chown root:wheel /Users/frontrow/Composite/StartupParameters.plist
    sudo mkdir /System/Library/StartupItems/ATV_Color
    sudo mv /Users/frontrow/Composite/TVComposite.kext /System/Library/Extensions/TVComposite.kext
    sudo mv /Users/frontrow/Composite/ATV_Color /System/Library/StartupItems/ATV_Color
    sudo mv /Users/frontrow/Composite/StartupParameters.plist /System/Library/StartupItems/ATV_Color
    rm -r /Users/frontrow/Composite
    sudo reboot

    Default
    Hi! I'm new to the forum also. I'm close to your type too!

    __________________
    Taux credit calcul empunt immobilier | Calcul emprunt immobilier taux pret | Taux calcul emprunt immobilier


  6. #6
    Newbie Array

    Join Date
    Nov 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by christophfe View Post
    Hi, I have done the following steps to have the color composite on startup:

    preconditions: NitoTV with Turbo's Kextloader is installed.

    Download this Package and unzip: http://files.me.com/christoph.feil/hz2o3q
    (no password - if prompted for a password just enter anything)

    Copy them over
    scp -1 -r Composite frontrow@appletv.local:Composite

    Then Login on the appletv with
    ssh appletv.local
    sudo mount -uw /
    sudo chmod -R 755 /Users/frontrow/Composite/TVComposite.kext
    sudo chown -R root:wheel /Users/frontrow/Composite/TVComposite.kext
    sudo chown root:wheel /Users/frontrow/Composite/ATV_Color
    sudo chmod +x /Users/frontrow/Composite/ATV_Color
    sudo chown root:wheel /Users/frontrow/Composite/StartupParameters.plist
    sudo mkdir /System/Library/StartupItems/ATV_Color
    sudo mv /Users/frontrow/Composite/TVComposite.kext /System/Library/Extensions/TVComposite.kext
    sudo mv /Users/frontrow/Composite/ATV_Color /System/Library/StartupItems/ATV_Color
    sudo mv /Users/frontrow/Composite/StartupParameters.plist /System/Library/StartupItems/ATV_Color
    rm -r /Users/frontrow/Composite
    sudo reboot

    After the reboot I have selected 576i resolution! If it is still black/white just reboot again. Then it should work!
    Regards Chris

    Hi Christophfe,

    Could you please put the files back up you linked to? I've had composite colour working for a long time until i accendentally hit OK to update to 2.4... I haven't been able to get it working since

    I'd like to try your approach please

    Thanks in advance!
    Mrs Often

  7. #7
    Newbie Array

    Join Date
    Nov 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Sorry! It downloaded without me seeing! Safari told me files were no longer available under the link, but the files had already sneaked into my downloads folder! Thanks!

 

 

Similar Threads

  1. Color Composite not working :-(
    By ATVn00b in forum AppleTV 1
    Replies: 3
    Last Post: 03-19-2010, 08:54 PM
  2. Composite cable hack?
    By truehybridx in forum General
    Replies: 0
    Last Post: 02-19-2010, 01:49 AM
  3. Replies: 2
    Last Post: 11-04-2009, 10:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:10 PM.
twitter, follow us!