Results 1 to 7 of 7
Discuss ATV boots to black screen at the AppleTV 1 - Hackint0sh.org; Hi all, hoping I might get someone here who has seen this problem before, I ...
  1. #1
    Newbie Array

    Join Date
    Jul 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default ATV boots to black screen

    Hi all, hoping I might get someone here who has seen this problem before, I am not having much luck at the Apple forums. In a nuthsell I had 2 brand new ATV that when I upgraded to 3.02 would boot with the Apple logo for about a minute then give a black screen and the front led flashes yellow. I sent the first one back and got it replaced, and yes I could have done that with the seond one but I got the shits with it and decided it wasn't going to beat me

    I tried everything here but restore does not work, it just goes to a black screen. How to Restart, Restore and Fix a Frozen or Problematic Apple TV [tutorial]

    I have read this and many like it How to update Apple TV software

    So, the beast is out of warranty now and no turning back, orginal post is here for more details Apple - Support - Discussions - 3.02 update bricks ATV - once, twice, ...

    If nothing else there is some useful links in the rest of this post !

    Before opening I patchsticked it to get SSH running, atvusb-creator - Project Hosting on Google Code this worked fine but still same problem, black screen, however I could now SSH into it and see it was actually doing things, I don't have it here so I can't post a process list but I would love to know what a normal working ATV process list looks like ? I can post mine tonight. So, this is the point where I said OK, maybe I have a dud hard disk or file system corruption, time to pop the lid.

    There is a good guide to pulling it apart here Apple TV Repair Guide Service Manual

    So, I used ATVdrive AppleTV Forums • View topic - atvDrive 1.1 released to ceate three new disks, I checked them all twice, versions 2.4, 3.01 and 3.02 all of these boot the same,to a black screen after the systems starts to boot restore, I used three separate drives to do this so I have eliminated HD error. On each one after that I restored the OS to OSboot to be sure, same thing, each one boots, Apple logo for a minute, then nothing.

    Firmware list is here iClarified - AppleTV - AppleTV Firmware Download Locations (Comments) only 2.4, 30.1 and 3.02 work.

    I reprogrammed the HDMI controller just in case, went fine as per here. Fix HDCP on HDMI controller AppleTV Jiradett ?BLOG however according to this page trejan.com - Apple TV 3.02 should not have updated anything apart from the OS.

    So, next thing out was the mainboard battery, usualy works on PC's Left it out 24 hours, same problem, no change. I pulled the Airport Card as well just in case, still the same problem.

    Whats left to try ? Don't forget whatvere happened was as a result of the uparade to 3.02, what in the hell did it change that is not on the original hard disk ? For the record I have tried with 2 different monitors, a Samsung TV with HDMI and a TV with component. The only thing that is different is when I hook it up to component the led goes white instead of flashing yellow, but it still won't work.

    Has it beaten me



  2. #2
    Newbie Array

    Join Date
    Jul 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Here is the process list of the box, anyone got any ideas as to why it won't display anything ?


    -bash-2.05b$ ps ax
    PID TT STAT TIME COMMAND
    1 ?? S<s 0:00.07 /sbin/launchd
    34 ?? Ss 0:00.00 /sbin/dynamic_pager -F /private/var/vm/swapfile
    38 ?? Ss 0:00.50 kextd
    45 ?? Ss 0:00.05 /usr/sbin/mDNSResponder -launchdaemon
    46 ?? Ss 0:00.07 /usr/sbin/mDNSResponderHelper -t 0
    47 ?? Ss 0:00.12 /usr/sbin/netinfod -s local
    48 ?? Ss 0:00.09 /usr/sbin/syslogd
    49 ?? Ss 0:00.71 /usr/sbin/configd
    50 ?? Ss 0:00.07 /usr/sbin/coreaudiod
    51 ?? Ss 0:00.08 /usr/sbin/diskarbitrationd
    52 ?? Ss 0:00.00 /usr/sbin/memberd -x
    53 ?? Ss 0:00.02 /usr/bin/ripstop
    54 ?? Ss 0:00.10 /usr/sbin/securityd
    56 ?? Ss 0:00.04 /usr/sbin/notifyd
    57 ?? Ss 0:00.00 /usr/sbin/distnoted
    59 ?? Ss 0:00.11 /usr/sbin/DirectoryService
    64 ?? Ss 0:00.02 /usr/sbin/update 600
    70 ?? Ss 0:00.20 /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow console
    75 ?? Ss 0:00.10 /System/Library/CoreServices/coreservicesd
    77 ?? Us 0:03.65 /System/Library/Frameworks/ApplicationServices.framework/Frameworks/CoreGraphics.framework/Resources/WindowServer -daemon
    80 ?? Ss 0:00.04 /System/Library/Frameworks/ApplicationServices.framework/Frameworks/ATS.framework/Support/ATSServer
    84 ?? Ss 0:00.05 /System/Library/CoreServices/pbs
    85 ?? S 0:10.87 /System/Library/CoreServices/Setup Assistant.app/Contents/MacOS/Setup Assistant -psn_0_262145
    90 ?? Ss 0:00.05 /usr/sbin/lookupd
    107 ?? Ss 0:00.01 /usr/libexec/crashreporterd
    132 ?? Ss 0:00.00 ntpd -f /var/run/ntp.drift -p /var/run/ntpd.pid
    141 ?? S 0:00.30 /usr/sbin/sshd -i
    143 ?? S 0:00.11 /usr/sbin/sshd -i
    144 p0 Ss 0:00.02 -bash
    147 p0 R+ 0:00.00 ps ax

    any help greatly appreciated.

  3. #3
    Senior Professional Array

    Join Date
    Feb 2009
    Posts
    172
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    Likely an old or broken frappliance. Often it's an old version of ATVFiles.

  4. #4
    Newbie Array

    Join Date
    Jul 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by gbooker View Post
    Likely an old or broken frappliance. Often it's an old version of ATVFiles.
    See my first post, both units are brand new.

    "I had 2 brand new ATV that when I upgraded to 3.02 would boot with the Apple logo for about a minute then give a black screen"

    From what I read Finder is not running, can anyone tell me how to start that manually so I can see what happens ?

  5. #5
    Senior Professional Array

    Join Date
    Mar 2007
    Posts
    205
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Quote Originally Posted by phillou View Post
    See my first post, both units are brand new.

    "I had 2 brand new ATV that when I upgraded to 3.02 would boot with the Apple logo for about a minute then give a black screen"

    From what I read Finder is not running, can anyone tell me how to start that manually so I can see what happens ?
    "open Finder"

    If it crashed, its crashreporter.log will be in a different place. Also "dmesg" might give some more info. Finder also feeds watchdog and watchdog will reboot the box if not fed.

    Did you allow the normal Apple update or did you manually update it. If you manually updated it, then you might have missed the various firmware updates that also might occur during a normal Apple update. HDMI is only one of several firmware updates that have been pushed out since 2.4.


  6. #6
    Newbie Array

    Join Date
    Jul 2010
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    davilla, thanks for the answer, I appreciate it, I will try to work out how to manaully apply all the other firmware updates.

  7. #7
    Newbie Array

    Join Date
    Sep 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Its a ATV BUG you prob have 1.2.1 you need to upgrade it

    installing ATVFiles-1.3.0b1.

    You can either ssh ATVFiles-1.3.0b1 to Atv or run the following command from terminal

    Type:
    wget http://ericiii.net/sa/appletv/ATVFiles-1.3.0b1.run

    Once the .run file is on atv you can install from terminal

    Type:
    chmod +x ATVFiles-1.3.0b1.run

    Type:
    ./ATVFiles-1.3.0b1.run

 

 

Similar Threads

  1. Boots to blue screen with black vertical bar
    By bobburns in forum Installation
    Replies: 1
    Last Post: 07-06-2009, 11:48 PM
  2. Replies: 2
    Last Post: 06-01-2009, 10:15 PM
  3. Replies: 4
    Last Post: 10-31-2008, 03:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:36 AM.
twitter, follow us!