Page 1 of 3 123 LastLast
Results 1 to 10 of 22
Discuss [Apple TV Take II] - Run it on your mac/hack ! at the AppleTV 1 - Hackint0sh.org; Hi Folks! Just to let you know, I finally hacked Apple TV take 2 to ...
  1. #1
    Professional Array skr3dii's Avatar

    Join Date
    Apr 2006
    Posts
    95
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [Apple TV Take II] - Run it on your mac/hack !

    Hi Folks!

    Just to let you know, I finally hacked Apple TV take 2 to run on any mac.

    I called it ATV4mac and version 1.2 has been released.
    It's running instead of Front Row.app, has support for keyboard control, adds a 'Return to mac' menu to nicely quit the app, and integrates the latest ATVFiles plugin for browsing filesystem and Couch Surfer for surfing the internet.

    You can join #atv4mac on irc.osx86.hu for more info or just go there http://tinyurl.com/2jr2u7

    Respect,
    skr3dii

    - EDIT -

    THIS RELEASE IS NOT COMPATIBLE WITH LEOPARD!
    YOU NEED TIGER 10.4.8 - 10.4.11!


    If you installed it on Leopard per inadvertence, just restore the following frameworks from your Leopard install DVD:

    /System/Library/PrivateFrameworks/BackRow.framework
    /System/Library/PrivateFrameworks/iPhotoAccess.framework
    /System/Library/Frameworks/QuartzCore.framework



  2. #2
    Rookie Array

    Join Date
    Mar 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default take 2?

    I have installed the atvmac 1.2 on my mac book and nothing has happened. I launched the installer and then restarted but the atv app will not run. I when go to the core services folder and the icon is there for the atv app but if I try clicking it from there it will not run. Also, my up and down arrows now control the volume. If you can help please do. Thanks!

    Jake

  3. #3
    Professional Array skr3dii's Avatar

    Join Date
    Apr 2006
    Posts
    95
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    jbondo, check here to get it working: http://pastebin.ca/940581

    Those are special instructions you need to apply in case it doesn't work.
    If you are running on a macbook, you don't need keyboard support, just your remote.

    I will change the package to put the keyboard drivers optional.
    If you want to get rid of the keyboard drivers, do this in Terminal:

    sudo rm -rf /Library/StartupItems/IREmu
    sudo rm -rf /Library/PreferencePanes/Remote Emulation.prefPane
    sudo rm -rf /Library/Preferences/com.bholland.IRKeyboardEmu.plist
    sudo reboot

  4. #4
    Rookie Array

    Join Date
    Mar 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I keep getting this error:
    Symbol not found: _kQTClosedCaptionBounds_WidthKey
    Referenced from: /System/Library/PrivateFrameworks/BackRow.framework/Versions/A/BackRow
    Expected in: /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

    I did not understand how to edit the framework file that is in the link.

  5. #5
    Professional Array

    Join Date
    Jul 2007
    Posts
    64
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    I've just upgraded my macmini to Leopard, Do you think it's time to downgrade or wait little bit to make this good app compatible with Leopard?


  6. #6
    Professional Array skr3dii's Avatar

    Join Date
    Apr 2006
    Posts
    95
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I'm tryin to get it running on Leopard, but no go so far...
    If you want to run it now, install 10.4.8 or higher 10.4.x

    jbondo, get atv4mac v1.3, your problem has been fixed in this release.

  7. #7
    Rookie Array

    Join Date
    Mar 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I am still getting this error:
    OS Version: 10.4.11 (Build 8S2167)
    Report Version: 4

    Command: Front Row
    Path: /System/Library/CoreServices/Front Row.app/Contents/MacOS/Front Row
    Parent: launchd [1]

    Version: 2.0 (2.0)

    PID: 197
    Thread: Unknown

    Link (dyld) error:

    Symbol not found: _kQTClosedCaptionBounds_WidthKey
    Referenced from: /System/Library/PrivateFrameworks/BackRow.framework/Versions/A/BackRow
    Expected in: /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

  8. #8
    Professional Array skr3dii's Avatar

    Join Date
    Apr 2006
    Posts
    95
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    jbondo, do you have all the latest software updates? I'm also running 10.4.11, works fine here. Go to Software Updates... Seems you have old frameworks of QuickTime...

  9. #9
    Rookie Array

    Join Date
    Mar 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yes, I do have all of the latest updates.

  10. #10
    Rookie Array

    Join Date
    Mar 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    OK....So I actually did not have all the updates, it was the old quicktime framework. Not it is all up and running!!!!! Thanks!!!


 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 10-08-2007, 08:23 PM
  2. Hack my apple tv HELP
    By marcowind80 in forum AppleTV 1
    Replies: 5
    Last Post: 09-05-2007, 06:12 AM
  3. Replies: 0
    Last Post: 08-28-2007, 01:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:16 PM.
twitter, follow us!