Results 1 to 7 of 7
Discuss Apple TV 3.0.2 no surround at the AppleTV 1 - Hackint0sh.org; I just upgraded my original ATV to 3.0.2 and did the whole patching again. I'm ...
  1. #1
    Rookie Array

    Join Date
    Sep 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Apple TV 3.0.2 no surround

    I just upgraded my original ATV to 3.0.2 and did the whole patching again.

    I'm having trouble getting surround to work.

    I enable it in ATVFiles and NitoTV but get no sound from AC3 xvid files.
    If I press the up button on the remote to increase volume I get noise.

    I remember for 2.1 this was well known problem, at that time Nito and ATVFiles played the sound track but only noise.
    There was something you had to do, replace some files or something. I cannot remember.

    Can anyone help me get AC3 sound back?

    I cannot access the awkward forum where the solution was posted back then

    Regards,

    Mads



  2. #2
    Senior Professional Array

    Join Date
    Feb 2009
    Posts
    172
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    Are you saying that you increase the volume and you start to hear noise getting louder and louder? The volume level must be unmodified for AC3 to work. Try playback in Sapphire to see if it plays AC3 correctly.

  3. #3
    Rookie Array

    Join Date
    Sep 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I get the helicopter sound only in ATVFiles when pressing the volume up/down button.

    I get not sound what so ever in NitoTV when the xvid files has AC3 sound and I have passthrough enabled

  4. #4
    Senior Professional Array

    Join Date
    Feb 2009
    Posts
    172
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    It likely doesn't work with your receiver then.

  5. #5
    Rookie Array

    Join Date
    Sep 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I had never used Sapphire, but gave it a shot.

    It plays my files with AC3 beautifully

    What the heck is going on? Where is the treatment of files different in Sapphire than NitoTV and ATVFiles?

    Don't they use the same framework to play files?

    This is weird

    Anyone got a clue?


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by mazebr View Post
    I had never used Sapphire, but gave it a shot.

    It plays my files with AC3 beautifully

    What the heck is going on? Where is the treatment of files different in Sapphire than NitoTV and ATVFiles?

    Don't they use the same framework to play files?
    I thought that they both used CommonMediaFramework - if you look here:

    CMP Framework - AwkwardTV it says that they only share the same framework for DVDPlayback.

    So playing back xvid, mkv, mv4 doesn't guarantee the same playback framework. The strange thing is that I read here nito blog Blog Archive nitoTV 0.8.6 + Common Media Player framework that when using mplayer for playback, passthrough works for other container formats also.

    Can either Gbooker or Nito chime in with a more accurate answer please.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Senior Professional Array

    Join Date
    Feb 2009
    Posts
    172
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    CMP is not currently used for Quicktime based playback, but it will eventually be moved into there.

    There are quite a few steps to ensure that AC3 passthrough is setup properly, and Sapphire goes through all of these steps. Last I looked at the source, I thought ATVFiles was as well. I cannot answer fully for mplayer, but to that end make sure you have the latest version of Nito (and Sapphire since at the time I write this it has a newer version of CMP than nito). I have tested AC3 passthrough in Nito using mplayer and gotten it to work.

    Also, you may want to try playing something in Sapphire, and then if the passthrough works, try the other plugins without rebooting your ATV. Some of the setup that Sapphire uses is not reverted after it is done since there is no need. Perhaps that may be the missing step.

 

 

Similar Threads

  1. MacNN: Netflix adding Dolby 5.1 surround to PS3, more devices
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 10-14-2010, 02:50 PM
  2. MacNN: ASUS intros Cine5 compact surround PC speaker bar
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 03-10-2010, 06:00 PM
  3. MacNN: Fraunhofer details MPEG Surround for handhelds
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 02-09-2010, 10:30 PM
  4. MacNN: Netflix may offer 1080p streaming, 5.1 surround
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 02-09-2010, 01:00 AM
  5. Replies: 0
    Last Post: 10-23-2008, 04:40 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:20 AM.
twitter, follow us!